WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] All the script turns to italics and I can't switch it back! (9 posts)

  1. ingmarz
    Member
    Posted 8 years ago #

    Hello Word Press Wizards!

    I put up a post the other day to my Word Press site, http://www.ingmarlee.com, and the whole site has switched to italics and I can't switch it back! Any solutions?

    Help will be most appreciated!

    Cheers, Ingmar (ingmarz@gmail.com)

  2. Jonathan Landrum
    Member
    Posted 8 years ago #

    Well, I found this at post-67:

    <em></em><em></em><em></em><em></em><em></em>
    <em></em><em></em><em></em><em></em><em></em>
    <em></em>...

    Are you using the visual rich editor? Also, do you have the option "WordPress should correct invalidly nested XHTML automatically" selected?

  3. Doodlebee
    Member
    Posted 8 years ago #

    The problem is right here:

    <p lang="en-CA">
    <font size="3">
    <em>Pangong Lake, 130 kms long, straddles the Ladakh/Tibet border</em>
    </font>
    <em>
    <font size="3">(Photo, Ingmar Lee)
    <a href="image URL here">(more…)</a>

    You have no closing </em> tag after that caption for the picture - so everything after it is in italics. "Everything after it" happens to be the entire page. (Why *do* you have text styling around an image, anyway? Just curious.)

    Common mistake -people just don't close a tag - should be the first thing you check! ;)

  4. ladydelaluna
    Member
    Posted 8 years ago #

    </font><em><font size="3">

    Okay, this kind of stuff shouldn't even be IN there... you're apparently copying and pasting into the editor, and that's not a good idea, as it will ALWAYS insert junk code like this...

  5. ingmarz
    Member
    Posted 8 years ago #

    Thanks so much! I'm an html zero, but I'll go try doodlebee's suggestion and add the "" to the end of my phot caption.

    ladydelaluna says I shouldn't cut-and-paste to the site, but I write my stuff in a word processor first. That's no good??

    I appreciate all the help!

    Cheers, Ingmar

  6. bran8464
    Member
    Posted 8 years ago #

    Use a simple text editor like notepad or textpad. I had that problem too, it was a nightmare when I used Word.

  7. ingmarz
    Member
    Posted 8 years ago #

    Hi again, Well, I tried inserting "" after the caption, but it didn't change anything. The italics are still there.

    Also, I don't know if I'm using ".. the visual rich editor?.." How can I find out?

    Also, I don't know if I have the option "WordPress should correct invalidly nested XHTML automatically" selected.

    Where can I find this?

    Thanks again!

    Cheers, Ingmar

  8. moshu
    Member
    Posted 8 years ago #

    Everything is in your admin panel of the tool that you are using. It is always advisable to study it for a while before jumping into it.
    1. Wysiwyg - in 2 places:
    admin > Options > Writing (for the whole site)
    admin > Users > Your profile: left bottom, for yourself
    2. XTHML nesting... Options > Writing

  9. ingmarz
    Member
    Posted 8 years ago #

    Thanks everyone, I've stripped all the <EM>'s out now and that's solved the problem!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.