WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] All subsites "missing" after update to WP 3.2/BP 1.5 (4 posts)

  1. KatieBen
    Member
    Posted 2 years ago #

    I updated to WP 3.2.1, and BP 1.5 - and wasn't able to update my network using the auto script. When I try to access any of my network sites - such as http://andrewcohen.bkgiveawayfreebooks.com - the site isn't accessible.

    Here's the error I get:

    Warning! Problem updating http://andrewcohen.bkgiveawayfreebooks.com. Your server may not be able to connect to sites running on it. Error message: Couldn't resolve host 'andrewcohen.bkgiveawayfreebooks.com'

    I've regenerated permalinks on the main site - other than that I'm not quite sure what to do. Any ideas or pointers?

  2. dgilmour
    Member
    Posted 2 years ago #

    Did you follow the manual upgrade instructions here: http://codex.wordpress.org/Updating_WordPress?

    In particular, could you have deleted the .htaccess file in your WordPress root?

  3. The subdomain sites work on wildcards, not permalinks. ;) Those are for subfolders.

    Try going to bkgiveawayfreebooks.com/wp-admin/upgrade.php - what happens?

    Check and see if wildcard dns stuff got messed up at the same time. The upgrade cannot change this, it may just be a coincidence.

    make sure your wp-config file still has multisite defines in it.

  4. KatieBen
    Member
    Posted 2 years ago #

    Thanks guys - Andrea_r, it was exactly a wildcard dns problem.

    This is my dev site, and while I'd set up wildcards on my live site, I'd forgotten I needed to do so with the dev site. I finally thought to add that last night, and though it didn't work right away (propagation time of some sort?), everything's working just fine this morning. Hooray! (:

    Thanks! (:

Topic Closed

This topic has been closed to new replies.

About this Topic