WordPress.org

Ready to get started?Download WordPress

Forums

all permalinks suddenly dead 404s - akismet to blame?? (12 posts)

  1. ashsimmonds
    Member
    Posted 7 years ago #

    hello, yesterday i enabled akismet due to spammage (*sigh*) and today ALL of my permalinks don't werk. :(

    this is bad, i've just gone and updated a bunch of places on my latest stuff, and all i get is 404s.

    even worse, it's the standard hosting 404, not my wordpress 404.

    could akismet have done this? it's the only thing that's changed in the last 24 hours.

  2. Pravin Paratey
    Member
    Posted 7 years ago #

    did you delete your .htaccess file by accident? It's present in the folder that you installed wordpress in.

  3. amintorres
    Member
    Posted 7 years ago #

    I am actually having the same issue,
    I installed the nishita theme and none of my links are working, i get 404 exept for the home link:
    http://www.amintorres.com/theblog
    in my case, i have a windows server and i know i need to change my permalins structure to something else, just dont know what that is. plus how to make it work if my server doesnt know how to deal with .htaccess files?
    some help please?

  4. tommygeorge
    Member
    Posted 7 years ago #

    I'm not positive how to fix your individual problems, but I would at least like to mention the following:

    I was updating some things recently and downloaded (to view) my ".htaccess" file, and re-uploaded it. Since windows was being naughty (and perhaps something I screwed up) something changed the name or the contents of the file (I don't remember which).

    I fixed my WordPress install by doing the following:

    1. Use your FTP program to delete the existing '.htaccess' file.
    2. If your FTP program supports it, create a new '.htaccess' file. If not: create an empty file with any name, upload it, and use the FTP program's Rename option to rename the file to '.htaccess'.
    3. Most FTP programs will allow you change "permissions" on the files. Change the "permissions" to '0666' (I think). Or if your options are Text based: you want "owner" and "group" to both be able to WRITE to the file. That should normally work.
    4. Now, login to your admin panel via yourblog.com/wp-login.php or yourblog.com/blog-directory/wp-login.php - whichever applies to you.
    5. Once in the Admin panel, go to OPTIONS and click PERMALINKS. Fill in the desired options, or use the defaults, and Save/Update your changes. Since WordPress was given permission to write to the '.htaccess' file this should automatically fix your problem.

    Hope that helps.

  5. amintorres
    Member
    Posted 7 years ago #

    ok, so i never seen the so called .htaccess file.
    Ican simply create a file with any text editor right?
    what is the extension to this file?
    or is it a folder?
    a*

  6. tommygeorge
    Member
    Posted 7 years ago #

    In your case (on a windows server) I'm not positive. I have seen windows based servers set up to use HTACCESS, although I'm sure it "just depends".

    The '.htaccess' file has no extension: rather, it has no name, and 'htaccess' is the extension - it's literally named "dot H T access" - that's why Windows systems sometimes mess up those files, because they expect every file to be [somename][dot][someextension].

    You should check with your host (online docs? 800 number?) and ask if they support HTACCESS files.

    Perhaps someone else could help you better, and I hope they do,

    tommygeorge

  7. tommygeorge
    Member
    Posted 7 years ago #

    And yes, I'm sorry - the '.htacces' is a text based file that can be created.

  8. amintorres
    Member
    Posted 7 years ago #

    tommygeorge

    they dont support the .htacces file, i know that for a fact.
    actually a support person told me they dont. he was expecting that the person who created nishita would tell me what they could do on their end -my server support- to be able to help me.
    I contacted the nishita creator and he said he cant help me and that the problem wasnt theme related instead it is wordpress related.
    i communicated all this to my server people via a support ticket and havent heard from them. :(

  9. tommygeorge
    Member
    Posted 7 years ago #

    Interesting.

    I noticed that the links containing the "/index.php/blah" type reference work correctly, but your Pages (about/contact/etc...) don't.

    I don't mean to ask a dumb question, but have you tried setting your Permalink style to "Default" and saving?

    Just to be sure, clear your browser history/cache afterwords, close it out, and start from scratch.

    It's not as "search engine friendly" as some would like it to be, but it would at least be fully functional until you found another solution.

    UPDATE:
    Have you seen this?
    http://www.bradbice.com/index.php/2005/08/03/fixing-wordpress-permalinks/

  10. amintorres
    Member
    Posted 7 years ago #

    sorry for the late response.
    yes, i did tryied all that and didnt work, but now it is working see:
    http://www.amintorres.com/theblog,
    Brajeshwar, sent me instructions on how to fix the problem, i am not sure i can share the solution to the problem though, he said that he is currently working on a new realease of the theme and that it wasnt availeable - and i think he just did it for me cause i have been dealing with this for the last few days- I am going to ask him though and see if he lets me share the changes he sent me.
    if he does, i will come edit this post with the solution.
    sorry for now, just dont want to get my self in trouble.
    a*

  11. tommygeorge
    Member
    Posted 7 years ago #

    Nice of you to consider other people's property rights. Hopefully you'll come back and share, as I'm sure having a solution posted would be much appreciated by the community.

    Glad you got it working.

  12. amintorres
    Member
    Posted 7 years ago #

    Hi tommygeorge..
    Brajeshwar just sent me an email saying it was ok with him to post the solution.
    So, to solve the permalink issue, for the nishita theme in a windows server, the following worked for me:

    1- under Options >Permalinks check, "Custom, specify below " and insert this in the custom permalink field: /index.php/%year%/%postname%/
    -then save.

    2 - find your header.php file and replace whatever it is in between <!-- BEGIN #nav --> "replace here" <!-- END #nav -->
    with the following code:

    <!-- BEGIN #nav -->
    <ul id="nav">
    <li id="nav-home">/"
    title="<?php bloginfo('name'); ?>">Home

    <?php wp_list_pages('title_li=');?>
    <li id="nav-default">"
    title="Entries RSS Feed">RSS Feed

    <!-- END #nav -->

    Now, that worked for me. again this applies for the nishita theme only, not sure this will fix the same problem with other themes... but it might not hurt to try.
    if you want to go back to re-use one of the others themes such as the default theme, make sure you check default for the permalink structure for the other themes to work.

    hope this makes sense.
    a*

Topic Closed

This topic has been closed to new replies.

About this Topic