WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] All pages loading my home page (6 posts)

  1. ryanrice
    Member
    Posted 1 year ago #

    Please help!

    I recently added a new theme. I noticed that I was getting a "Page Not found" at the top of the page as well as a 404 on the page. After doing some research I found where someone said to change the 'permalink' to a 'default' which worked for the page, however, none of my other pages will load. When I click the on one of my other pages, I can see the permalink in the URL pops up, then redirects me back to the home page.

    Here is the link to the site: http://ryanricefineart.com

    Thank you,
    Ryan

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. ryanrice
    Member
    Posted 1 year ago #

    Hello esmi thank you for your response.

    - I have deactivated all of my plugins.

    -when I switch to the Twenty Eleven theme, it does the same thing, where the link pops up in the URL and then goes back to the home page.

    -I have not tried resetting the plugins folder, I will give that a shot.

    Thank you!

  4. gholem
    Member
    Posted 1 year ago #

    You should also have a look at your .htaccess file.

    Found something about that here.

  5. ryanrice
    Member
    Posted 1 year ago #

    Thank you gholem, I had tried that link, still nothing.

  6. ryanrice
    Member
    Posted 1 year ago #

    I think that I got it figured out and I hope that this is able to help anyone else out there that is stuck and nothing seems to work.

    I went into my settings and I noticed that my wordpress URL was http://mydomain.com/wp but my "Site URL" was http://mysite.com, with no /wp. As soon as I added the /wp to my site url everything is up and working!! I hope that this helps others out there save some time.

    Click on 'Settings' (General), you will see
    "WordPress Address (URL) ->http://yourdomain.com/wp and below it
    "Site Address (URL)"->http://youdomain.com/wp

    Thank you again to 'esmi' and 'gholem' and the wordpress community!

Topic Closed

This topic has been closed to new replies.

About this Topic