WordPress.org

Ready to get started?Download WordPress

Forums

All pages keep redirecting to my static front page!! HELP! (8 posts)

  1. d3viant
    Member
    Posted 4 years ago #

    Hey all... I'm a relative newbie to WordPress, and after having created a site and wanting it to go live, I find myself pulling my hair out, being unable to view ANYTHING except the initial splash/front page.

    I've got a basic index.html page in my root folder (WordPress is also installed in the root) and it displays fine (at http://skinbonestone.com ). The image on that page is supposed to link through to the main site (http://skinbonestone.com/?page_id=2), but it's just getting redirected back again. (Make sense?) I haven't fiddled with the .htaccess file at all. I'm pretty sure it's something painfully obvious and simple, yet I've been overlooking it. Changing to a different theme doesn't seem to help. And if I simply remove the index.html file from the root, I get the following error:

    You don't have permission to access / on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    There is SOMETHING that seems to be always trying to redirect my site to the index page, but I can't work out what. Any ideas PLEASE?! I'll love you forever!...

    Chris.

  2. Brandon Allen
    Member
    Posted 4 years ago #

    You might want to open up your .htaccess file, and look for this line:

    DirectoryIndex index.html

    If it's there, try replacing it with this:

    DirectoryIndex index.html index.php

    Depending on how you've installed WP, this may not work. The easiest thing to do is make a custom page template for your WP theme, and then set this as your homepage in the Dashboard options.

  3. d3viant
    Member
    Posted 4 years ago #

    Hmm, that damned .htaccess file. I'll have to work out how to even find the thing first (I believe GoDaddy.com doesn't make it easy?), and then I'll try your little trick...

    Cheers mate!

  4. d3viant
    Member
    Posted 4 years ago #

    Okay, I'm struggling to find that htaccess file. Perhaps GoDaddy doesn't allow fiddling with it? Any ideas on where/how to find it?

  5. MichaelH
    Member
    Posted 4 years ago #

    You can't expect WordPress to work properly if you have an index.html file and the index.php for WordPress in the same folder. Suggestion: delete the index.html and use the static frontpage option of WordPress.

  6. Alternatively, put WP in a subdirectory. Though MichaelH's suggestion is good too.

    FYI, there's some controversy about splash pages in general, and how they work against SEO. Just something to keep in mind. It's less applicable, IMO, for artsy sites, but still something to consider.

  7. d3viant
    Member
    Posted 4 years ago #

    MichaelH: I don't have an index.php and index.html file in the same folder. I only have index.html in my root. If I remove this file (by simply renaming it to index2.html, for instance) then the site breaks completely, and all I get is this error:
    ------
    Forbidden

    You don't have permission to access / on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    ----
    What's that all about?!

    I do have an index.php in my theme's wp-content folder, but that's a standard one that I haven't tinkered with...

    Cheers
    C.

  8. d3viant
    Member
    Posted 4 years ago #

    Ipstenu: I'm thinking about doing what you suggest - but it means rebuilding the entire site again, doesn't it? This would be my third time!... *sigh*

Topic Closed

This topic has been closed to new replies.

About this Topic