WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] All pages in site periodically come up blank (4 posts)

  1. celebitchy
    Member
    Posted 7 years ago #

    All pages in my site, including the admin section, are periodically coming up blank.

    http://www.celebitchy.com

    Some times the main page will appear blank, but reappear on a page re-load. Other times the entire WordPress site including the admin section is rendered blank and does not reappear until the server is rebooted.

    If I am working in the admin section when it happens the browser will prompt me to download post.php when I try to save a post.

    I know this is a WordPress or PHP issue because the server is up and running fine when this happens, and non-Wordpress pages still appear without a problem.

    There are two recent plugins which could be causing this problem, but both have been deactivated and it is still happening: wp-cache, and sociable

    I deactivated sociable and deleted it.

    I read that wp-cache can cause blank pages with PHP 5, and I applied the fix listed here:
    http://www.bloggingblog.net/wp-cache-and-the-blank-page-problem/

    The site is running PHP 4.4.2, though, so I'm not sure if that's the issue.

    That didn't seem to fix the problem so I deactivated wp-cache yesterday but did not delete it.

    The blank pages are still coming up periodically.

    My question is: could wp-cache still be causing the problem even though it is deactivated? Should I delete it entirely and/or is there a cache it creates somewhere that I should delete too?

    Is there a different potential culprit?

    Thanks for your help with this, and I hope this is the right place to ask.

  2. Abhisheksharma
    Member
    Posted 7 years ago #

    Hello Celebitchy, what version of WordPress are you using? Can you please use version 2.0.4?

  3. celebitchy
    Member
    Posted 7 years ago #

    It says 2.0.4 at the bottom of the main admin page, so that must be the version I'm using.

  4. celebitchy
    Member
    Posted 7 years ago #

    Someone at my hosting company installed wp-cache for me, and I just realized that I had never successfully applied the fix because I did not have permission rights to overwrite the file.

    I read on another thread that wp-cache can cause these problems even when it's deactivated, so I've added the fix for now and hope that solves it. I'll close this issue, and thanks for your help.

Topic Closed

This topic has been closed to new replies.

About this Topic