WordPress.org

Ready to get started?Download WordPress

Forums

All pages give a 404 after migration (11 posts)

  1. Dethredic
    Member
    Posted 3 years ago #

    Here is what I did

    exported my database
    copied my wordpress folder from 1 server to another
    imported the database on the new server
    changed the site address from http://xxx to http://yyy/wordpress in the general settings menu

    I can still edit all my pages in the control panel, and when I use the search bar on my site it still finds all the pages, but when I click any page link (even from the editor) I get a 404. Not the wordpress "opps not found" error, my server's 404.

    What did I do wrong?

  2. jeezyo
    Member
    Posted 3 years ago #

    Take a look at your permalinks settings.

  3. Dethredic
    Member
    Posted 3 years ago #

    My peralinks are set to:
    http://yyy/wordpress/2011/07/04/sample-post/

    which is what I want

  4. You probably just need to hit save again and it will recreate the .htaccess file.

  5. Dethredic
    Member
    Posted 3 years ago #

    I deleted my .htaccess file and then hit save again and it was re-created.

    I still get the same 404 errors though

  6. jeezyo
    Member
    Posted 3 years ago #

    What Christine meant, was to just hit save on your permalinks settings. It regenerates them and that often solves this problem.

    Edit: I guess thats what you did, i read it too fast.

  7. Dethredic
    Member
    Posted 3 years ago #

    Yes, I hit save on the permalinks settings.

  8. BSK
    Member
    Posted 2 years ago #

    SAME problem here. tried re-saving permalink settings & re-creating & neither works.

    one thing i noticed is that if i change to default my pages load, but anything other than default i get 404s.

  9. Andrew
    Member
    Posted 2 years ago #

    Hitting 'Save' in the permalinks settings seemed to work for me, but for some reason just one page in particular is still giving me a 404.

    So I just manually changed the permalink for that page and now the page is visible.
    Not really sure why but there it is..

  10. SirAdams
    Member
    Posted 2 years ago #

    I ran into the same problem when I moved the index files. I definitely know it is caused by the permalink titles. I set all of them back to default and it seems to work fine again. (I recommend you find a plugin that renames your links, personally)

    Took a lot of detective work and very good to know for future reference...

  11. alxvallejo
    Member
    Posted 2 years ago #

    me too, I hate to see this thread unresolved.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.