WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] All pages except blog frontpage redirecting to site home (9 posts)

  1. I have just installed a new blog on a client's server (Network Solutions) and have run into a big problem.

    All pages - categories, individual posts, monthly archives, static pages - except for the blog front page, are redirecting to the homepage.

    To see it in effect, paste nominingue.com/blog into your browser.

    You'll see that this one page looks fine, but click March 2011 or a post name, for example, and you'll see that it redirects to the homepage (which looks all messed up because it's not using absolute paths right now, but I'm not concerned with that.)

    Server stats:

    PHP 5.2.13 / API CGI/FastCGI
    MySQL 5.0.89

    Here is what I've tried:

    • verified that the .htaccess file has correct rewrite rules
    • turned off all plug-ins - same result
    • applied default Twenty Ten theme - same result
    • turned off pretty permalinks and reverted back to the /?p=123 structure - same result
    • tried different permalink structure - same result
    • Googled for Network Solutions-specific issues, but nothing applied
    • tried adding a php.ini file at the site root with cgi.fix_pathinfo = 1
      cgi.force_redirect = 0
    • deleted and re-uploaded theme folder

    This is a fresh (manual) install of WP 3.1 and the same site is working perfectly fine on my test server (my own dedicated server.)

    Thanks for any ideas!

  2. Just to follow up on this - I've discovered that every URL that doesn't exist as an actual PHP file - example nominingue.com/adsfasdfdsf - is redirecting to the homepage, as well as dynamically generated blog URLs like the archives, categories, individual posts - example: nominingue.com/2011/03/

    Tried turning off the site's custom 404 error - same result

    Tried removing my WP theme's custom 404.php - same result

    I put in a ticket yesterday with Network Solutions but no reply yet.

    p.s. apologies for not using full URLs that are clickable, but I don't want search engines spidering them.

  3. Jeremy Clarke
    Member
    Posted 3 years ago #

    Well you covered all the easy ground already, good work!

    One thing I always do is explicitly define the SITEURL and friends URL constants in wp-config, you can find them (there's two) in the codex article about wp config. I doubt it will fix your problem but it just might, as they avoid any issues related to the URL settings in the database. They are also not dangerous which is nice, just have to remember that if the URL settings in wp-admin are ever greyed out it's because of the constants in wp-config.

    After that I'd go back to your domain config at your registrar and make sure that is configured properly. Check that its not forwarded or masked or something like that. You should also create some actual directories and files alongside WordPress to see if they work, if no directories work then it's not a wp problem and you can force network solutions to fix it.

    Good luck :)

  4. Thanks so much for the ideas, Jeremy. *Really* appreciated.

    Created test directory and file outside WordPress - worked.

    Added define('WP_SITEURL', 'http://www.mydomain.com/blog'); to config.php - but that alone didn't change anything. I'm looking for the second constant you mentioned but not finding the word "friend" on this page: http://codex.wordpress.org/Editing_wp-config.php

    Any ideas where I might find it? Thanks.

  5. Jeremy Clarke
    Member
    Posted 3 years ago #

    define('WP_HOME', 'http://example.com/wordpress');

    It was right after the WP_SITEURL one. Sorry for not stating it specifically was using my magic tablet ;)

  6. Thanks - I just actually guessed it might be that one and tried adding it too - still no change. :-(

    Also checked the registrar's domain configuration and don't see any masking/forwarding or anything unusual.

  7. Jeremy Clarke
    Member
    Posted 3 years ago #

    Hmm, so I don't know what the right test would be, but you want to make sure that .htaccess - in general - is working on the server. Look up htaccess and find a simple redirect example and try inserting that and see if it has the right effect or not. .htaccess can be disabled in several places in the apache configuration so that could be the problem.

    Just to be clear, you should also be working on this with a totally default install of WP with no plugins or themes and you should try re-uploading all the core files in case that is part of the problem.

    P.S. Network Solutions have always been the worst in my experience. It may be worth considering a migration rather than dealing with this issue further ;)

  8. Thanks again, Jeremy.

    Just got a call from a NetSol tech and the issue was fixed by doing the following two things:

    1. Changed the site URL to http://www.nominingue.com/blog (from http://www.nominingue.com)

    2. Changed .htaccess rewrite rules (which had been automatically generated) from:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    to:

    RewriteEngine On
    RewriteBase /blog/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]

    I still don't understand why this was working fine on my test server without these changes, but I am very glad it's finally working.

    Thanks again for all your suggestions, truly appreciated.

  9. Jeremy Clarke
    Member
    Posted 3 years ago #

    Man that should NOT be required! NetSol FAIL.

    Good luck to you and your client, may your site run well despite bad hosting decisions :)

Topic Closed

This topic has been closed to new replies.

About this Topic