WordPress.org

Ready to get started?Download WordPress

Forums

Custom Post Type UI
[resolved] All pages display index.php instead of page content (5 posts)

  1. lord_dev
    Member
    Posted 1 year ago #

    Hello

    When the Custom Post Type UI plugin is enabled all of my pages display index.php's content (currently index.php is displaying blog posts).

    Very strange problem.

    When I disable CPT, refresh permalinks, then everything starts working again as normal.

    Anyone know a fix for this bug? I presume its something to do with CPT's permalink functionality.

    Thanks in advance

    http://wordpress.org/extend/plugins/custom-post-type-ui/

  2. lord_dev
    Member
    Posted 1 year ago #

    PS. I have also tried disabling all the plugins and just using the CPT UI and it still does not work.

    I have also tried switching themes to a clean slate Twenty Ten but it still does not work.

    This is a clean WordPress install with the latest version too.

    I'm stumped.

    Any ideas?

  3. lord_dev
    Member
    Posted 1 year ago #

    Fixed the problem!

    Quite simple really - 1 of my taxonomies was called 'year' which caused a bug in the system due to WordPress Posts reserving the 'year' taxonomy for their blogging system.

    So just avoid any default taxonomies that WordPress may use, and you should avoid this problem.

    Hope this helps someone

  4. codex73
    Member
    Posted 1 year ago #

    Thanks for sharing this tip lord_dev

  5. Michael Beckwith
    Member
    Plugin Author

    Posted 1 year ago #

    Sounds like notices/warnings about reserved post types and any taxonomies would be a benefit

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic