WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] All pages but the homepage throw 404 errors (22 posts)

  1. hairedesigner
    Member
    Posted 1 year ago #

    All pages on my site, aside from the homepage, are giving me 404 errors. The pages definitely exist and the permalink structure is correct.

    The site is nomascantina.com/newsite/

    I've been troubleshooting this issue quite a bit and have tried creating an .htaccess file with:

    # BEGIN WordPress
    <IfModule mod_rewrite.so>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    I've changed the file permissions on directories to 755 and files to 644. I have a sneaking suspicion that someone else that was working on the site may have been manipulating the file permissions.

    There's nothing unusual in the apache error logs.

    The pages were loading just fine yesterday and I've done nothing to the site since.

    Any assistance would be greatly appreciated.

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Check with your hosts that mod_rewrite is running on your server.

  3. Deepak Rajpal
    Member
    Posted 1 year ago #

    Can you try once saving permalink structure again to default. Check if it works:

    Admin > Settings > Permalinks

    If it works, swith it to desired permalink option and check it again.

  4. cinqueorange
    Member
    Posted 1 year ago #

    Hi everyone,

    I'm having a similar issue and not that technically savvy. Can anyone offer any solutions?
    My site is http://www.kickmag.net/

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    @cinqueorange: It is impolite to interrupt another poster's ongoing thread with a question of your own. It causes significant problems for the forum's volunteers and prevents us from being able to track issues by topic. Please post your own topic.

  6. hairedesigner
    Member
    Posted 1 year ago #

    @deepak that worked! Can you explain why that solved the issue?

  7. cinqueorange
    Member
    Posted 1 year ago #

    So sorry Esmi, I'm not used to posting to the forums but I have taken note for future reference!

  8. Deepak Rajpal
    Member
    Posted 1 year ago #

    @hairedesigner
    I am glad it worked for you.
    Reason: .htaccess might not be proper, but switching permalinks rebuild it. Not sure, but always works for me. :)

    @cinqueorange Have you tried that?

  9. cinqueorange
    Member
    Posted 1 year ago #

    Hi Deepak,

    Again I apologize to everyone for not knowing the proper posting etiquette. But I wanted people to know that Bluehost is kind of suspect. I had this problem with my site and contacted Bluehost and they told me it was a WordPress issue and to go to the forums. When I checked my site later in the day the problem was gone and I didn't change anything! Thank you for your response.

  10. esmi
    Forum Moderator
    Posted 1 year ago #

    We're glad to hear that the problem has been resolved for you.

    Many hosts are currently experiencing problems due to mass attacks. Bluehost may be one of them.

  11. aycrew
    Member
    Posted 1 year ago #

    been pulling my hair trying to resolve same issue..
    changing permalink settings fixed immediately, thanks to all contributors on the topic..

  12. cinqueorange
    Member
    Posted 1 year ago #

    Thank you for letting me know that Esmi.

  13. Roger M
    Member
    Posted 11 months ago #

    I contacted Bluehost and they sent me the following:
    "It looks like you needed to update your site location inside your database. I've done that for you, and now you need to update you permalinks inside of WordPress, so that WordPress can re-learn where your information is stored on the server. You can read about Permalinks here:

    http://codex.wordpress.org/Using_Permalinks

    All you need to do is go to the Permalinks section in your WordPress dahsboard under Settings. You just need to resave the existing settings; no change is needed, and everything will update."

    What I don't know is will I experience the same problem again tomorrow. Or, will I have to contact Bluehost to fix the problem. Perhaps Bluehost and WordPress might work together to fix this issue.

  14. defyapathy
    Member
    Posted 7 months ago #

    Not to interrupt the post, but I'm having the same problem! I'm using dot5hosting.com I've followed the steps above and no dice. site=www.mainstreetconstruction.net/dev

  15. esmi
    Forum Moderator
    Posted 7 months ago #

    @defyapathy: If you require assistance then, as per the Forum Welcome, please post your own topic.

  16. defyapathy
    Member
    Posted 7 months ago #

    But it's the same issue.

  17. Swayze
    Member
    Posted 7 months ago #

    @defyapathy: I think we don't understand the complications and difficulties that the moderators have with trying to get the answers and tips to different members in a single topic post. When you start your own topic they can direct their comments with an easier flow.

  18. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    Exactly! Not to mention that this thread references WP3.5.1 and is already marked resolved.

    @defyapathy - you might want to read this part of the forum welcome:

    Unless you are using the same version of WordPress on the same physical server hosted by the same hosts with the same plugins, theme & configurations as the original poster, do not post in someone else's thread. Start your own topic.

  19. IsaacGreen
    Member
    Posted 6 months ago #

    Sorry Guys for jumping in. I have same issue about permalinks and posts not found. When I change to default structure, everything is fine but when I switch to /%postname%/, i get error viewing my posts. Please guys, help me. Thanks a million.

  20. Norman C Hoffmann
    Member
    Posted 4 months ago #

    I removed my custom permalink structure /%post_id%/%postname%/ and saved my permalinks as the default structure /?p=123.

    Then I saved my permalinks as day and name structure /%year%/%monthnum%/%day%/%postname%/.

    Then I saved my permalinks as my custom structure again /%post_id%/%postname%/.

    This series of steps seems to work though I am not sure why this happened as I was trying to uplaod a background image and suddenly all my pages and posts all returned 404 errors.

    Anyways following the steps above seems to have 'reset' whatever went wrong. I hope, lol. :-)

    Thanks for the advice. WP Version 3.8.1

  21. jlamarca
    Member
    Posted 3 months ago #

    I am having this exact same problem now. I've tried everything I can find listed here, as well as elsewhere. NOTHING works. The only way my blog works is to set Permalinks to Default but as I've now had the blog up and running for quite some time, I don't want to do that. Help!

  22. Andrew
    Forum Moderator
    Posted 3 months ago #

    The Exact Same Problem was resolved 11 months ago by deepak. If that solution has not worked for you then you do not have the Exact Same Problem.

    Create your own thread here: http://wordpress.org/support/forum/how-to-and-troubleshooting#postform

Topic Closed

This topic has been closed to new replies.

About this Topic