WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] All local images dissappeared (9 posts)

  1. DavidBrugge
    Member
    Posted 1 year ago #

    http://sachimemphis.com

    An associate was trying to install W3 Total Cache, got turned around and deactivated and uninstalled it. Since then ALL images stored in the Media Library or Theme directory fail to appear. The URLs are correct, and the files still exist in the Uploads Directory and individual Theme Directories.

    The thumbnails of the files do not appear in the media library. Clicking on the edit button will bring them up correctly, but re-saving them has no effect.

    When changing (and even installing new) themes the previews shows only type, no images. Trying to change the header image calls up the crop tool, but no image appears beneath it.

    I have renamed my plugin directory, switched to Twelve-Ten, and changed the permalinks to generate a new .htaccess, all to no avail.

    I deleted the wp-includes and wp-access and replaced them with fresh copies, and overwrite the core files in wp-content.

    Using the Web-Developer plugin in Firefox, the source code calls the images correctly and the missing images are listed in the "Missing Images" tab. Clicking on the links on that tab takes me to the correct image confirming that the files and url are correct, and that they will appear in the browser when wp is taken out of the equation.

  2. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Deactivate all plugins, and replace the theme with a freshly downloaded copy of Twenty Eleven and see if the problem persists.

  3. DavidBrugge
    Member
    Posted 1 year ago #

    Thanks for the suggestion, but that's one of the first things I did.

  4. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Can you try posting an image with all the plugins turned off and after switching over to Twenty Eleven?

  5. Rev. Voodoo
    Volunteer Moderator
    Posted 1 year ago #

    and overwrite the core files in wp-content

    Not 100% sure what this means - did you delete any files w3tc creates in the wp-content directory?

    I believe aside from deactivating w3tc, you need to ensure a clean .htaccess, and remove the cache file in wp-content

  6. DavidBrugge
    Member
    Posted 1 year ago #

    Humm. I thought that I had posted a reply, but I don't see it. Here goes again.

    Can you try posting an image with all the plugins turned off and after switching over to Twenty Eleven?

    http://davidbrugge.com/images/sachi_screen_grab.jpg

    Not 100% sure what this means - did you delete any files w3tc creates in the wp-content directory?

    I deleted the wp-access and wp-include directories and uploaded fresh copies. I opened a fresh copy of wp-content on my desktop and uploaded the files to the wp-content folder with the transfer set to "overwrite" so that non-core files would be preserved.

    I believe aside from deactivating w3tc, you need to ensure a clean .htaccess, and remove the cache file in wp-content

    I checked the .htaccess and it is empty. I did a search in the wp-content folder for and W3 or cache related files.
    There is a php file in the root of the wp-content folder for the W3 plugin's settings. I renamed the extension to .xphp to make it inoperable. All of the settings in THAT file indicate that the browser cache is turned off.
    http://davidbrugge.com/images/ftp_screen_grab.jpg

  7. DavidBrugge
    Member
    Posted 1 year ago #

    On a friends advice, I looked in the wp-config.php file and found the line:

    define('COOKIE_DOMAIN', 'www.sachimemphis.com'); // Added by W3 Total Cache

    It was the only line that I could see different from the original.

    I deleted the line and cleared my browser cache, but no improvement.

  8. Rev. Voodoo
    Volunteer Moderator
    Posted 1 year ago #

    Looks like this has cleared up for you? I see your images now

  9. DavidBrugge
    Member
    Posted 1 year ago #

    Yes, all cleared. It appears that the plugin adds a rewrite_MOD that redirects image requests to a different directory on the server. Uninstalling I guess, removed all but the redirect. My hosting provider actually tracked this one down for me.

    Thanks to all for your contributions

Topic Closed

This topic has been closed to new replies.

About this Topic