WordPress.org

Ready to get started?Download WordPress

Forums

All links on site pointing to dashboard (10 posts)

  1. masey
    Member
    Posted 8 years ago #

    I have no idea, but for some reason I start a new page and when I go to preview the page and click on the link I get redirected (?) to the dashboard. I sense that it's got something to do with not referencing the index.php file. That is, I start a new page called 'Photography'. When I preview my site, I click on the Photography tab and I get sent to the dashboard. The URL is this:

    http://www.mysite.com/wordpress/?page_id=3

    when I think it should be:

    http://www.mysite.com/wordpress/index.php?page_id=3

    Has anyone else had this problem before or know a solution?

    Secondly, when I'm in Dashboard and I click on the 'View Site' link in the top left I again, just get sent to the Dashboard front page.

  2. Would you mind posting your blog URL?

  3. masey
    Member
    Posted 8 years ago #

    I've done basically nothing to it so far but upload the default files, but here it is:

    http://www.masey.com.au/testbed/index.php

  4. Hm, how very odd. All of the links are going to your login page (which would be the Dashboard if I was logged in). Worse yet, http://www.masey.com.au/testbed/ also goes to the login page.

    Does this also happen with the Default Theme? And, do you have any .htaccess files in /testbed/ and your root directory?

  5. masey
    Member
    Posted 8 years ago #

    I don't use any .htaccess files at all and the problem still surfaces with the default theme selected...

  6. In Options/General, please make sure that the two URL values are set to:

    http://www.masey.com.au/testbed/

  7. masey
    Member
    Posted 8 years ago #

    They already are...

  8. Hm. In that case, I suggest that you download WordPress again and try a separate test installation. See if it does the same thing.

  9. masey
    Member
    Posted 8 years ago #

    Just did a FRESH install with a newly downloaded install file and the same problem is persisting. :(

    Am I at least on the right track thinking that:

    http://www.mysite.com/wordpress/?page_id=3

    should be:

    http://www.mysite.com/wordpress/index.php?page_id=3

  10. You are somewhat on the right track, because it does work with index.php added in, but that index.php chunk hasn't been required since WordPress hit v1.5.

    This is very confusing. I suggest that you contact your hosting provider, and ask if they have index.php setup to be recognized as a normal index file. Also, ask them if they have had any problems with WordPress in the past.

Topic Closed

This topic has been closed to new replies.

About this Topic