WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] All links are root URL (5 posts)

  1. annmariedwyer
    Member
    Posted 1 year ago #

    I have read the last few days and have seen nothing on this.

    On any page, all links on the page lead back to the page.

    If you click on a Gravatar link: back to the post/page.
    If you click on a link in the post: back to the post/page.
    If you click on any link in the widgets: back to the post/page.
    Click on the header: It reloads the page.

    It even applies to links inside widgets. e.g. If you click on "Show results" inside a PollDaddy poll, it reload the page. If you click on the WP nav bar, menus, theme icon in footer, wordpress.org link in footer...all of them reload the page.

    The only links not returning to the page are the non-Automattic share buttons and the widgets generated by offsite API (Facebook, Google, Twitter). Every link generated inside the shell is reverting back to the post/page.

    http://mommasmoneymatters.com
    Theme: Comet by Frostpress
    Last update: JetPack

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - resetting your custom permalinks back to the default setting via Settings -> Permalinks. If this works, then review Using_Permalinks before setting a custom permalink structure back up again.

  3. annmariedwyer
    Member
    Posted 1 year ago #

    Yes, I tried deactivating all of them, and it is still not working.

    I have no inactive plugins.

    This is not just permalinks. It is every single link on the page. The last/next post, outside URL coded into the posts, the share buttons by JetPack, all photos.

    The only links not reloading the page are the offsite API.

  4. Rev. Voodoo
    Volunteer Moderator
    Posted 1 year ago #

    Seems like something is overlaying your entire site.

    I don't see it in the source code, but when I use a browser developer tool, your body calss has

    <body class="home blog" jQuery17206499768376050172="2" onload="">

    added to it, and no matter where I click, the entire screen gets selected

  5. annmariedwyer
    Member
    Posted 1 year ago #

    I found it. It was a plugin which did not eject from the cache. I have contacted the developer. It was Quick Page/Post Redirect. They have a known issue which should have been fixed when I dropped their jQuery and cleared out the site cache.

    Here's hoping it works. Whatever it was degraded over the course of the last two days or was a direct conflict after the update from JetPack. The huge issue for me now is Automattic has removed its 301 from the WordPress.com site and is generating traffic at the old blog.

    These are the days I hate blogging.

    Thank you for all of your help.

Topic Closed

This topic has been closed to new replies.

About this Topic