WordPress.org

Ready to get started?Download WordPress

Forums

all internal (wp) links are broken (4 posts)

  1. ericsoco
    Member
    Posted 5 years ago #

    sorry to double-post, but i realized that the thread i was posting in ( http://wordpress.org/support/topic/201589 ) was marked as resolved.

    here's the scoop:

    just started my blog:
    http://words.transmote.com/

    every link seems to point to the correct address, but resolves immediately back to the homepage. can't dig into a post, can't view About, can't leave comments. yikes.

    tried switching themes to a few different options (including WP default), and having the same problem regardless of theme.

    my permalinks settings are on "default" -- i tried changing them, "Save Changes", changing them back to default and saving again -- no luck.

    i'm running WP Super Cache; tried clearing the cache after every change -- still no luck.

    also, i tried disabling WP Super Cache -- still have the same problem.

    some more info:

    changing permalinks to anything other than Default causes my site to display a 404 with *any* link, even the homepage / base URL ( http://words.transmote.com/wp/ ).

    i installed AskApache RewriteRules Viewer 3.0, which shows me this:

    > Not using permalinks
    > Writable .htaccess file found
    > mod_rewrite found
    > Not using pathinfo style index permalinks
    > Not using mod_rewrite permalinks

    hm....
    help? thanks!

  2. stvwlf
    Member
    Posted 5 years ago #

    take a look at what is IN your htaccess file - something is redirecting everything back to root URL

  3. ericsoco
    Member
    Posted 5 years ago #

    ok, figured it out. this thread helped:

    http://wordpress.org/support/topic/184246?replies=2

    with a link to:

    http://www.tamba2.org.uk/wordpress/site-url/

    the problem had to do with the fact that, in the General page in Settings, i set the WordPress address to a different URL than the Blog address. the WP address was pointed at the root, and the blog address at root/wp (where my wordpress install is).

    i guess what was happening was that everything happening in /wp was redirecting back to root, when then redirected to my blog homepage.

    didn't figure this out until i stumbled across those settings, changed them, and *totally* broke my site (couldn't even login because of a redirect). just followed the phpmyadmin instructions in the link above to get things working.

  4. ericsoco
    Member
    Posted 5 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic