WordPress.org

Ready to get started?Download WordPress

Forums

All in One SEO Pack
[resolved] All in one SEO pack - problem with General Settings (22 posts)

  1. fspberlin
    Member
    Posted 1 year ago #

    I am using AIOSP together with WPML. Since it is possible now to have multiple keywords and descriptions for multiple homepages, I added these indiviually on the language homepages.

    Now I wanted to delete the texts in Home Title and Home Description in the General Settings. But after clicking "Update Options" the texts keep showing up under Home Title and Home Description. I can't delete them.

    What can I do?

    http://wordpress.org/extend/plugins/all-in-one-seo-pack/

  2. lovediving
    Member
    Posted 1 year ago #

    I have similar problem but my problem is i change home description and click update options but nothing change when you search on Google.

    What to do why its error ???

  3. fspberlin
    Member
    Posted 1 year ago #

    Cause the update first only applies on your website. In terms of Google it needs some time for their crawlers to revisit your website and check for updates.

    But I still cannot update the Home Title and Home Descirption. Any help?

  4. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    fspberlin,

    I tested this and can't reproduce your issue; what are your settings under Settings -> Reading under where it says "Front Page displays"?

  5. fspberlin
    Member
    Posted 1 year ago #

    It says "A static page" and the page selected is the correct static home page for all languages.

  6. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    fspberlin,

    And what are the other settings? Do you just have a Front Page set, or a Posts page as well? I trust they aren't the same page. Do your settings update properly in the All in One SEO Pack Pro General Settings? If your issue is just with Google, then I'd suggest using Google Webmaster Tools to get an idea of what they see when they crawl your site; also realize that these things do not update instantly.

  7. fspberlin
    Member
    Posted 1 year ago #

    No, I don't have a problem with Google! I have a problem with your plugin! I am trying to change/delete the texts within "Home Title" and "Home Description" in the "General Settings". And when I click "Update Options" the old texts reappear there.

  8. fspberlin
    Member
    Posted 1 year ago #

    Ok I figured something out. I changed the texts in "Home Title" and "Home Description". After clicking on "Update Options" the old texts were there again, then I pressed F5 and the new updated texts appeared. But this somehow doesn't work when I want to delete the texts in total...

  9. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    fspberlin,

    Is your issue with what shows up in the source of your page, or is it an issue with actually updating the Home Title and Description boxes themselves? That is to say, if you delete the text in those boxes and click Update Options, do the boxes stay empty, or do they still have text in them?

  10. fspberlin
    Member
    Posted 1 year ago #

    Hi Peter

    thanks for your reply.

    What I want:
    I want translated titles & description for die different home pages of each language (using WPML). Therefore I inserted the translation on each page.

    Whats the issue:
    I initially inserted a Home Title and Home Description in the boxes at General Settings. I want to delete them now, as each home page should have its own title and description.

    And yes, when I delete the texts for Home Title and Description in the boxes, the texts reappear after clicking "Update Options".

  11. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, that's a bug that I haven't encountered or been able to reproduce. One thing you can try if you don't mind re-entering your other settings for All in One SEO Pack is to reset the options on the General Settings screen, that should clear those fields as well. But if you do this, take note of what your other settings are on that screen, so you can enter them in again.

  12. fspberlin
    Member
    Posted 1 year ago #

    I am afraid, but guess what's happening when I click on reset? The texts ramain in the boxes! I also tried another browser/computer, deleted cookies & cache and even downgraded your plugin to see whether its a new issue, but in vain.

    For now I have an interim solution by simply inserting a space character, clicking Update Options and pressing F5. This keeps the space character in the box, but I cannot leave it blank, though...

  13. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    fspberlin,

    Yeah, that shouldn't even be possible. Resetting the options should zero out all the settings and return them to their defaults, and the default for those fields is to be blank. This could be due to a conflict with your theme or with another plugin, though I can't imagine what would be causing this. Try using a different web browser?

  14. fspberlin
    Member
    Posted 1 year ago #

    Ok, I suppose its a WPML bug. But I found a solution now to display different titles & descriptions on the language homepages. WPML is solving this by string translations. Didn't know about this...

    many thanks for your replies and help anyway...

  15. jasonred
    Member
    Posted 11 months ago #

    I am having the same issue but have not found a solution.
    when I leave the hoe title and home description blank and hit update options, it reappears the way it was. same is true if I reset general settings to default.

    I am also using WPML

    I would be interested to know the fix found by fspberlin as I have spend 30 min trying to figure this out.

  16. fspberlin
    Member
    Posted 11 months ago #

    I found a solution. This works via String-Translations.

    In WP go to WPML >> String-Translation
    Here you have e.g. "[aioseop_options]aiosp_home_keywords". Click on Translation on the right and you can add keywords for all languages...

  17. kimbo6365
    Member
    Posted 9 months ago #

    I'm having the same problem as fspberlin.

    I customized the fields under Home Page Settings and saved. Then when I clear the fields and save again, the old values still appear. The only way to completely clear the fields again is to restore the plugin default settings.

    Additionally, when I make any change in the plugin and save, I first have to refresh the page before the new, updated information is shown. I also use the WPML plugin, so it's possible it interferes with the All in One SEO Pack.

  18. fspberlin
    Member
    Posted 9 months ago #

    You have to go to the WPML menu >> String translation. Here you can enter home title and description :-)

  19. Konstantin Ryabenko
    Member
    Posted 8 months ago #

    Hi, everyone.

    I also use AIOSP together with WPML.
    I'm having other issue:
    When I try to deactivate AIOSP I lose access to my site's admin panel, 'wp-admin' just doesn't open. The only way to restore access to admin panel - rename folders 'sitepress-multilingual-cms' and 'all-in-one-seo-pack'.
    Both plugins deactivate, but I can activate WPML only after activating AIOSP, otherwise 'wp-admin' again doesn't open.

    Help me, please. How can I deactivate AIOSP?

    Thanks...

  20. Peter Baylies
    Member
    Plugin Author

    Posted 8 months ago #

    Konstantin,

    It sounds like you're having a different problem, you should open a new thread. This may be an issue with the PHP memory limit on your server, but it could possibly be due to any number of things.

  21. Konstantin Ryabenko
    Member
    Posted 8 months ago #

    Peter,

    You're right. My hoster demand memory limit (64Mb for one process). I checked my web-server's log file and found this string:
    [Sat Dec 14 18:38:05 2013] [error] PHP Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 536 bytes) in /public_html/wp-includes/pomo/streams.php on line 66

    After long Googling this trouble I found solution:
    Add "define('WP_MEMORY_LIMIT', '128M');" in "wp-config.php"

    After this I could deactivate AIOSP without problem.
    But I don't understand how this solution allows overcome my hoster's demand.

    Peter, what do you mean when you wrote about "open a new thread". Can you tell me more details about this?

    Thanks...

  22. lasharipk
    Member
    Posted 5 months ago #

    I am using All in one seo pack pro in my site (http://pashtorung.com) but I face the same error, I also consult with hosting service provider but no vain, so how can I resolve this issue?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic