WordPress.org

Ready to get started?Download WordPress

Forums

All in One SEO Pack
[resolved] All in One SEO Meta tags not showing up (16 posts)

  1. rlichtenstein
    Member
    Posted 10 months ago #

    Hi,
    I've been looking at the source code for the homepage of my website and after I put keywords and a description in with the All in One SEO pack, I cannot see that meta data coming up in the source code. Can somebody tell me why this might be and how to fix it?

    Thanks,
    Ruthie

    http://wordpress.org/plugins/all-in-one-seo-pack/

  2. mcolm83
    Member
    Posted 10 months ago #

    I am experiencing the same thing on all pages. The META description is not showing up.

  3. Peter Baylies
    Member
    Plugin Author

    Posted 9 months ago #

    rlichtenstein,

    What are your settings in Settings -> Reading for this? Is your home page set up to display a static page, or latest posts?

    mcolm83,

    It sounds like you have a different problem, so you might want to start a new thread here. Also check to see if you might be having a conflict with another plugin or with your theme.

  4. rlichtenstein
    Member
    Posted 9 months ago #

    It's on all pages for me, too, not just the homepage, so your advice to mcolm83 probably applies. How should I proceed from here? Would deactivating the other plugins show me if that's where the conflict is, or would I have to delete them and reinstall them? Is there something specific I can look for in the theme code?

  5. Peter Baylies
    Member
    Plugin Author

    Posted 9 months ago #

    rlichtenstein,

    Yes, deactivating plugins to test this is fine. For testing the theme, you can switch to one of the default themes that come with WordPress such as Twenty Eleven or Twenty Twelve. If this is a live site, you might want to take a backup and/or test on a development site as well, if you have one.

  6. rlichtenstein
    Member
    Posted 9 months ago #

    Yep, I deactivated the Akismet plugin and All in One SEO started working. Then I updated and reactivated Akismet and it's still working. Glad it turned out to be an easy fix. Thanks so much!

  7. rlichtenstein
    Member
    Posted 9 months ago #

    Oh actually this only solves the problem for the meta description. The keywords still aren't working, or rather, only the first out of several is showing up.

  8. Peter Baylies
    Member
    Plugin Author

    Posted 9 months ago #

    rlichtenstein,

    That's strange behavior. Are you on a singular page, and are they separated by commas? On the plus side, meta keywords aren't that useful these days.

  9. rlichtenstein
    Member
    Posted 9 months ago #

    They are separated by commas. What do you mean by a singular page? This information is only for the homepage if that what you mean.

  10. Peter Baylies
    Member
    Plugin Author

    Posted 9 months ago #

    If it's the "Home Keywords (comma separated)" setting, then yes, those should all show up on the home page.

  11. rlichtenstein
    Member
    Posted 9 months ago #

    I was working from the homepage itself, but after your comments I went to General Settings under All in One SEO on the dashboard and did it in there, too. It's still producing the same results, though.

  12. Peter Baylies
    Member
    Plugin Author

    Posted 9 months ago #

    As I asked before, what are your settings in Settings -> Reading for this? Is your home page set up to display a static page, or latest posts?

  13. rlichtenstein
    Member
    Posted 9 months ago #

    Static page

  14. Peter Baylies
    Member
    Plugin Author

    Posted 9 months ago #

    rlichtenstein,

    Ok, that should be set on the Home Keywords only; if those are showing up on the front page, then this is the expected behavior.

  15. sivaprasad.bevara
    Member
    Posted 7 months ago #

    Hi Peter,
    I have the same issue. Meta tags are not visible in the Home as well as other pages. Only title is generating.
    Please help

  16. Peter Baylies
    Member
    Plugin Author

    Posted 7 months ago #

    Hi sivaprasad,

    Please start a new discussion thread for your problem; in that thread, also let me know what version of WordPress you're using, and what your website is, so I can take a look at it.

Reply

You must log in to post.

About this Plugin

About this Topic