WordPress.org

Ready to get started?Download WordPress

Forums

all import attempts return white screen (blank screen of death) (24 posts)

  1. kristinachilds
    Member
    Posted 2 years ago #

    i've spent a couple days trolling this forum as well as google and it seems many people have the same problem but no solutions have been found. making yet another post just in case anyone has an answer.

    i am trying to import a movable type blog into a fresh install of wp 3.2.1 (initially was on 3.2 and upgraded in hopes it would solve the problem). i have tried the standard movable type/typepad importer as well as the movable type backup importer. all is well until submit the file i wish to import. on the screen directly after the import button i get nothing but a blank screen. i have enabled ALL error reporting and still get no errors, just a blank screen. here's what i've done so far:

    Movable type export file: 483k

    wordpress settings:
    <?php error_reporting(E_ALL); ini_set('display_errors', 1);
    define('WP_MEMORY_LIMIT', '64M');
    define('WPLANG', 'en-US');
    define('WP_DEBUG', true);

    wordpress plugins: none except the import plugin

    php 5.2.8 settings:
    memory: 2GB
    error_reporting: 6143 (all)
    upload max filesize: 80MB

    i'm pulling my hair out. this blog has posts back to 2006 so re-entering them is simply not an option. is there ANY way to get this blog migrated??

  2. kristinachilds
    Member
    Posted 2 years ago #

    just read another post that mentioned it was sending to the wrong URL so i'll add this: clicking the import button returns this page: http://mysite.com/blog/wp-admin/admin.php?step=1

  3. kristinachilds
    Member
    Posted 2 years ago #

    just for kicks i took the advice from this post and manually changed the url to:
    http://mysite.com/blog/wp-admin/import.php?import=movable-type-backup-importer&step=1

    which returned a dashboard panel that simply said "are you sure you want to do this?" a start, i guess, but there was no actionable object on the page, just text.

  4. kristinachilds
    Member
    Posted 2 years ago #

    update: on a whim i decided to export an existing wp blog and try to import that. it worked, so it must be something specifically related to the MT import (or export)

  5. kristinachilds
    Member
    Posted 2 years ago #

    beuller?

    i decided to try it with an older version of wordpress (since the plugins "have not been tested" with the newer versions) but now i have a whole new problem. wordpress 3 installed just fine but wordpress 2 keeps getting a 500 error at step 2 of the install process. i can't even log in... can't set a password and even setting it directly in the database doesn't work. each time i try to log in, wordpress overwrites the password i've set in the database to some crazy long string of random numbers.

    help!

  6. kristinachilds
    Member
    Posted 2 years ago #

    anyone know how to fix this install problem? i feel like i'm talking to a wall here.

    i've tried every solution i could find on the net and none worked. when i click the button to install, it gives an error 500 message. however, it DOES write the tables to the database, including user, email and all that jazz. it just doesn't create a working password and no password change methods seem to work.

    when i take the password WP wrote to the user account, it *still* says the password isn't correct. once i got stuck in a loop where it would "accept" the password but return me to the login screen as though i hadn't input anything at all.

    i'm running out of ideas here.

  7. tomaltman
    Member
    Posted 2 years ago #

    This seems like the issue you are having:

    Importing a Huge Number of Posts
    If you don't have administrative control of the server (root access), then Importing a Large Number of Posts has relevant links and help. This should be helpful if your import process dies before completing the import. The php installation on your webserver may have a low script timeout, or if the file is too large, your server may run out of memory. This is what's happening when you see a blank, white page, during the import, or your browser says "Done" before WordPress says "Have Fun!" after the import.

    If you do have root access to the server, edit php.ini and increase the maximum memory setting. For a large import (e.g. 5MB), increase the script memory to 100MBs and restart apache. When the import is complete, restore the limit to what it was originally and restart apache again.

    I found this near the middle of this codex page.

    Hope it helps. :)

  8. kristinachilds
    Member
    Posted 2 years ago #

    this doesn't apply. the file i'm uploading is under 500k and the php settings are already set to file size upload of 80MB with memory of 2000MB. i have a hard time believing it's a memory or file size maximum problem.

    unless i'm missing something?

  9. Japh
    Member
    Posted 2 years ago #

    Have you checked in the error logs on your server? They may shed some light.

    Obviously an error is occurring, but for some reason isn't displaying, but it's more than likely still being output in an error log file somewhere. Try checking the php error log, and also the apache error log file.

  10. kristinachilds
    Member
    Posted 2 years ago #

    i'm trying to get my hands on it. i know where it is on the server but due to the way it's set up i can't navigate to it and will have to rdp into the server itself... still trying to get the info to do that. not having that error log available to me is causing a lot of problems.

  11. kristinachilds
    Member
    Posted 2 years ago #

    so... got into the php error log and all the file contained was this

    {\rtf1}

    riiiiiiiight. i rdp'd directly into our dedicated server and did an advanced find for any document with the word "error" in the file name and there wasn't a single file modified since march.

    i'm about to throw this stupid computer out the window.

  12. tomaltman
    Member
    Posted 2 years ago #

    There are always errors in there...you are sure its the correct file?

    Also - don't throw that computer out...you need to throw out the server! :)

  13. kristinachilds
    Member
    Posted 2 years ago #

    well, when i run phpinfo that's the file it says for the error log... i would *assume* it's the correct file but given the circumstances no, i'm not sure

  14. tomaltman
    Member
    Posted 2 years ago #

    Is this your server or are you hosting? In other words - can you get help?

  15. Japh
    Member
    Posted 2 years ago #

    Is your server *nix or Windows? Running Apache or IIS?

    It might be worth contacting your hosting provider for assistance with troubleshooting. They'll be able to access everything more easily and are probably used to this sort of thing.

  16. kristinachilds
    Member
    Posted 2 years ago #

    it's windows server 2008 (not my choice!) and we have dedicated, self-managed hosting meaning no technical support outside of needing things to be physically done to the hardware.

    i'm not all that familiar with IIS, being a linuz server junkie myself. is there an easy way to find the error log? obviously the file path denoted in phpinfo is incorrect.

  17. kristinachilds
    Member
    Posted 2 years ago #

    okay, after much learnining i activated trace logging and got an error report.

    fastcgi activity timeout. so theoretically all i have to do is increase the length of time the server allows before timeout?

  18. Japh
    Member
    Posted 2 years ago #

    Yeah, that would certainly be worth a try. If the timeout is set very small, anyway. If the timeout is already fairly big, then the problem isn't a short timeout, but rather a long-running process.

    See what the timeout is, and if it's less than say, 120 seconds, increase it and see how you go.

    Don't forget to put it back once your import has succeed though, because having a really long timeout when you don't need one can mask other problems.

  19. kristinachilds
    Member
    Posted 2 years ago #

    this presents a new problem (when will it end??)

    IIS says that fastcgi is configured, however there is no fcgiext.ini file. the api clearly says that cgi/fastcgi is running and the error is a fastcgi activity timeout, yet when i go into iis config the only module visible is cgi (set to a 15 min timeout).

    stumped again.

  20. Japh
    Member
    Posted 2 years ago #

    Do you have a php.ini file somewhere? It may be that fastcgi is "timing out" because PHP is timing out. So changing the max timeout in php.ini could help.

  21. kristinachilds
    Member
    Posted 2 years ago #

    php timeout settings are set obscenely high.

    i got the iis7 admin pack installed so i could finally modify the fastcgi timeout settings, however it didn't solve the install problem. it doesn't time out but it *still* doesn't get to step 2 where the encrypted password is set.

    it also can't send me a lost password email. i tried turning off the auto-generated password to hard set it to a password of my choosing and that didn't seem to work either.

    AND, even though it doesn't time out or install, it also doesn't generate an error so now i REALLY don't know what the problem is.

  22. tomaltman
    Member
    Posted 2 years ago #

    Here's a thought...can you run a local copy of wordpress, like with xampp or something, import it MT blog - then export a "native" WP file?

    I'm just looking for options...

  23. kristinachilds
    Member
    Posted 2 years ago #

    i thought about that - making a clean install on one of my linux servers then exporting. that's probably what i'll end up doing.

    i'm just concerned that whatever this problem is will cause more problems down the road. it's unsettling to have something liek this undiagnosed... it also sucks that the problem wins. grr

  24. Japh
    Member
    Posted 2 years ago #

    In some ways, the problem is diagnosed. It appears to be a timeout issue.

    Unfortunately, working out where to adjust that timeout has proven elusive, but hopefully no other process your site ever needs to do would take as long as an import.

Topic Closed

This topic has been closed to new replies.

About this Topic