WordPress.org

Ready to get started?Download WordPress

Forums

EWWW Image Optimizer
[resolved] All Images Not Optimizing (11 posts)

  1. J5RBIZ
    Member
    Posted 9 months ago #

    I am using ewww-image-optimzer, 1.7.2 on worpress 3.7.1.

    I love the plugin and it does a great job overall. There is an issue that I need help with:

    I have optimized all images in media library (158 images) and in my theme (987 images). The site performs much better than it did before.

    When I run Google page speed and GoDaddy's website accelerator, both programs indicate that all images are not optimized. Google Page Speed identifies 28 images out of 158 in the media library as not being optimized. GoDaddy's website accelerator says my site's images are only 58% optimized. The ewww-image-optimizer indicates that everything is optimized.

    How do I get the full optimization to be realized?

    http://wordpress.org/plugins/ewww-image-optimizer/

  2. nosilver4u
    Member
    Plugin Author

    Posted 9 months ago #

    It's possible you have some other plugin generating resizes that wordpress doesn't know about. Hard to say for sure without a little more detail on how you are checking the results above.

    It would be useful to know what plugins you are using for starters.

    In the meantime, you can try this (not really recommended as a permanent solution, but it should work for now:
    1. On the settings page, enter the full path to your /uploads/ folder in the Folders to Optimize setting.
    2. Visit Optimize More, you should have an Import option available which will import the media library images into the custom table so they don't get re-optimized.
    3. Then re-run the Optimize More function, and see what happens.

  3. J5RBIZ
    Member
    Posted 9 months ago #

    Thanks, will try the workaround you suggest.

    I am running the following plugins:

    Contact Form 7
    Disqus Comment System
    EWWW Image Optimizer
    Google Analytics for WP
    Jetpack
    Repost
    RSS Just Better
    SEO Friendly Images Business
    W3 Total Cache
    Word Press SEO
    Yet Another Related Post

  4. freerange
    Member
    Posted 9 months ago #

    FWIW the Repost plugin doesn't resize images so I don't think we're the cause.

  5. nosilver4u
    Member
    Plugin Author

    Posted 9 months ago #

    @freerange - good to know, I'm suspecting it might be SEO Friendly Images (business edition) or something directly in the theme.

    J5RBIZ, if it isn't one of the above plugins, I wonder if your theme has some auto-resizing capability? In particular, it looks like these areas are problematic:
    main slider
    representative engagements
    testimonials

    If we can track down where those resized images are coming from, that will give us an idea of why those images were missed. Does your theme do any image resizing?

  6. nosilver4u
    Member
    Plugin Author

    Posted 9 months ago #

    You may also be interested in this plugin: http://wordpress.org/plugins/imsanity/

    This will help you out with those images that ought to be scaled down (at least I believe that's what most people use it for, I don't have a need for it on any of my sites). According to pagespeed, that's around 700kb of savings.

  7. J5RBIZ
    Member
    Posted 9 months ago #

    Thanks, appreciate the information. The SEO Friendly Images updates the alt and title tags and generates Google images site map. It doesn't seem to me that these functions would resize images.

    I don't know if my theme changes image sizes. How would I determine this?

    The theme for my site is Nevada. I use the revolution slider function for the main slider on the home page. The representative engagements uses the portfolio functionality within the theme. The testimonials use the native functionality in the theme, which will rotate through the testimonials

    I am still in the process of optimizing using the work around you originally provided.

    Following that, I will install the imsanity plugin.

    I will update this post with my results.

    Thanks again for your help. I appreciate it.

  8. nosilver4u
    Member
    Plugin Author

    Posted 9 months ago #

    I would suspect the theme is generating the images. One way to find out, is to remove one of the images from those areas (manually from the server side... might be best to just move it to a different location, just in case).

    Then view your frontpage, and see if the image gets automatically regenerated.

    If that happens, check the table on the Optimize More page to see if it shows up in there. If it does, this indicates that the Nevada theme is using the proper wp_image_editor class to do the image resizing, and all future images will be auto-resized.

    That also means that you could simply remove any of the images that the theme is generating, and when the theme regenerates them, they will be auto-optimized.

  9. J5RBIZ
    Member
    Posted 9 months ago #

    I have made some progress in resolving this issue, but it is not yet completely fixed. I removed one of the images from front page as you suggest and it was not regenerated. So it appears that the theme is not at fault.

    I had a few images that were pointing to a staging directory when my website was originally loaded. This was an error that had not been previously corrected. That was changed and those issues were corrected. That explained why JPEG images previously optimized were showing up as not optimized.

    I changed the optimization settings to remove JPEG meta data and increased the PNG optimization level 4. Following these steps, I re-optimized everything. This drove my results on Google PageSpeed up to 87 out of 100 for web and 73 out of 100 for mobile.

    The remaining image optimization issues found by PageSpeed were PNG images in my theme. I am currently at level 5 for PNG optimization. I have re-optimized about 2/3 of the theme images at level 5.

    Here are the current settings I am using for image optimizer:

    Remove JPEG meta data
    PNG optimization level 5
    Enable GIF to PNG conversion

    I will finish the re-opitmization of theme images at level 5. If that doesn't fix it, should I increase PNG optimization level to 6?

  10. nosilver4u
    Member
    Plugin Author

    Posted 9 months ago #

    I would never go higher than 4 (and even then you'll probably see no difference over level 2 or 3). If you enable and install pngout, you'll see more substantial gains, and there again, level 2 is usually pretty good, with minimal gains beyond that. Also worth noting that the pngout levels are backwards, with 0 being the highest, most processor intensive option, and 3 being the lowest level of compression.

    To understand the levels, you need to realize what they actually represent. They aren't quality/compression levels like JPG has. The png format has several variables for compression that can all result in different filesizes. When you set optipng to level 2, it tries 8 different combinations of those variables to see what will yield the smallest filesize. If you move it to level 3, it tries 16, and so on.

    Level 2 is the recommended max for normal folks, although I set level 2 as the default for performance reasons also. Level 4 should be sufficient for those who want the absolute best compression possible, and have cpu cycles to burn. Above that, and you're just burning cpu cycles for fun.

  11. J5RBIZ
    Member
    Posted 9 months ago #

    Thanks for the assistance. Added pngout and re-optimized and changed optipng setting level 4. All optimization issues addressed at this point.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.