WordPress.org

Ready to get started?Download WordPress

Forums

all image uploads fail (24 posts)

  1. richards1052
    Member
    Posted 8 years ago #

    I've never previously had this problem & am stumped by it. When I try to upload any image (or pdf) file to my default image folder, I receive this failure error msg:

    Couldn't upload your file to /home/richard2/public_html/photos/uncategorized/CynthiaNimsSAM1.jpg

    Does this mean anything to someone? And couldn't this error be a little more specific so I could figure out what was causing the failure? I haven't changed any settings relating to uploads or images.

  2. richards1052
    Member
    Posted 8 years ago #

    I figured out my problem. My image file name had hyphens in it. WP insists on no hyphens in image file names (I gather).

  3. richards1052
    Member
    Posted 8 years ago #

    Nope, that didn't fix it. Even with a single word in the image filename (i.e. lark.jpg) the image still wont' upload. It will however upload via ftp.

    What gives?

  4. James
    Happiness Engineer
    Posted 8 years ago #

    Make sure that the permissions for the folder which you are attempting to upload into are 777 (CHMOD 777).

  5. richards1052
    Member
    Posted 8 years ago #

    They are & they've been that both when I could upload images & now when I can't.

  6. dedge
    Member
    Posted 8 years ago #

    There's an option to disable uploading in OPTIONS > MISCELLANEOUS. Could the "Allow File Uploads" box have gotten unchecked somehow? Also be sure the various options, such as "Allowed File Extensions" are still set the way you want them.

  7. richards1052
    Member
    Posted 8 years ago #

    No, the Allow Uploads box remains checked & I have both jpg & pdf listed as allowed file types. Still no upload.

  8. dedge
    Member
    Posted 8 years ago #

    Figured you'd have checked that right away, but it's always worth a reminder...

    Are the files you're trying to upload now markedly larger than the earlier ones? The maximum php-uploadable file size can be configured on the server. Maybe you're hitting that limit?

  9. richards1052
    Member
    Posted 8 years ago #

    I've increased the file size upload maximum in both the WP admin interface & in my php.ini file to accomodate larger files & it still won't work. The php.ini file readme.txt even suggested uploading it to every folder into which you would upload image or audio files. I did that. No dice.

    But no, these files are not especially big.

    It just started happening out of the blue a few days ago. I have no idea what's causing this but it's a royal pain in the behind.

  10. richards1052
    Member
    Posted 8 years ago #

    Can anyone suggest a workaround for creating thumbnails if I only have ftp upload functionality? Is the only way to create thumbs if you upload within the WP interface? Or is there a way to do this via ftp? Pls. don't say the answer is no or I might cut my wrists (not really).

  11. dedge
    Member
    Posted 8 years ago #

    Sorry, you've got me stumped at the moment... The only thing I can think of is the usual troubleshooting step of "what changed around the time this happened" in your install. If nothing truly changed then that pretty much just leaves the server. You've probably thought of this stuff already, but a few ideas:

    • Log off & back on in case it's a user level / cookie thing.
    • Disable plugins one by one, testing each time. I've had functions broken by plugins in very non-intuitive ways.
    • Check with your host to see if PHP security or the upload path has changed somehow.

    You can fake a thumbnail by hard-coding the image size you want into your (X)HTML, i.e <img height="150" width="100" ...>. This does not create an actual thumbnail file, and has the added drawback of not provding any bandwidth reduction because the full file is still downloaded to the browser.

    There are lots of image editing programs that can make thumbnails on your computer, then you can upload them. Some can automatically batch process lots of images at once. Some are free. I've never heard of an FTP application with this built in, though. Try Googling "thumbnail image editor" or similar.

  12. richards1052
    Member
    Posted 8 years ago #

    I should try yr. suggestion about turning plugins on & off & testing. haven't done that.

    I've just realized that I can use ecto to publish to my blog & so avoid the image upload problem in the wp interface. But I'm having a separate problem with ecto that is causing uploads to my server to fail. Got to get that fixed. But I do think I'll be able to upload images & create thumbs via ecto.

    I also figured out how to create 2 separate image files using ftp that would combine as thumb & full size versions. But it's godawful duplication of work compared to creating a nice simply thumb via wp.

  13. James
    Happiness Engineer
    Posted 8 years ago #

    Hm, dedge has already touched on most of what I would have suggested. Have you tried uploading with all plugins disabled? Also, have you tried using a different browser to upload?

  14. richards1052
    Member
    Posted 8 years ago #

    Hey, btw can anyone tell me why the upload failure error msg. referred to in the first post in this thread refers to my host server filepath like so:

    Couldn't upload your file to /home/richard2/public_html/photos/uncategorized/CynthiaNimsSAM1.jpg

    rather than to my wp filepath which would be:
    http://www.richardsilverstein.com/tikun_olam/photos/uncategorized/CynthiaNimsSAM1.jpg

  15. James
    Happiness Engineer
    Posted 8 years ago #

    Ah, good point.

    /home/richard2/public_html/photos/uncategorized/ is actually a server path, but it is incorrect because it does not include the /tikun_olam/ directory.

    Go to Options/Miscellanious and enter the following path for "Destination directory":

    /home/richard2/public_html/tikun_olam/photos/uncategorized/

    I hope that works!

  16. James
    Happiness Engineer
    Posted 8 years ago #

    Wait, there doesn't seem to be /photos/ or /uncategorized/ under /tikun_olam/ you'll have to create those first.

    The key point is that WordPress can only write to directories inside its blog directory, even if the directory permissions are 777.

  17. richards1052
    Member
    Posted 8 years ago #

    macmanx: Terribly sorry about incorrect info above. The true filepath for my images is:

    http://www.richardsilverstein.com/photos/uncategorized/...

    Sorry for sending you on a wild goose chase by mistakenly adding 'tikun_olam' to the path. It's my blog subdirectory, but it & my photos folder are both in the public_html folder.

    I just deactivated every single plugin I have & the image upload still fails.

    I've tried using IE & FF & both fail.

    Tried loggin in & out & that didn't work either.

  18. James
    Happiness Engineer
    Posted 8 years ago #

    Try uploading the image to a directory that is inside your blog directory, like:

    /home/richard2/public_html/tikun_olam/photos/

    (You will have to create the /photos/ directory.)

  19. richards1052
    Member
    Posted 8 years ago #

    The reason I'm using this filepath is because when I was with Typepad for some reason it created the same file path (http//:www.richardsilverstein/photos/uncategorized/...). In order to preserve old link & image filename structures Carthik & I basically recreated the same filepaths in WP & uploaded new images there along with the old ones fr. my former blog. And the WP uploads worked fine using this path until about 2 wks. ago when they just stopped working--phhht!

    I do also have an images folder in this filepath--
    .../tikun_olam/images/...

    and I could try to change my upload path to that & see if anything changes.

    UPDATE: Just as I suspected...after changing the upload path to tikun_olam/images I receive the same basic error msg:

    Couldn't upload your file to /home/richard2/public_html/tikun_olam/images/FestivalofWoodenBoatsZanzibarwp.jpg

  20. James
    Happiness Engineer
    Posted 8 years ago #

    Hm, yuck. Have you tried contacting your hosting provider about this?

  21. richards1052
    Member
    Posted 8 years ago #

    That's my next call...Maybe they did something server wise globally that would've affected me or perhaps something in their software conflicts with me somehow.

    I wish bluehost had a user forum like hostdime & other hosts do. Then I could specifically ask WP users who use bluehost whether they're suffering the same problem as me.

  22. James
    Happiness Engineer
    Posted 8 years ago #

    Well, I can say that I did use Bluehost and never had an upload problem, but that was a long time ago. Good luck with their support dept ...

  23. richards1052
    Member
    Posted 8 years ago #

    I thought I'd check the error log for my host server to see what was happening when I tried to upload a jpg image. I was hoping that the error might help a fellow member narrow down where my upload problem might lie:

    MAIN error_log: [Sun Jul 31 01:19:20 2005] [error] [client 66.196.91.171] File does not exist: /home/richard2/public_html/tikun_olam/folk_and_world_music/ [Sun Jul 31 01:22:08 2005] [error] [client 67.142.130.12] Invalid URI in request GET HTTP/1.1 [Sun Jul 31 01:22:08 2005] [error] [client 67.142.130.12] File does not exist: /usr/local/apache/htdocs/400.shtml

    SUEXEC error_log: [2005-07-31 01:22:49]: info: (target/actual) uid: (richard2/richard2) gid: (richard2/richard2) cmd: upload.php [2005-07-31 01:23:20]: info: (target/actual) uid: (richard2/richard2) gid: (richard2/richard2) cmd: upload.php

    The first thing that looks wacky here is that I see "file does not exist" and it refers to my Folk & World Music category. I was using a blank post screen which had no category associated with it. So why this part of the error appears is a mystery.

  24. wpuser123
    Member
    Posted 8 years ago #

    i believe this happened because the spykidz issue. i am having this problem as well. any thoughts?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags