WordPress.org

Ready to get started?Download WordPress

Forums

All comments have the same IP address (15 posts)

  1. russ960
    Member
    Posted 5 years ago #

    I've had this issue for some time but I'm just now getting to it. Every comment has the same IP address 172.16.10.1. This is not pingable and I think it is a reserved IP address. I think there is an issue on my IP configuration or maybe mine. I've googled this a number of different ways with no success. Any ideas or help would be greatly appreciated.

  2. poggers
    Member
    Posted 5 years ago #

    Hi russ,
    I have a very similar problem.
    All my comments are logged to my local IP...
    Everything else on the site seems to be working just lovely.
    Have you found a solution to this issue?

  3. jillsays
    Member
    Posted 5 years ago #

    I'm also having this problem - out of the blue. I'm using wordpress 2.5.2

    Things were fine until Thursday, October 9th. Then, all comments started coming in with my local IP.

    Anyone have any ideas?

  4. whooami
    Member
    Posted 5 years ago #

    thats a host issue. its a result of their dns resolver and php not talking.

  5. whooami
    Member
    Posted 5 years ago #

    ps: you need to upgrade also, btw, jillsays.

  6. jillsays
    Member
    Posted 5 years ago #

    Thanks for the reply! I have no idea what the hell you're talking about, but I'll call my web host and see if they have any ideas.

    Cheers

  7. whiterosie
    Member
    Posted 5 years ago #

    Same problem here and it started last Thursday. Actually, mine have one of three different IPs and they are all for spam so every comment ends up in the spam folder.

  8. whiterosie
    Member
    Posted 5 years ago #

    Jillsay, don't listen. The current upgrade is the upgrade from hell. If you're not really comfortable with mysql, I wouldn't try it. Wait until the next one!

  9. jillsays
    Member
    Posted 5 years ago #

    How strange the issue started on Thursday for BOTH of us. I'm using YAHOO as a host... I bet you are too?

    I disabled Askimet - and comments are now at least being posted on my website, but they all have my local IP and it's frustrating, since I can't blacklist people, etc.

    I've heard horror stories about this latest version of wordpress, so I'm going to be waiting before upgrading!

  10. whooami
    Member
    Posted 5 years ago #

    I've heard horror stories about this latest version of wordpress, so I'm going to be waiting before upgrading!

    thats your choice. I guess a hacked blog is always better than taking the time to learn or simply paying someone to take care of something you cannot. Good luck with that.

  11. jillsays
    Member
    Posted 5 years ago #

    Thanks for the snide, sarcastic answer! You seem so pleasant. Can we be friends?

  12. whooami
    Member
    Posted 5 years ago #

    theres absolutely nothing snide or sarcastic in that answer.

    youre making a bad choice, its not anyone else's fault that you dont like hearing it. Facts are facts.

    and honestly, while I think you were probably kidding about the 'lets be friends' thing -- I would have to decline. Not upgrading wordpress, consciously making a decision to continue running insecure software on your web site, is not only detrimental to you, its detrimental to me, and anyone else that shares the WWW with you, so no thanks.

    to steal another oft used meme:

    "friends dont let friends run exploitable software on their web site"

  13. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    172.16 is indeed in the reserved private IP range, and it means your host is now filtering incoming connections through some kind of proxy.

    You could add code similar to this in your wp-config.php file, right after the defines. Not the best way, but what the heck, eh?

    if ($_SERVER["HTTP_X_FORWARDED_FOR"]) {
       if ($_SERVER["HTTP_CLIENT_IP"]) {
        $proxy = $_SERVER["HTTP_CLIENT_IP"];
      } else {
        $proxy = $_SERVER["REMOTE_ADDR"];
      }
      $ip = $_SERVER["HTTP_X_FORWARDED_FOR"];
    } else {
      if ($_SERVER["HTTP_CLIENT_IP"]) {
        $ip = $_SERVER["HTTP_CLIENT_IP"];
      } else {
        $ip = $_SERVER["REMOTE_ADDR"];
      }
    }
    $_SERVER['REMOTE_ADDR'] = $ip;

    That should work out what the IP of the proxy vs. the real client IP is, if you're behind a proxy. Then it assigns it to the REMOTE_ADDR variable, to trick WordPress into getting the right IP.

  14. jillsays
    Member
    Posted 5 years ago #

    Thanks for the response Otto -

    My comments aren't coming in with an IP of 172.16 - they're coming in with my local IP. I'll call my host, and try your code.

  15. poggers
    Member
    Posted 5 years ago #

    whooami: Ok, thanks for pointing it out - do you have any idea on how to make php and the DNS-resolver start talking properly again?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.