WordPress.org

Ready to get started?Download WordPress

Forums

All blogpost 404 not found (6 posts)

  1. mairaj
    Member
    Posted 1 year ago #

    My primary website under a MultiSite suddenly broke, its permalink settings are forcing '/blog' that came from nowhere. I always had mywebsite.com/%postname%/ as my permalink setting.

    Please see screenshot

    http://s22.postimg.org/gotv0enc1/image.jpg

    The settings at mywebsite.com/wp-admin/network/site-settings.php are as following screenshot

    http://s23.postimg.org/qe3xb3wrv/image.jpg

    Kindly help, its urgent as my site seems to have this problem for 2-3 days now.

  2. Go back to mywebsite.com/wp-admin/network/site-settings.php

    Make the change (removing /blog/ from the path)

    Click save.

    Never again try to save permalinks on that site normally.

    (WP is doing it correctly, you're supposed to have /blog/ in there)

  3. mairaj
    Member
    Posted 1 year ago #

    Hi!

    I'm sorry but my webite pages never had '/blog' in urls and it is all indexed in google without '/blog'.

    My entire website is now generating 404 errors, my webmaster tools in full of errors and warnings. My website pages have started disappering and it all is hurting my SERPs.

    I have to get rid of '/blog', please help.

    Thank you.

  4. IF you have been using SubFOLDER WordPress Multisite, then at one point in time you did too have /blog/

    That's how WordPress has always worked. So clearly you did something to change it :)

    Go back to mywebsite.com/wp-admin/network/site-settings.php

    Make the change (removing /blog/ from the path)

    Click save.

    If that doesn't work, you'll have to be a little more forthcoming with what's happening.

  5. mairaj
    Member
    Posted 1 year ago #

    Somebody suggested me to deactivate all plugins and reactivate them. I did and problem resolved. All my posts are now located and accessible at http//mywebsite-com/postname and this is how they are indexed in Google.

    Somewhat the problem is gone however there is something strange in my dashboard settings. It reads as follows (the 'blog' is still there )

    Default http//mysite-com/?p=123
    Day and name http//mysite-com/blog/2013/04/12/sample-post/
    Month and name http//mysite-com/blog/2013/04/sample-post/
    Numeric http//mysite-com/blog/archives/123
    Post name http//mysite-com/blog/sample-post/
    Custom Structure http//mysite-com/blog

    Here is the screenshot :

    http://s16.postimg.org/c04tidhgl/perma_settings.jpg

  6. Yes, that's exactly how it's supposed to be. Nothing's wrong there.

    As I've tried to explain before, by default, WP hardcodes /blog/ into your path.

    If you want to change it, you must do this:

    Go back to mywebsite.com/wp-admin/network/site-settings.php

    Make the change (removing /blog/ from the path)

    Click save.

    Never again try to save permalinks on that site normally.

    From this moment on, you can NEVER go back the site's permalink page. If you do, /blog/ will come back. That is how it works, that is how it is supposed to work, yes we know it sucks.

Topic Closed

This topic has been closed to new replies.

About this Topic