WordPress.org

Ready to get started?Download WordPress

Forums

ALL Blank! Everything gone! (33 posts)

  1. Denkfabriq
    Member
    Posted 6 years ago #

    I am desperate. I have been reading all the topics that could solve my problem - unfortunately I did not find anything that matches my desaster: I installed a new plugin (yigg-wordpress-plugin) which apperently did not work. I deleted the plugin - usually that worked. But I got a white screen and NOTHING worked any more. As this was by far not the first time I white screen challanged me I kept cool and tried some things out.
    BUT nothing works! All I get when I want to access my site is a white screen. I cannot access the admin menu nor any post or page. Even the homepage is blank!

    Take a look: http://www.denkfabriq.de

    I deleted all the plugins - no reaction.
    I checked the databases - everything seemed to be OK.
    I deleted everything and reinstalled wordpress - STILL no change!

    I am stressed out. Just got the page going well and readers returning and now the page is down.

    I would be so thankful for help.

  2. Just Thomas Misund
    Member
    Posted 6 years ago #

    Have you tried another theme?

    Edit: If the theme is the problem, it still shouldn't kill the admin menu... Hm. Tricky one.

  3. Just Thomas Misund
    Member
    Posted 6 years ago #

    .htaccess?

  4. Denkfabriq
    Member
    Posted 6 years ago #

    Thank you for your help dnusim...
    It's like a nightmare - nothing works!?! Never experienced anything similar...
    I deleted everything that could cause problems. I deleted the plugins and the theme I used before - no change. I reinstalled it - nothing.

    I am not quite familiar with that .htaccess-thing. I remember that I tried to use it once but then I changed something in the wordpress admin so I had the post-names in the adress without needing to have or to modify an .htaccess file. It looked like this: http://www.denkfabriq.de/index.php/2008/02/22/landschaftsbilder
    or something like that. I think because of the "index.php" in the adress there was no need for a .htaccess-file.

    Anyways, I don't want to leave anything out to solve this problem here so I created a .htaccess-file with the following content:

    RewriteCond %{DOCUMENT_ROOT}%{REQUEST_FILENAME} !-f
    RewriteCond %{DOCUMENT_ROOT}%{REQUEST_FILENAME} !-d
    RewriteRule ^ /index.php [L]

    I don't know if that matches my settings. Well, guess what happened after I changed that: Right, NOTHING.

    That is a miracle! I have no clue what to do!? Anyone?

  5. Denkfabriq
    Member
    Posted 6 years ago #

    I am thinking and thinking - maybe it really does have to do something with the database... could it be that the plugin changed something in the database and that's why nothing works any more even though I installed everything new?
    How could I refresh the database without losing data?
    Or is it maybe something else???

  6. Martensen
    Member
    Posted 6 years ago #

    I still can see your content at http://www.denkfabriq.de/blog/

    Hope that helps :)

  7. Martensen
    Member
    Posted 6 years ago #

    Kannst auch noch einloggen unter http://www.denkfabriq.de/blog/wp-login.php

    Da ist nur irgend ein Setting zerschossen :)

  8. Denkfabriq
    Member
    Posted 6 years ago #

    Well, thank you but denkfabriq/blog is another install that has nothing to do with "denkfabriq.de" ... :-D
    It's the "old" page... Danke trotzdem

  9. Denkfabriq
    Member
    Posted 6 years ago #

    Just found that piece of information, so most likely it is NOT the database...:

    "A White screen most likely means a PHP Error has occured and your webserver is set to NOT show them.

    Do you have some Error logs you can look at?"

    Where and how do I look at Error logs?

  10. Martensen
    Member
    Posted 6 years ago #

    Dunno, bet it depends on your host. Have you called them yet and asked them to have a look at it?

  11. Just Thomas Misund
    Member
    Posted 6 years ago #

    Have you tried uploading a static page to see if it will wisplay?

    Make sure to backup your database if you intend to do something out of the ordinary.

    Edit: Whoa, not reloading fast enough here, I see =) Glad to see you found the nature of the problem.

  12. Martensen
    Member
    Posted 6 years ago #

    Did you try phpinfo yet?

    Make a new file, call it phpinfo.php and put in of the dirs that are still http accessible, like /blog and put the following in

    <?php phpinfo (); ?>

    and then point your browser to that file.

    Example: http://manuelmartensen.com/phpinfo.php

  13. Denkfabriq
    Member
    Posted 6 years ago #

    Well in fact, there is nothing http accessible any more. As I said, the Blog-file is an independent site and does not belong to the installation at question...

    I created that phpinfo-file but I have to admit that I personally see nothing from that...

    I reinstalled the root files again - nothing. It starts making me mad !!! Thanks for your support anyways! :)

  14. Just Thomas Misund
    Member
    Posted 6 years ago #

    It looks to me like the page is 302 redirected to itself, which causes the server to kill the loop.

    --14:34:48--  http://www.denqfabriq.de/
               => 'index.html'
    Resolving www.denqfabriq.de... 195.78.76.109
    Connecting to www.denqfabriq.de|195.78.76.109|:80... connected.
    HTTP request sent, awaiting response... 302 Found
    Location: http://www.denkfabriq.de [following]
    --14:34:48--  http://www.denkfabriq.de/
               => 'index.html'
    Resolving www.denkfabriq.de... 195.78.76.109
    Reusing existing connection to www.denqfabriq.de:80.
    HTTP request sent, awaiting response... 500 Internal Server Error
    14:34:48 ERROR 500: Internal Server Error.
  15. Denkfabriq
    Member
    Posted 6 years ago #

    Just to remind: All that started after I installed a plugin (yigg wordpress plugin) that apparently did not work. Until that time it was routine... I hope I am not maneuvering towards a 'game over'...

  16. Denkfabriq
    Member
    Posted 6 years ago #

    wow! and how do I make the page not redirect to itself?

  17. Just Thomas Misund
    Member
    Posted 6 years ago #

    Good question. Um... I guess it depends on how the redirect is made.

  18. Denkfabriq
    Member
    Posted 6 years ago #

    the index.php points to wp-blogheader which points to wp-config.php ... where do I edit or at least look for that redirect thing? Shouldn't a new install have solved a problem of that kind? Maybe it really is a problem of the database, all other problems would have been solved with a new installation... Is that true or complete nonsense?

  19. Martensen
    Member
    Posted 6 years ago #

    Question:

    You say that /blog is a different installation. OK. But is /blog hosted somewhere else or do you just tell me that it has nothing to do with your mainpage?

    If your only argument is that it has just nothing to do with your mainpage, then we know that your php in general is operating fine.

  20. Martensen
    Member
    Posted 6 years ago #

    Another idea:

    Get the latest version of the yigg plugin that should work with your WP version, upload it and check in your db if you can activate it there. If you did that, then deactive it again. Maybe the deactivation is mandatory to remove some hooks it adds when you activate it.

    And for more researching, which version did you use anyways? Yigg 1.0 or YIGGer 1.0.1?

  21. Just Thomas Misund
    Member
    Posted 6 years ago #

    If you've got a fresh install without any plugins it shouldn't be anything wrong with the files.

    Will a static file display?

  22. Denkfabriq
    Member
    Posted 6 years ago #

    OK: The "blog" (denkfabriq.de/blog) is a wordpress installation and the "denkfabriq.de" is another wordpress installation with a seperate database and everything. The "Blog" is kind of the old site and I just left it online... - by this it should not be part of the problem.

    Anyways, I just made a clean sweep and deleted the denkfabriq-installation and reinstalled everything brand new using a new database. It worked just fine. Of course I want my old content back so I copied the files from the database I used before to the brand-new one. And "flupp", it did not work anymore. Seems to be a database problem, huh? So how can I save my content or how do I find the foul piece?
    Thanks so much for the help.

  23. Martensen
    Member
    Posted 6 years ago #

    What i was trying to say: If the correct plugin deactivation is critical, then by just deleting it might have left something somewhere.

    Another way to deactivate the plugin without the need to find that key in your database: Upload the plugin you used before, and point your browser to this adress to deactivate it:

    http://denkfabriq.de/wp-admin/plugins.php?action=deactivate&plugin=yigg.php

    I am just guessing here though ;)

  24. Martensen
    Member
    Posted 6 years ago #

    Hope the “post-mortem” plugin deactivation fixes something in the db. Worth a try if you have a backup.

  25. Denkfabriq
    Member
    Posted 6 years ago #

    Sorry, I did not answer the question "do static pages display". Well, I tried the page "http://www.denkfabriq.de/index.php/mission/" as an example of a static page I had before and it does not work. Even in the new installation I cannot access the admin panel or anything

  26. Just Thomas Misund
    Member
    Posted 6 years ago #

    Oh, what I meant to ask was if an uploaded .html file would display. But given "reinstalled everything brand new using a new database. It worked just fine", it doesn't matter anymore. =)

  27. Denkfabriq
    Member
    Posted 6 years ago #

    I used the yigg wordpress plugin 1.0.
    I downloaded it here: http://www.yigg.de/hilfe?show=wpplugin

    To make all that a bit easier: Isn't it possible to install everythig freshly on a new database and copy the wp_posts-file to get my content back? As a quick solution as my site has been down for quite a while?

    I will also try to deactivate the plugin in the database though... So far I did not find anything pointing to that plugin.

  28. Denkfabriq
    Member
    Posted 6 years ago #

    OK. Now I am doing it the hard way :-) I installed everything new another time and now I am changing every single database-bit manually... I am glad I have my site back though :-D It's still work to do but superficially it's back again!!!

    Thank you for your support!

    Anyways, if I find something how to solve a problem like that more easily I'll let you know.

    Cheers.

  29. Denkfabriq
    Member
    Posted 6 years ago #

    The foul piece was the "wp-options" in the database...

  30. Martensen
    Member
    Posted 6 years ago #

    Looks like your back, or?

Topic Closed

This topic has been closed to new replies.

About this Topic