WordPress.org

Ready to get started?Download WordPress

Forums

Acunetix WP Security
[resolved] Alerts on dashboard don't reflect current settings (8 posts)

  1. Ate Up With Motor
    Member
    Posted 9 months ago #

    A while back I accidentally disabled the options in WP Security's settings list (I deactivated the plugin while troubleshooting and it took me a few days to realize reactivating it caused all the checkboxes to revert to unchecked). I subsequently re-enabled all of those options, but the dashboard still shows some of them as alerts with datestamps from the period when they were turned off.

    Is there a way to get the plugin to update the alerts? Clicking "update settings" a few times has no effect.

    Thanks!

    http://wordpress.org/plugins/wp-security-scan/

  2. Acunetix
    Member
    Plugin Author

    Posted 9 months ago #

    Hello, Ate Up With Motor

    This happens because some of the alerts are running using internal WP cron jobs, for example every hour or every 8 hours. No need to worry :)

    Regards,
    Costin

  3. Ate Up With Motor
    Member
    Posted 9 months ago #

    How long should I expect it to take for the alerts to refresh? It's been days and they haven't updated.

  4. Acunetix
    Member
    Plugin Author

    Posted 9 months ago #

    Hello, Ate Up With Motor

    I see no reason why those alerts won't update...which alerts are those?

    Regards,
    Costin

  5. Ate Up With Motor
    Member
    Posted 9 months ago #

    Any alert that regards a function performed by the plugin itself: "WordPress version is displayed in links for all users"; "Core update notifications are displayed to all users"; "The check for PHP and database error reporting is disabled"; and so on.

    Essentially, all the options controlled by the plugin settings are red or yellow and the alert dates have not updated in over a week. All of these settings are enabled in the Settings page and have been for days now.

    Cron jobs for other functions, such as backups, are being performed on schedule, so it puzzles me that the alert checks are not.

  6. Acunetix
    Member
    Plugin Author

    Posted 9 months ago #

    Hi, Ate Up With Motor

    That is indeed, very strange... I'm not sure what's causing this strange behavior, can you please send me some more details like the errors from the error log or from the WP's debug.log file if enabled at my email address: costin@acunetix.com? Maybe I can figure out what's going on from them?

    Thank you

    Regards,
    Costin

  7. Ate Up With Motor
    Member
    Posted 9 months ago #

    Costin,

    I'm sorry, I don't have debug logging enabled. I looked through the most recent error logs and didn't see anything related (the host only keeps them for a few days, so that isn't necessarily revealing).

    As an experiment, I tried deactivating and completely deleting the plugin, then reinstalling and reactivating a fresh copy from WordPress. That appears to have done the trick; I re-enabled all the settings and all the alerts are now green.

  8. Acunetix
    Member
    Plugin Author

    Posted 9 months ago #

    Hi, Ate Up With Motor

    Good to hear! :) Thank you for letting us know!

    Regards,
    Costin

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.