WordPress.org

Ready to get started?Download WordPress

Forums

Cookillian
Alerts not showing (9 posts)

  1. backd00r
    Member
    Posted 8 months ago #

    I'm testing cookillian plugin on my test site and it's not working correctly.
    When I'm connected and in debug mode it works correctly, but when I try to simulare a real situation it not works.

    I've tried also in incognito mode.

    Console at Developers tools shows that:

    --- BEGIN ---
    Object {blocked_cookies: true, deleted_cookies: true, implied_consent: false, opted_out: true, opted_in: false…}
    blocked_cookies: true
    debug: Object
    country_list_ok: true
    country_long: "Spain"
    country_short: "ES"
    handle: true
    ip: "83.36.130.15"
    is_selected_country: true
    logged_in: false
    __proto__: Object
    __defineGetter__: function __defineGetter__() { [native code] }
    __defineSetter__: function __defineSetter__() { [native code] }
    __lookupGetter__: function __lookupGetter__() { [native code] }
    __lookupSetter__: function __lookupSetter__() { [native code] }
    constructor: function Object() { [native code] }
    hasOwnProperty: function hasOwnProperty() { [native code] }
    isPrototypeOf: function isPrototypeOf() { [native code] }
    propertyIsEnumerable: function propertyIsEnumerable() { [native code] }
    toLocaleString: function toLocaleString() { [native code] }
    toString: function toString() { [native code] }
    valueOf: function valueOf() { [native code] }
    get __proto__: function __proto__() { [native code] }
    set __proto__: function __proto__() { [native code] }
    deleted_cookies: true
    has_nst: false
    implied_consent: false
    is_manual: false
    opted_in: false
    opted_out: true
    __proto__: Object
    pub.js?ver=1.2:9
    event.returnValue is deprecated. Please
    --- END ---

    Thanks for your help.
    Javier

    http://wordpress.org/plugins/cookillian/

  2. myatu
    Member
    Plugin Author

    Posted 8 months ago #

    Looking at the following, it appears you had already opted out at one point?

    opted_out: true

    This would be why you're not seeing the alert when debug mode is off.

    You can reset this by using adding ?cookillian_resp=2 to your URL, ie., http://example.com?cookillian_resp=2

    Alternatively, as you are using the Developer Tools, in the "Resources" -> "Cookies" tab of the Developer Tools, delete "cookillian_opt_out".

  3. backd00r
    Member
    Posted 8 months ago #

    Thanks @myatu!

  4. backd00r
    Member
    Posted 8 months ago #

    Hi again @myatu,

    The problem has returned!
    I'm having the same problem:
    I've deleted all the cookies of my computer.
    I've tried with culturageek.com/?cookillian_resp=2
    I've also deleted the cookies from the Developers Tools...
    And the cookies banner is not shown...

    I don't know what to do.

    Thanks,
    Javier

  5. myatu
    Member
    Plugin Author

    Posted 8 months ago #

    Javier,

    It is showing for me on your website. What is the debug output?

  6. backd00r
    Member
    Posted 8 months ago #

    Hi myatu!

    - From my computer:

    First I remove all the cookies from the browser.
    I go to culturageek.com

    And the banner is not shown.

    From my mobile:

    I go to to culturageek.com and the banner is shown. But if I agree or disagree, the banner is always shown...

    This this the debug output:

    ---
    Object {blocked_cookies: true, deleted_cookies: true, implied_consent: false, opted_out: true, opted_in: false…}
    blocked_cookies: true
    debug: Object
    country_list_ok: true
    country_long: "Spain"
    country_short: "ES"
    handle: true
    ip: "195.77.222.100"
    is_selected_country: true
    logged_in: false
    __proto__: Object
    deleted_cookies: true
    has_nst: false
    implied_consent: false
    is_manual: false
    opted_in: false
    opted_out: true
    __proto__: Object
    ---

    Thanks,
    Javier

  7. myatu
    Member
    Plugin Author

    Posted 8 months ago #

    Looking at the AJAX requests, they seem to be going to:

    https://culturageek.com/wp-admin/admin-ajax.php

    That is an SSL-secured request (https), though the website was accessed without SSL (so the cookies are set incorrectly).

    Has "https" been set anywhere specific in WordPress or using a plugin?

  8. backd00r
    Member
    Posted 8 months ago #

    Hi myatu,

    Yes I'm using WordPress HTTPS Plugin (http://wordpress.org/plugins/wordpress-https/) in order to force https when accessing to http://culturageek.com/wp-admin

    Thanks,
    Javier

  9. myatu
    Member
    Plugin Author

    Posted 8 months ago #

    Ah, that would be the issue then - specifically with that plugin itself - because it is also forcing the AJAX URL to occur over https (even if accessing the website over a non-https URL). You'd have to contact the developer of that plugin to have that fixed, or disable the plugin.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.