WordPress.org

Ready to get started?Download WordPress

Forums

Cookillian
[resolved] Alert does not appear! (9 posts)

  1. Javierren
    Member
    Posted 4 months ago #

    Hello,
    I'm not able to make alert appear in my page.
    I've even tried to deactivate every installed plugin, but it hasn't work anyway.

    I don't know why, and I think this is a very interesting plugin, it fits perfectly Spanish legislation and I'd like to use it, I think it worths.

    Debug shows:
    Detected IP: 87.218.245.57
    Detected Country: Spain
    Active caching plugin: Yes

    I've activated: Show the alert if the visitor's country could not be determined (Recommended)
    But alert doesn't appear...

    URL is: http://www.pintandolasnubes.com

    Thanks for your attention.
    Regards.
    Javier.

    https://wordpress.org/plugins/cookillian/

  2. Javierren
    Member
    Posted 4 months ago #

    Sorry, I forgot that my wordpress version is 3.8.1 and cookillian 1.2

    Regards.
    Javier.

  3. wordscant
    Member
    Posted 4 months ago #

    Hello,
    I am using wordpress 3.8 and it appears it doesn't work, but if I look up at the source code it is there:

    <div class="cookillian-alert" style="display:none;"><a class="close">×</a><h3 class="alert-heading">Information regarding cookies</h3><p>This site uses cookies to store information on your computer. Some of these cookies are essential to make our site work and others help us to improve by giving us some insight into how the site is being used. <a href="#">More information</a>. </p><p>By using our site you accept the terms of our <a href="#">Privacy Policy</a>. </p><div class="buttons"><a class="btn btn-ok" href="/theroom/?cookillian_resp=1" rel="nofollow"><i class=""></i>Yes, I'm happy with this</a> 
            <a class="btn btn-no" href="/theroom/?cookillian_resp=0" rel="nofollow"><i class=""></i>No! Only store this answer, but nothing else</a></div></div>

    So I guess it is a small problem with css styling or something, as I noted this I checked out with firebug and deleted the "display: none;" directive and it appears correctly.
    Do you hav some idea of what we can do to make it work?
    Thanks!
    PS: As I checked out in your website, Javier, it happens exactly the same: check it out with the firebug, I saw that you translated it into spanish.

  4. myatu
    Member
    Plugin Author

    Posted 4 months ago #

    @Javierren: The website uses some sort of minifier for JavaScript (and CSS) that is breaking the script. You'll have to disable the minifier, or use one that does not alter the loading order of scripts.

    @wordscant: The "display:none" is there by design. Have a look here first: http://myatus.com/p/cookillian-troubleshooting/

  5. Javierren
    Member
    Posted 4 months ago #

    Hello,

    it was exactly the reason. Thank you myatu!
    I've disabled "W3 Total Cache" plugin Minify section and everything has worked.
    I'll take a look in order to enable it again, but trying it doesn't alter orders of scripts.

    Thank you wordscant for sharing also your issue.

    Regards.
    Javier.

  6. wordscant
    Member
    Posted 4 months ago #

    Thanks for the quick answer myatu!
    I will take a look and say something.

  7. wordscant
    Member
    Posted 4 months ago #

    One question: I am trying the debuging mode. The thing is that my instalation at the moment is local, as I am developing in my own computer. Can this be the reason it doesnt display?
    Thanks

  8. wordscant
    Member
    Posted 4 months ago #

    I found out that the alert was not showing because I had DoNotTrackMe enabled in my Firefox browser.
    When I disable this option in the browser it is showing the alert.
    For my understanding of the question it shouldn't be like that, should it?
    Am I missing something?

  9. myatu
    Member
    Plugin Author

    Posted 4 months ago #

    @wordscant: For local installations, it may interfere if you're accessing it on the localhost (127.0.0.1). And DNT will cause it to assume you do not wish to have any cookies (which is why the feature is there for in browsers).

Reply

You must log in to post.

About this Plugin

About this Topic