WordPress.org

Ready to get started?Download WordPress

Forums

WP Photo Album Plus
[resolved] Album Does Not Show Up (19 posts)

  1. crackedjar
    Member
    Posted 3 years ago #

    I am using the latest version of WP on a private blog. I installed the plug-in, created 2 albums and uploaded 2 pictures into each of them. I created the page "Photo Albums" and put the code %%wppa%% into it and saved it. When I try to view the page, it is only showing the code. I am using the Matala theme, if that makes a difference, and I am very new to this, so I don't want to mess up any coding.

  2. Andrewjmarino
    Member
    Posted 3 years ago #

    You may need to add the album id #

    %%wppa%%%%album=2%%

  3. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    A link to the site would be helpfull

  4. crackedjar
    Member
    Posted 3 years ago #

    It is http://thisthingcalledmylife.com. I didn't post the link because it is a members only site.

  5. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    Please updat to wppa+ version 4.0.3
    It should work now

  6. crackedjar
    Member
    Posted 3 years ago #

    I updated, but it's still not working. I can't figure out what I'm doing wrong.

  7. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    And i cannot see anything because i cannot login because i am not a member...

  8. crackedjar
    Member
    Posted 3 years ago #

    If you register, I will gladly approve you. Thank you for all the help.

  9. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    I can login now, but i cannot find a page "photo albums".

    Please supply a link to a page that exhibits the problem

  10. crackedjar
    Member
    Posted 3 years ago #

  11. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    I inspected it and can not yet find an explanation. The input looks ok (%%wppa%%).

    I downloaded matala to my docs and demos site and tested it, no problems.

    Please try the following:

    Go to the Themes page, activate twentyten (or eleven) and see what happens.

    Do you use the wysiwyg editor or the html editor?
    If the wysiwyg, please try a normal blogpost with %%wppa%% made with the html editor. Not that i think the problem lays there, but just to be sure.

  12. crackedjar
    Member
    Posted 3 years ago #

    I activated twentyten and the page still showed up with just the code.

    I use the wysiwyg editor most of the time but I use the html editor too, and I tried both. I also tried the normal blogpost with %%wppa%% on the html editor and it is still the same, so I changed it back now.

  13. crackedjar
    Member
    Posted 3 years ago #

    Oh, and if this helps any, I uninstalled WP Photo Gallery Plus and installed WP Photo Gallery instead, and it worked. I really wanted to use the Plus, though, because I can have comments on individual photos, if I am understanding it correctly. I reinstalled the Plus version and it still doesn't work.

  14. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    Ok, i will help you until it works.

    Please go to the Photo Albums -> Settings screen, and check Table IX item 5: Allow WPPA+ Debugging and press Save changes
    This way i can see more

    Also, try an empty line BEFORE the %%wppa%%

  15. crackedjar
    Member
    Posted 3 years ago #

    That setting was already checked. I tried the empty line but when I saved it, the code moved back to the top.

    Thank you for all the help.

  16. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    Please do the following:

    1.
    De- activate all other plugins temporary, and test the photo albums page. If it works, activate the other plugins one by one and test the page after each activation (press CTRL+F5 to refresh the browser).
    Remenmber the plugin whose activation caused the fail and tell me so.

    2.
    If de-actvation of all other plugins failed to get the photo albums page to work, do the following:

    Go to the Edit tab of the Plugins menu of the left sidebar in the admin screen.

    Select plugin to edit WP Photo Album Plus in the right sidebar.

    Click on file wp-photo-album-plus/wppa-filter.php

    You will see this:

    <?php
    /* wppa-filter.php
    * Package: wp-photo-album-plus
    *
    * get the albums via filter
    * version 4.0.0
    *
    */
    
    add_action('init', 'wppa_do_filter');
    
    function wppa_do_filter() {
    	add_filter('the_content', 'wppa_albums_filter', 10);
    }
    
    function wppa_albums_filter($post) {
    global $wppa;
    
    	$post_old = $post;
    	$post_new = '';
    .
    .
    .
    .

    please change

    add_filter('the_content', 'wppa_albums_filter', 10);

    into (change 10 to 1)

    add_filter('the_content', 'wppa_albums_filter', 1);

    and press Update File

    This should result in the album(s) being displayed.
    However, if it works, it is NOT a solution (the layout will be wrong), but i am eager to know this.

  17. crackedjar
    Member
    Posted 3 years ago #

    The plugin "My Live Signature" is causing the problem. I have it disabled at the moment, so the album is working.

    :-)

  18. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    You should forget about My Live Signature as it destroys all so called filters

    You can see other complains about this plugin here

    If you want to avoid many problems, with standard wp and with other plugins, DO NOT INSTALL My Live Signature

  19. crackedjar
    Member
    Posted 3 years ago #

    O.K. I will find another way to add my signature to the posts.

    Thank you again!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic