WordPress.org

Ready to get started?Download WordPress

Forums

Akismet: "Your WordPress home URL is invalid." (2 posts)

  1. Ratspeed
    Member
    Posted 2 years ago #

    A few days back, I started getting the

    "Akismet is almost ready. You must enter your Akismet API key for it to work."

    message appearing again even though I've had Akismet key installed for a few weeks now.

    So I clicked to config it again, and the API key is field is empty. It invites me to get a new key. I input the key that was given for my account, and a gray box appears underneath saying:

    Your WordPress home URL is invalid. Please fix the home option.

    "Home Option" is a link to WP's settings page ( wp-admin/options.php#home ) but see no applicable fields. My siteurl seems is set properly, (http://brassandmortar.com ) and I haven't touched it.

    One thing that I DID touch was on cPanel, changing the document-root for the addon domain. My host's tech support reassured me that doing so would not cause any complications. I rarely trust their judgement.</conspiracy>

    I first emailed Akismet about this issue, and they requested I bring the problem up here.

    Hi,
    You don't need a new key.
    The key -omitted- is fine but something looks to be stopping Akismet from contacting the servers here. This could be for many reasons and this is why I suggest having a word over at http://wordpress.org/support

    Before coming to y'all I scoured Google for a solution to this, and the phrase "Please fix the home option." doesn't return any results that aren't hacked sites showing raw PHP. Could I be the only one in the world having this problem?

    One thing I noticed is that the raw code calls for a string:

    Your WordPress home URL %s is invalid.

    So apparently there should be a URL showing up, but judging from the returned string on the plugin settings page, that variable is being left empty when parsing the error.

    I've tried deleting Akismet and re-installing the plugin, and nothing changes. I also tried sticking 'www.' before my domain in the siteurl settings field and still nothing.

    Everything else on my site is functioning normally.

    Any suggestions?

    cPanel Version 11.30.6 (build 6)
    Apache version 2.2.20
    PHP version 5.2.17
    MySQL version 5.0.95-community

  2. lewis42
    Member
    Posted 1 year ago #

    Did you ever resolve this? Having the exact same problem.

    Can't find the 'home option' in the options page it links to. If I change the wordpress URL (which is correct) in general settings, it says that is invalid too.

Topic Closed

This topic has been closed to new replies.

About this Topic