WordPress.org

Ready to get started?Download WordPress

Forums

Akismet
Akismet plug-in produces White Screen of Death (44 posts)

  1. DSchuler
    Member
    Posted 5 months ago #

    I have been using the Akismet plug-in to blog comment spam from my blog for many years. In the last few days a new problem has occurred. When I attempt to go to my home page (http://theglitteringeye.com) I only get a white page. This does not occur when I access any other of my pages via direct link. I can access the admin dashboard.

    I have isolated the problem to Akismet. I deactivated all of my plug-ins--the problem went away. I reactivated Akismet--the problem recurred.

    My web host says that, since the plug-in is third-party, it's not their problem.

    If I deactivate Akismet, I get several hundred comment spam per hour. If I activate Akismet, I can't reach my home page.

    HELP!!!!!!

    https://wordpress.org/plugins/akismet/

  2. Jason Lemahieu (MadtownLems)
    Member
    Posted 4 months ago #

    Check your error logs to find out exactly what error is taking place, and post those details here.

  3. dusty1215
    Member
    Posted 4 months ago #

    I too got a fatal error when I updated to the newest version of this plugin. I have been using WP and akismet forever. This is wrong on every level. I had to go to great lengths to get this fixed and that includes having my hosting company help me which I hate as it costs me money. Fix it please. I can not update this plugin until it's fixed.

    leftwingnutjob.net

  4. dusty1215
    Member
    Posted 4 months ago #

    Warning: require_once(/home/content/43/7371043/html/wp-content/plugins/akismet/default.php) [function.require-once]: failed to open stream: No such file or directory in /home/content/43/7371043/html/wp-includes/template.php on line 2

    Fatal error: require_once() [function.require]: Failed opening required '/home/content/43/7371043/html/wp-content/plugins/akismet/default.php' (include_path='.:/usr/local/php5/lib/php') in /home/content/43/7371043/html/wp-includes/template.php on line 2

  5. BDaggerhart
    Member
    Posted 4 months ago #

    I'm getting the exct same errors as dusty1215, the entire site is shot right now.

    Thanks

  6. dusty1215
    Member
    Posted 4 months ago #

    I had to reset my blog back a couple of days and ignore the update to fix it. Only way I found to get around the fatal error.

  7. rodsee
    Member
    Posted 4 months ago #

    How do you reset a website back a couple of days? I know that I can do this for individual pages but is there a way to do the entire website?

    Previous post:

    I'm not sure if this issue belongs here or not.

    Yesterday, my dashboard showed that I needed to install some updates. I started at the top and Akismet 2.6.0 was the first one on the list. I clicked on 'Update Now' and when I tried to go back to the 'Plugin' page, the screen goes blank. I did the same thing on a second website and the same thing happened. Any suggestions? I don't know anything about Wordfence.

    Websites:
    http://www.naranonkc.org Twenty Eleven Theme
    http://www.naranonmidwest.org Twenty Twelve Theme

    I do not use Akismet on either site, I left it on my plugin list because I thought someday I might need to install it. I have updated it before and haven't had any issues.

    Please let me know how I can fix this problem. I can still update pages and events but cannot pull up my 'Plugin' page.

    Rod

  8. skogsstjrna
    Member
    Posted 3 months ago #

    I have the exact same problem as Rod. I wanted to upgrade to Akismet 2.6.0 and afterwards the whole plugin page turned white.

    I have no clue how to solve this. Please help out here!

  9. esmi
    Forum Moderator
    Posted 3 months ago #

    @skogsstjrna: If you require assistance then, as per the Forum Welcome, please post your own topic.

  10. jlptbootcamp
    Member
    Posted 3 months ago #

    It looks like they got the cart before the horse. WordPress 3.8 contains code that doesn't play nice with the new version of Akismet. Upgrading to 3.9 fixes the issue.

    Now, if you can't access the dashboard because akismet broke everything, you'll have to comment out the offending code.

    Go to <root>/public_html/wp-includes/template.php and put // before line 331 to comment out require_once(ABSPATH.'public_html/wp-content/plugins/akismet/default.php') or something similar.

    I upgraded and it deleted the code, so I'm not sure the exact code. But, I had the white screen of death, and commented out the code, then upgraded to 3.9 fixed everything.

    Hope this helps.

  11. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 3 months ago #

    jlptbootcamp: It looks like your version of WordPress was manually modified at some point; line 331 of wp-includes/template.php in 3.8 was blank. See this: https://core.trac.wordpress.org/browser/tags/3.8/src/wp-includes/template.php#L331

    Upgrading to 3.9 would indeed fix the issue, but so would reinstalling 3.8.

  12. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 3 months ago #

    DSchuler: Did you install WordPress manually, or was it an auto-install by your host? If by your host, which host are you using?

  13. jlptbootcamp
    Member
    Posted 3 months ago #

    Huh, well ain't that something. Why would code get edited that way? I thought it looked a little strange.

    I never hack the core so some other strange force must have done it. I'm not sure why I hacker would do that though.

    All I can remember was updating askimet lately. And the latest 3.8.3 security update.

  14. lutzcreativegroup
    Member
    Posted 3 months ago #

    I just attempted to update to Akismet 3.0.0. It did the download, but never activated. Now when I click on Installed Plugins I get a white screen. I can navigate to other areas of the CMS. I tried to updated to 3.9 after this happened and that too is a completely white screen. The site is up and functioning, just not the CMS. HELP!

  15. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 3 months ago #

    What other plugins do you have installed? And what theme are you using?

    Are you able to view your site's error log? If you are, any error that mentions Akismet would be helpful in resolving this.

  16. lutzcreativegroup
    Member
    Posted 3 months ago #

    I'm on WordPress 3.8.3
    Elegant Themes: Harmony (with child)
    Since I can't see any of the installed plugins, I can't tell you what they are.

    I honestly don't need Akismet since this site doesn't utilize Comments. I tried to delete the folder via FTP, but that didn't fix the issue. I put it back.

    I was able to get into Plugins > Editor and it looks like 3.0.0 was installed:

    <?php
    /**
     * @package Akismet
     */
    /*
    Plugin Name: Akismet
    Plugin URI: http://akismet.com/
    Description: Used by millions, Akismet is quite possibly the best way in the world to <strong>protect your blog from comment and trackback spam</strong>. It keeps your site protected from spam even while you sleep. To get started: 1) Click the "Activate" link to the left of this description, 2) <a href="http://akismet.com/get/">Sign up for an Akismet API key</a>, and 3) Go to your Akismet configuration page, and save your API key.
    Version: 3.0.0
    Author: Automattic
    Author URI: http://automattic.com/wordpress-plugins/
    License: GPLv2 or later
    Text Domain: akismet
    */
    
    /*
    This program is free software; you can redistribute it and/or
    modify it under the terms of the GNU General Public License
    as published by the Free Software Foundation; either version 2
    of the License, or (at your option) any later version.
    
    This program is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
    GNU General Public License for more details.
    
    You should have received a copy of the GNU General Public License
    along with this program; if not, write to the Free Software
    Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301, USA.
    */
    
    // Make sure we don't expose any info if called directly
    if ( !function_exists( 'add_action' ) ) {
    	echo 'Hi there!  I\'m just a plugin, not much I can do when called directly.';
    	exit;
    }
    
    define( 'AKISMET_VERSION', '3.0.0' );
    define( 'AKISMET__MINIMUM_WP_VERSION', '3.0' );
    define( 'AKISMET__PLUGIN_URL', plugin_dir_url( __FILE__ ) );
    define( 'AKISMET__PLUGIN_DIR', plugin_dir_path( __FILE__ ) );
    define( 'AKISMET_DELETE_LIMIT', 100000 );
    
    register_activation_hook( __FILE__, array( 'Akismet', 'plugin_activation' ) );
    register_deactivation_hook( __FILE__, array( 'Akismet', 'plugin_deactivation' ) );
    
    require_once( AKISMET__PLUGIN_DIR . 'class.akismet.php' );
    require_once( AKISMET__PLUGIN_DIR . 'class.akismet-widget.php' );
    
    add_action( 'init', array( 'Akismet', 'init' ) );
    
    if ( is_admin() ) {
    	require_once( AKISMET__PLUGIN_DIR . 'class.akismet-admin.php' );
    	add_action( 'init', array( 'Akismet_Admin', 'init' ) );
    }
    
    //add wrapper class around deprecated akismet functions that are referenced elsewhere
    require_once( AKISMET__PLUGIN_DIR . 'wrapper.php' );
  17. lutzcreativegroup
    Member
    Posted 3 months ago #

    Since installing Akismet 3.0.0 I get the white screen on these pages:

    /wp-admin/update-core.php
    /wp-admin/plugins.php

  18. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 3 months ago #

    If deleting the akismet/ folder via FTP didn't help, then either you're running an APC cache that is caching the files, or the error isn't related to Akismet.

    Try deleting the contents of the file via the plugin editor and/or deleting the folder (and any akismet.php file in the same directory) again and let me know if that allows you to see what plugins you're running.

  19. lutzcreativegroup
    Member
    Posted 3 months ago #

    It's gotta be something to do with Akismet. Before I hit Update I didn't have a white screen.
    I do not believe I am running any caching software.

    So go into Plugins > Editor and select Akismet and delete the PHP in there?

    Here are the plugins I can see via FTP (of these, I am not sure which are active):
    add-logo-to-admin
    addthis
    akismet
    all-in-one-event-calendar
    all-in-one-seo-pack
    backupbuddy
    captcha
    cms-tree-page-view
    contact-form-7
    contact-form-7-to-database-extension
    elegant-theme-updater
    email-encoder-bundle
    ithemes-sync
    jetpack
    post-types-order
    really-simple-captcha
    ultimate-coming-soon-page
    wordpress-seo

  20. lutzcreativegroup
    Member
    Posted 3 months ago #

    There are all these files accessible by the editor.

    akismet/index.php
    akismet/class.akismet.php
    akismet/wrapper.php
    akismet/readme.txt
    akismet/class.akismet-admin.php
    akismet/class.akismet-widget.php
    akismet/_inc/akismet.css
    akismet/_inc/akismet.js
    akismet/_inc/form.js
    akismet/views/start.php
    akismet/views/stats.php
    akismet/views/strict.php
    akismet/views/notice.php
    akismet/views/get.php
    akismet/views/config.php
    akismet/akismet.php

  21. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 3 months ago #

    > So go into Plugins > Editor and select Akismet and delete the PHP in there?

    Yes, just delete everything you can from that file; that should prevent Akismet from running at all.

  22. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 3 months ago #

    Just removing the code from akismet/akismet.php should be sufficient.

  23. lutzcreativegroup
    Member
    Posted 3 months ago #

    Well, I deleted the code that was part of akismet/akismet.php and clicked Update File. Then clicked on Installed Plugins, still white screen.
    Then went back to Plugins > Editor and Akismet is no longer an option.
    I have never encountered anything like this (white screen in some places) before. Truly baffled.

  24. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 3 months ago #

    The next step I would take would be to contact your webhost and ask them to restart Apache (or whichever Web server software you're running) on your site. In the case that there is some cache software running that you're not aware of, that usually helps to fix problems with it.

  25. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 3 months ago #

    For what it's worth, I installed and activated all of those plugins and wasn't able to get a white screen. My top guesses are either that you're running a version of WordPress that your host has modified, or that a cache somewhere thinks that some plugin files exist that really don't. Either way, contacting your host is the way to go.

  26. lutzcreativegroup
    Member
    Posted 3 months ago #

    Apache restart didn't fix it.

  27. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 3 months ago #

    The next step would be getting ahold of the error log and see what errors show up there when you try to access any of the pages that are white-screening.

  28. lutzcreativegroup
    Member
    Posted 3 months ago #

    This site has been sitting here for a bit. I went in tonight to add some content and saw some updates. The first plugin I went to update was Akismet. Got the white screen. I thought maybe updating to 3.9 might right the ship. That too gave me a white screen.

    I have a Dedicated Virtual server with MediaTemple.

  29. lutzcreativegroup
    Member
    Posted 3 months ago #

    When I view the error log for the offending /plugins.php it too is blank.

  30. lutzcreativegroup
    Member
    Posted 3 months ago #

    Same with /update-core.php

Reply »

You must log in to post.

About this Plugin

About this Topic