WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Akismet Installed - Still Getting Slammed by Spam (6 posts)

  1. nrepair
    Member
    Posted 4 years ago #

    I have getting several spam messages each day, and virtually none of them are being identified by Akismet. I have my blog settings so that a commentor must have a previously approved comment, so the spam is held in queue until I mark it as spam. I just can't understand why Akismet isn't catching them without me having to manually flag them. They are obviously spam, since most are for sex-enhancing drugs.

    Anything I can do to make Akismet work better?

  2. Brandon Allen
    Member
    Posted 4 years ago #

    Just to cover the basics. Have you entered your API key? Assuming you did set it up properly, and that you are running the most current version (I assume this is the case since you're using WP 2.9.1), they have a "Server Connectivity" section of Akismet Configuration page which will let you know if you're connecting to Akismet's servers properly. If they're not all green, that could be the problem. One plugin I've found very handy, is Cookies for Comments.

  3. nrepair
    Member
    Posted 4 years ago #

    I don't see a configuration page. How do I access it?

  4. Brandon Allen
    Member
    Posted 4 years ago #

    In the "Plugins" dropdown, of your dashboard, you'll see "Akismet Configuration." This will only show up, however, if you have Akismet activated.

  5. nrepair
    Member
    Posted 4 years ago #

    I think something was wonky with my installation. It was preinstalled with WordPress by my web host. I removed it and reinstalled it from scratch and it seems to be working properly.

    Thanks for your help!

  6. Brandon Allen
    Member
    Posted 4 years ago #

    No worries. Glad to help. Please mark as resolved.

Topic Closed

This topic has been closed to new replies.

About this Topic