WordPress.org

Ready to get started?Download WordPress

Forums

Akismet has detected a problem (9 posts)

  1. humbleopinion
    Member
    Posted 3 years ago #

    I keep getting this message from Akismet:

    Akismet has detected a problem. A server or network problem prevented Akismet from checking 1 comment. It has been temporarily held for moderation and will be automatically re-checked in 13 mins.

    It started yesterday, I have gone to the Akismet site and it said there are no problems, but it is getting annoying. There are no comments in moderation.

    Thanks in advance!

  2. Joseph Scott
    Member
    Posted 3 years ago #

    Are you using version 2.5.1 of the Akismet plugin? It had bug fixes for a few edge cases, which you may be seeing.

  3. cadfile
    Member
    Posted 3 years ago #

    The phantom upgrade came up again and I upgraded manually (downloaded files and FTP'd them to my site) now got several moderation e-mails with Akismet claiming there was a problem.

    This time the offending spam ended up in the trash which is fine but the way the plugin is acting is bothering me.

    I contacted my host and they said to contact you guys.

    What kind of question should ask my host.

    By the way when I looked at my fresh akismet.php file I found this on line 31:

    'define('AKISMET_VERSION', '2.5.0');' even though the title block said 2.5.1

  4. Joseph Scott
    Member
    Posted 3 years ago #

    We forgot to bump the AKISMET_VERSION constant, that was our bad. Won't cause any problems though.

    One of the other people who reported similar issues was able to resolve it by increasing the timeout value for HTTP requests made to aksimet.com to check comments.

    If you open up akismet.php, starting on line 128, modify it to look like:

    $http_args = array(
                'body'          => $request,
                'headers'       => array(
                    'Content-Type'  => 'application/x-www-form-urlencoded; ' .
                                        'charset=' . get_option( 'blog_charset' ),
                    'Host'          => $host,
                    'User-Agent'    => $akismet_ua            ),
                'httpversion'   => '1.0',
                'timeout'       => 15
            );

    Basically just add the timeout parameter at the bottom and set it to 15.

    Give that a try and let us know how it goes.

  5. cadfile
    Member
    Posted 3 years ago #

    Thanks for the suggestion. I will try it out and let you know

  6. jcglobalcitizen
    Member
    Posted 3 years ago #

    Hello,

    I tried the suggestion above, added that 'timeout' and this is the results:

    Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in akismet.php on line 136

  7. cadfile
    Member
    Posted 3 years ago #

    Make sure you add the comma to the httpversion line - the line unaltered doesn't have the comma so unless you add it, it may cause an error

    Also make sure the timeout line is inside the );

  8. Joseph Scott
    Member
    Posted 3 years ago #

    Yep, typo in the changes you made somewhere.

    I've increased the timeout in the development version of the plugin, so if you want to try that you can get the files from https://plugins.svn.wordpress.org/akismet/dev/

  9. blogachover
    Member
    Posted 3 years ago #

    I have this problem with one comment in Akismet 2.5.2. It has successfully blocked all kinds of spam comments, even today, but is saying this about 1 comment -- I'm guessing that it's one comment, because the amount of time before it will be automatically re-checked keeps doubling, now up to 8 days.

    When will it give up? Is there any way to find and delete this comment?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags