WordPress.org

Ready to get started?Download WordPress

Forums

Akismet has detected a problem (15 posts)

  1. dhin
    Member
    Posted 5 years ago #

    When I log in I saw text below

    Akismet has detected a problem. A server or network problem is preventing Akismet from working correctly. Click here for more information about how to fix the problem.

    And when I click on Click here for more information

    Server Connectivity

    Unable to reach any Akismet servers.

    A network problem or firewall is blocking all connections from your web server to Akismet.com. Akismet cannot work correctly until this is fixed. Please contact your web host or firewall administrator and give them this information about Akismet and firewalls.

    What I must do?

    Thank you

  2. dyates
    Member
    Posted 5 years ago #

    Follow the 'Click here for more information' link and try clicking on the “Check network status” button.

    I think it is a bit of a glitch caused by the new upgrade to Akismet. I checked with my host and there were no such blocks in place and the domain was not black-listed. Clicking this button probably refreshes the system. Certainly it seems to resolve the problem and cleared the alert message and shows that everything is running fine.

  3. bondobbs
    Member
    Posted 4 years ago #

    I am also having this problem and have been for about 3 days. When I click the button you suggest I get:

    The key you entered could not be verified because a connection to akismet.com could not be established. Please check your server configuration.

    on the top button and

    Unable to find Akismet servers.

    on the bottom.

    When will this be fixed? I think I am going to have to try downgrading akismet

  4. bondobbs
    Member
    Posted 4 years ago #

    This situation is completely pissing me off. Akismet, google analytics, and wordpress dev blog are all bombing. Did the 2.8.4 upgrade kill the ability to make external connections? The blog stats seems to work, but everything else is broken and has been for a week. Can SOMEONE roll out a new version that fixes this problem? I'm annoyed.

  5. bondobbs
    Member
    Posted 4 years ago #

    OK guys. I solved this problem! It was that my hosting company (jumpline) added allow_url_fopen = Off to the php.ini (security I guess). I overrode it in my user version of the php.ini and the problem immediately went away.

  6. rexgoode
    Member
    Posted 4 years ago #

    bondobbs, I also use jumpline. I overrode it, restarted my server, and the problem did not go away. What was the line you put in your user version of php.ini?

    I put:

    allow_url_fopen = On

  7. bondobbs
    Member
    Posted 4 years ago #

    Yes, I put that at the end of my user ini file:

    magic_quotes_gpc = 1
    magic_quotes_runtime = 0
    file_uploads = 1
    session.auto_start = 0
    session.bug_compat_warn = 0
    safe_mode=off
    memory_limit=128M
    session.save_handler=files
    post_max_size = 16M
    upload_max_filesize = 16M
    allow_url_fopen = On

    Is the current content. I restarted the server and then "checked network status" again. It cleared up immediately.

  8. st0kk
    Member
    Posted 4 years ago #

    I got the same problem.
    Verified that allow_url_fopen = On
    gethostbyname (i cant find that when i preform phpinfo)
    But sice it has worked before, it should work now.

    Apache/2.0.59 (Unix) DAV/2 PHP/5.1.6
    Wordpress 2.8.4
    Akismet 2.2.6

    It's been working until sunday... since a coupple off years.

  9. st0kk
    Member
    Posted 4 years ago #

    Found my problem and solved it.
    It had nothing to do with wordpress or akismet.

    Broken dns was my issue.

  10. velvetpixel
    Member
    Posted 4 years ago #

    I am getting the "Akismet cannot work correctly until this is fixed" error also.

    My iptables has:
    :OUTPUT ACCEPT [0:0]

    My PHP config has:
    allow_url_fopen => On => On

    How do I stop this error?

  11. h4x3d
    Member
    Posted 4 years ago #

    same, seems bust somehow :(

  12. msebald
    Member
    Posted 4 years ago #

    I have the same problems with two WordPress installations on my server starting the last night. I did not change anything since yesterday.

    Akismet on a third WordPress installation on the same server is wirking fine.

    All three installations are running WordPress 2.8.5. url_fopen is enabled on all installations.

    I restarted Apache2 and BIND DNS, wasn't successful.

  13. nc130
    Member
    Posted 4 years ago #

    i have de same problem :(

    wget rest.akismet.com
    --2009-10-26 15:55:35-- http://rest.akismet.com/
    A resolver rest.akismet.com...72.233.69.2, 72.233.69.3
    A conectar rest.akismet.com|72.233.69.2|:80... conectado.
    Pedido HTTP enviado, a aguardar resposta...200 OK

    allow_url_fopen On On

    iptables -L
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Akismet has detected a problem. A server or network problem is preventing Akismet from working correctly. Click here for more information about how to fix the problem.

    Server Connectivity

    Unable to find Akismet servers.

    Apache+ PHP 5.2.9
    Wordpress 2.8.4
    Akismet 2.2.6

  14. nc130
    Member
    Posted 4 years ago #

    partially solved width:
    add to /etc/hosts
    72.233.69.2 rest.akismet.com

  15. Alex Shiels
    Member
    Posted 4 years ago #

    This explains what you need for Akismet to work:

    http://blog.akismet.com/akismet-hosting-faq/

    fsockopen and gethostbynamel must be available.

Topic Closed

This topic has been closed to new replies.

About this Topic