WordPress.org

Ready to get started?Download WordPress

Forums

Akismet
Akismet 2.5.0 server/connection problem (40 posts)

  1. angliss
    Member
    Posted 3 years ago #

    I just installed Akismet 2.5.0 this morning and ever since I've been getting the following errors:

    "kismet has detected a problem. A server or network problem prevented Akismet from checking 2 comments. They have been temporarily held for moderation and will be automatically re-checked in 20 mins."

    and

    "The key below was previously validated but a connection to akismet.com can not be established at this time. Please check your server configuration."

    What's the problem here?

  2. Usually those things iron themselves out within the hour.

    Unfortunately, it's hard to tell if the problem is on Akismet's end or your server's end, but I'm reasonably sure that the problem wasn't on Akismet's end (otherwise there'd be quite a few more folks with the problem).

    If you're still having the problem, please contact Akismet support directly at http://akismet.com/contact/

  3. angliss
    Member
    Posted 3 years ago #

    Thanks - it hasn't resolved itself, so I submitted a technical help request at Akismet.com. Some more time Googling for similar issues has turned up others who have had the same issue, some of which resolved and others which did not.

    We'll see what happens.

  4. upgradetravelbetter
    Member
    Posted 3 years ago #

    I've had similar issues (..."A server or network problem prevented Akismet from checking 2 comments. They have been temporarily held for moderation and will be automatically re-checked in 20 mins....") on and off since upgrading to 2.50.

    I have not had the problems re: key validation that the OP reports.

  5. mza
    Member
    Posted 3 years ago #

    I updated Akismet version this morning, and when I click on Akismet Stats it takes forever for the page to download. I see some of it, but the graphs aren't showing, instead it lists the names of the graphs(hyperlinked). I have tried deactivating, and then activating it.

  6. Joseph Scott
    Member
    Plugin Author

    Posted 3 years ago #

    We've found that if a server can't reach akismet.com it is almost always due to a firewall, proxy server or network change at your hosting provider. Sometimes the problem comes and goes quickly, so 2.5 schedules periodic rechecks when it is unable to reach akismet.com.

    The graphs not showing up properly is a known issue at this point and we are working on an update to address that.

    As always, we are available to answer questions at akismet.com/contact/

  7. angliss
    Member
    Posted 3 years ago #

    I'll see if my host's firewall is the problem. Are there specific ports, IP addresses, or what have you that need to be opened in the firewall to permit Akismet to work right?

    Note that 2.4.n was working just fine through the firewall, but 2.5.0 may not be, so if changes were made to where/how Akismet is looking for spam info now, that would suggest that it's those changes that need to be opened up in the firewall.

    I submitted my original problem (top of this thread) via the contact link this AM but have received no response yet.

  8. godsofchaos
    Member
    Posted 3 years ago #

    Yep,

    Same problem here. At first I thought it was an issue with Mod_Security and Googled it - what I found?

    to change the file located here:
    /etc/httpd/modsecurity.d/modsecurity_crs_10_config.conf

    Ctrl+F: Find the line Below
    SecResponseBodyLimit 524288

    Replace it with:
    SecResponseBodyLimit 524288

    Did that and it still didn't work.

    I think this can also be an issue with ConfigServer Firewall and it may just help everyone (including Akismet) if we also include our relevant known server setup that might correspond to this particular problem's actual cause.

    Here goes mine:

    WordPress 3.03
    Akismet - 2.50
    Apache 2.2 (with low timeout)
    PHP 5.2.14
    Running Mod_Security
    Running ConfigServer Firewall with SynFlood Protection.
    Sysctl.conf includes Syn_Flood protection - On
    Custom HTaccess ruleset which shouldn't be relevant I think.

  9. Joseph Scott
    Member
    Plugin Author

    Posted 3 years ago #

    I have good news about the graphs - they should now all be fixed.

  10. cimddwc
    Member
    Posted 3 years ago #

    I got this "A server or network problem prevented Akismet from checking 1 comment..." message today, too. But it doesn't seem to go away, i.e. after the displayed minutes, it just starts its countdown again. (While other spam comments still get successfully marked as spam, so it's no permanent connection problem.)

    Some hours ago, I had received a standard "please moderate" mail for a typical spam comment with many links – so seemingly just one that Akismet didn't catch – and clicked the link to mark it as spam. Only after that I noticed this problem message for the first time (having installed 2.5.0 the day it was released). Some time later, I deleted all the spam that had accumulated with the "empty spam" button, but the problem message persists. Is Akismet trying to re-check a comment that no longer exists? And if so, how to turn this message off? (Even if it means editing a database entry.)

    On another note, I noticed that my wp_commentmeta table is filling with hundreds of akismet_* entries, mostly akismet_history and akismet_result. That's obviously related to the new features – but I hope those will be expired after a certain time and not flood the database with eventually tens of thousands of entries... will they?

  11. Joseph Scott
    Member
    Plugin Author

    Posted 3 years ago #

    Sounds like your server might be having issues reaching akismet.com to check comments for spam.

    I've confirmed the issue with the comment_meta data and we are going to include a fix in the next release.

  12. cimddwc
    Member
    Posted 3 years ago #

    Thanks for the reply. Well, Akismet successfully caught 44 spams over night but still displays this "...from checking 1 comment".

    I investigated a bit more: There's this one "akismet_error" db entry which contains the very same comment_id as the "please moderate" comment I mentioned yesterday, which I deleted – so Akismet is indeed trying to re-check a comment that doesn't exist anymore: function akismet_check_db_comment, which is called from akismet_cron_recheck, returns an empty result since $wpdb->get_row returns nothing from the comment table, and thus akismet_cron_recheck in its "else" section just reschedules the recheck.

    Or in other words: akismet_check_db_comment (and thus akismet_cron_recheck) doesn't distinguish between "comment doesn't exist anymore" and "akismet_http_post, the communication with akismet.com, had an error and returned ''"...

  13. Joseph Scott
    Member
    Plugin Author

    Posted 3 years ago #

  14. mormonstories
    Member
    Posted 3 years ago #

    I'm current w/ my upgrades and am still experiencing this problem...fwiw.

  15. MountainPhotographer
    Member
    Posted 3 years ago #

    Still experiencing this connection problem here too. I've only started seeing this issue with the upgrade to 2.5.1 from 2.4. I have not changed any server settings.

    I am also getting comment-moderation emails for clearly spam comments now.

  16. Joseph Scott
    Member
    Plugin Author

    Posted 3 years ago #

    Versions previous to 2.5 did not look for errors when connecting to akismet.com, those errors were simply ignored.

  17. kirkmc
    Member
    Posted 3 years ago #

    I'm having the same problems with Akismet 2.5.1. Frankly, it's become more or less useless. Server time-outs and tons of spams that come into my inbox for moderation... Is there anything I can do about this? Before 2.5, it worked great. I'm tempted to go back to an older version.

  18. Joseph Scott
    Member
    Plugin Author

    Posted 3 years ago #

    The next version of the plugin will have an increased timeout value for HTTP requests.

    If you don't want to wait for the next release you can use the development version, files are available https://plugins.svn.wordpress.org/akismet/dev/ - just be aware that this is the development version and not a full release yet.

  19. Yui
    Member
    Posted 3 years ago #

    I ve encountered similar problem after update, akismet 2.5.x is unable to check the comments, even when network is available, i've figured where was the problem for my server

    This is the working configuration for curl extension:

    cURL support enabled
    cURL Information 7.21.2
    Age 3
    Features
    AsynchDNS No
    Debug No
    GSS-Negotiate No
    IDN Yes
    IPv6 No
    Largefile Yes
    NTLM Yes
    SPNEGO No
    SSL Yes
    SSPI No
    krb4 No
    libz Yes
    CharConv No
    Protocols dict, file, ftp, ftps, gopher, http, https, imap, imaps, pop3, pop3s, rtsp, smtp, smtps, telnet, tftp
    Host i686-pc-linux-gnu
    SSL Version OpenSSL/1.0.0c
    ZLib Version 1.2.5

    when compiled with GnuTLS instead of OpenSSL and IPv6 support ON - problem with checking comments pop up. I havent tested IPv6+OpenSSL and GNUTLS without IPv6, so i cannot say what exactly is the culprit Ipv6 or GnuTls.

    If you have same problem - run <?php phpinfo(); ?> and post your curl config.

  20. kirkmc
    Member
    Posted 3 years ago #

    Joseph, do I just drop all of those files into the aksimet folder?

    Should there be an update soon?

  21. Joseph Scott
    Member
    Plugin Author

    Posted 3 years ago #

    If you want to use it, yes, you can save all of those in directory and enable it.

    There's is a schedule for the next release yet.

  22. Yui
    Member
    Posted 3 years ago #

    This curl config is bad:

    cURL support enabled
    cURL Information 7.21.2
    Age 3
    Features
    AsynchDNS Yes
    Debug No
    GSS-Negotiate No
    IDN Yes
    IPv6 Yes
    Largefile Yes
    NTLM Yes
    SPNEGO No
    SSL Yes
    SSPI No
    krb4 No
    libz Yes
    CharConv No
    Protocols dict, file, ftp, ftps, gopher, http, https, imap, imaps, pop3, pop3s, rtsp, smtp, smtps, telnet, tftp
    Host i686-pc-linux-gnu
    SSL Version GnuTLS/2.10.4
    ZLib Version 1.2.5

    and cause
    Akismet has detected a problem. A server or network problem prevented Akismet from checking 1 comment. It has been temporarily held for moderation and will be automatically re-checked in 19 mins.

  23. jcglobalcitizen
    Member
    Posted 3 years ago #

    I'm experiencing this too, and it gets worse these last 2 days. It's sooooooo baaaadddd...

    I got tons of e-mails of comments approval, can reach hundreds and hundreds in one day. And today even worse, even SPAM comments also asking for approval.

  24. jcglobalcitizen
    Member
    Posted 3 years ago #

    Forgot to inform, my site is BALTYRA.com and my Akismet is 2.5.1

    Akismet has detected a problem. A server or network problem prevented Akismet from checking 12 comments. They have been temporarily held for moderation and will be automatically re-checked in 18 min.

    That was the last message I got. So terrible.

  25. Joseph Scott
    Member
    Plugin Author

    Posted 3 years ago #

    Have you tried the development version?

  26. jcglobalcitizen
    Member
    Posted 3 years ago #

    Which one the development version?

  27. Joseph Scott
    Member
    Plugin Author

    Posted 3 years ago #

    Please review the thread before adding on to it, I mentioned and linked to the development version earlier in this thread - http://wordpress.org/support/topic/akismet-250-serverconnection-problem?replies=26#post-1880663

  28. Yui
    Member
    Posted 3 years ago #

    jcglobalcitizen - svn version, Joseph already dropped this link in this thread: https://plugins.svn.wordpress.org/akismet/dev/

    2 Joseph: with dev version "bad" cURL works too, posting a comment is quite slow (due to checking), but Akismet works. TY.

  29. Joseph Scott
    Member
    Plugin Author

    Posted 3 years ago #

    Concerns over delays is one reason why the timeout was kept low. You may want to ask your hosting provide for help in determining why HTTP requests to akismet.com from your server/WordPress install are slow. A traceroute from your server would be a good start.

  30. jcglobalcitizen
    Member
    Posted 3 years ago #

    Sorry Guys, I didn't look it carefully. I'll be trying immediately. However, currently I deactivated Akismet, and all the discussions are toll-road speed. No delay at all.

    Meanwhile, like what you suggested, I'll check with my hosting. But, the strange thing is why it didn't happen with older version? Same hosting, same conditions, even more traffic.

    Thanks a lot.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags