WordPress.org

Ready to get started?Download WordPress

Forums

The Events Calendar
[resolved] Ajax loading gif disappeared (5 posts)

  1. Skinny_Latte
    Member
    Posted 1 year ago #

    Hi,

    Since the upgrade to 2.0.10 the loading gif that normally appears when I switch months or years using the dropdown boxes has disappeared. Any ideas why that might be?

    Site is here

    Thanks

    http://wordpress.org/extend/plugins/the-events-calendar/

  2. Skinny_Latte
    Member
    Posted 1 year ago #

    Have reverted to 2.0.09 for now as the upgrade also broke some tabs on the homepage because of an error in the pjax file

  3. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    Hey Skinny_Latte. Thanks for the post here; sorry to hear you're having problems and that you had to revert to 2.0.9. We've had a few reports of this and it's due to the fact that we updated the jQuery used in 2.0.10 so that it was current and compliant with WP's standards.

    As a result, certain themes/sites that aren't running the latest jQuery saw things break. When I just checked the version of jQuery running on your site there it is 1.4.4; since The Events Calendar uses whatever version of jQuery ships with WP (as of 3.5, this is at least 1.7.2), any site running below 1.7.2 is going to encounter problems. It looks like in your case either your theme or another plugin is swapping the default jQuery for some older version, which is leading to these display problems.

    Sorry I couldn't offer up more. If you can find out what the conflict is caused by, I would definitely encourage updating so that you can run the latest 2.0.10 release (which includes a number of stability improvements over 2.0.9). If you have any other questions I can answer to help ease that, please do let us know.

  4. Skinny_Latte
    Member
    Posted 1 year ago #

    Thanks very much for your reply roblagatta.

    Apologies for not spotting this as my own error!

    I will make some changes and then update and see if I can get things working correctly again.

    Thanks

  5. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    Glad to be of service, Skinny_Latte. Thanks for the follow-up - once you've had a chance to jump into this, let me know what you come up with or if you have further questions. Cheers!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.