WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Ajax Interfering with post/category deletion/addition? (5 posts)

  1. Joni
    Member
    Posted 6 years ago #

    I've searched here and haven't found a solution or a problem quite similar to mine.

    This is a fresh install of WP 2.3.3. I notice that I cannot add categories either in the Dashboard or writing area. I also cannot delete posts or comments in the Dashboard.

    It seems to be an ajax problem because I get that fader effect that everyone is so in love with, and then my site's 404 page displays.

    I CAN delete posts if I go to the post itself and use the red Delete button (ajax is not involved apparently).

    Any thoughts as to how this can be solved? Can I "turn off" ajax or work around it somehow to be able to create new categories?

    Thanks.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Some people have trouble with this stuff and overly restrictive mod_security rules.

    Try adding this to the top of your .htaccess file, see if it makes the problem stop:

    <IfModule mod_security.c>
    SecFilterEngine Off
    </IfModule>

    That simply turns off mod_security. See if it helps any. If so, then you know that mod_security is the problem.

    The answer to your question, BTW, is no. WordPress does not support non-AJAX ways of doing everything, although some changes are being made in that regard. But here's the thing, AJAX is not your problem. If your server is returning 404's and such, then the problem is that the server is doing something wrong. Fix the problem, not the symptom.

  3. Joni
    Member
    Posted 6 years ago #

    Thanks, Otto. I'll try that fix and post back here one way or another.

  4. Joni
    Member
    Posted 6 years ago #

    Hmm. THIS code was already in there.

    <IfModule mod_security.c>
    SecFilterSelective REQUEST_URI ".*db_adodb\.php\?.*" chain
    SecFilterSelective QUERY_STRING ".*baseDir=http:\/.*
    </IfModule>
  5. Joni
    Member
    Posted 6 years ago #

    Otto, you ROCK! I took out that other code and substituted what you had provided and it works!

    Thanks you!!!

Topic Closed

This topic has been closed to new replies.

About this Topic