WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Aggravating 500 Internal Server Error comes and goes?? (8 posts)

  1. hypeon
    Member
    Posted 2 years ago #

    Hello! Help needed pleeeeease.

    I am getting random 500 errors on different pages on my site. Link: http://www.thebridgendmash.com, refreshing the page helps to load the site but then it crops up somewhere else when browsing around, so it isn't consistent with either page. It also occurs sometimes on the dashboard but again, refreshing usually loads as normal.

    Notable changes:
    -Upgraded from 3.1.1 to 3.2.2 not sure if this had anything to do with it but that's the last major change.
    - When the site was launched it had experienced high levels of traffic in roughly a three hour stretch, not sure if this has anything to do with it either.

    Troubleshooting:
    - Tried the delete .htaccess > Upload blank new version > access settings technique but that didn't seem to work either.
    - Tried the error logs but most all of them refer to PHP errors which have already been rectified during the development process.
    - Tried deactivating all plugins to see if it affected it, no change there.
    - Looked in the access-logs but couldn't really decipher what I was suppose to be looking for.

    The error is below. Any other troubleshooting techniques or general help would be greatly appreciated, I'm a bit out of my depth here so any advise is welcome!! It's really irritating since the client is happy with the site except for this irritating problem.

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@thebridgendmash.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

  2. chrismccorkle
    Member
    Posted 2 years ago #

    This happened with a few sites of mine a while back. I was using shared web hosting, and the sites were maxing out their user's allotted processing power.

    I created a new hosting user on the same account (they didn't mind), then moved one of the sites to it. This fixed the intermittent 500 errors. I confirmed this with tech support and using the top command via ssh.

  3. hypeon
    Member
    Posted 2 years ago #

    Thank you, I'm gonna enquire this with my host. It's on a reseller shared host so it may be the same problem you had. I tried opening 10 tabs at the same time and the 500 errors always came on the last 2 or 3 pages that were trying to load so I think you're right. I shall return with some answers.

  4. chrismccorkle
    Member
    Posted 2 years ago #

    That's exactly what happened to me. Good luck.

  5. hypeon
    Member
    Posted 2 years ago #

    "As we have enabled CloudLinux, this is not possible. We have allotted all customers an equal share of the server so not one user can not monopolize the server resources."

    That's was in response to asking if it was possible to expand on the alloted processing power.

    They suggested caching plugins which I've never had to venture into (due to the small scale sites I usually do) so I'm gonna have to run with that, could you recommend better hosts that can deal with high levels of traffic if in worse case I have to shift this site to a different host?

  6. chrismccorkle
    Member
    Posted 2 years ago #

    My shared web host limited resources on a per-user basis, not per-customer. Customers are allowed a number of users per account, which has helped me reduced those errors.

    View your usage and limits info with the TPC! Memory Usage plugin.

    Then install WP Super Cache and WP Widget Cache. Check your usage after a while.

  7. Shared hosts will always answer that way; they can't and won't adjust things for one account. Bluehost is a good host, and their Pro servers are not CPU throttled. Recommended WordPress Web Hosting

    Super Cache is good. Bump your memory allocation, too: try adding the line below near the top of your wp-config.php file, right after the opening <?php

    define('WP_MEMORY_LIMIT', '64M');

  8. hypeon
    Member
    Posted 2 years ago #

    I actually did the plugin thing and it seems to work (although the traffic has died down a bit) but the problem lay in the CPU throttling, which would explain the inconsistent 500 error. But yes, I'll try what you mentioned so thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic