WordPress.org

Ready to get started?Download WordPress

Forums

After Upgrading I Get 404 For Anything Admin Related (24 posts)

  1. ljutic213
    Member
    Posted 1 year ago #

    I just automatically upgraded to 3.4.2 and now I can't access anything related with wp-admin. My site is http://askagoose.com and every time I go to http://askagoose.com/wp-admin it takes me to http://askagoose.com/wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2F.

    I googled this topic quite a bit and deleted everything in my plugins folder as one option but nothing changed.

    Please help!

    Jed

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Try:
    - switching to the Twenty Eleven theme by renaming your current theme's folder inside wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

    - running the upgrade manually via wp-admin/upgrade.php

  3. ljutic213
    Member
    Posted 1 year ago #

    Wow. Thanks for the quick reply! I know just enough to be dangerous in the world of wordpress so please bare with me.

    I renamed my current theme to "nameoftheme-old" and now just a blank white page pops up. Is that what you meant by the first suggestion. If so, I take it I should move on down the list to the other suggestions???

    Thanks so much!

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Re-upload a fresh, unpacked, copy of the Twenty Eleven folder to wp-content/themes using FTP or whatever file management application your host provides.
    http://wordpress.org/extend/themes/twentyeleven

  5. ljutic213
    Member
    Posted 1 year ago #

    Or, after reading your post again, do you mean I should do all four at the same time?

    Never mind...trying to the upload now. Thanks!

  6. vjpo
    Member
    Posted 1 year ago #

    I got the same upgrade.php?_wp_http_referer=%2Fwp-admin%2F redirect after upgrading from 3.4.1 to 3.4.2 on two sites where W3 Total Cache plugin was activated. After deactivating this plugin I logged into a 3.4.2 dashboard successfully and then activated W3 again.
    So, it's better to disable W3 Total Cache before upgrading.

  7. ever8302
    Member
    Posted 1 year ago #

    I'm having the same problem. How did you manage to deactivate the plugin when you couldn't access the dashboard @vjpo. Sorry to be so dense - please help.

  8. ever8302
    Member
    Posted 1 year ago #

    Figured that out - thank you :)

  9. floydrose5150
    Member
    Posted 1 year ago #

    Same thing just happened to me, so this is a quick fix: (if you upgraded without disabling total cache)

    1) Go in via FTP to your site
    2) In your plugins folder, locate w3-total-cache
    3) Rename it to something like w3-total-cache_bak
    4) Go to your wp-content folder and rename these following files
    - advanced-cache.php to advanced-cache.php_bak
    - db.php to db.php_bak
    - object-cache.php to object-cache.php_bak

    Now try and access your wp-admin dashboard.

    You should get in no probs.Go back to your FTP and rename your w3-total-cache_bak folder to it's original name w3-total-cache

    You will be prompted with errors saying the files you renamed are not installed. Go back one at a time and rename them back and you're golden.

    Whole process took 1 minute. Hope this helps you.

  10. ever8302
    Member
    Posted 1 year ago #

    Thank you so much for responding. I followed the steps you outlined and now get this message:
    W3 Total Cache Error: some files appear to be missing or out of place. Please re-install plugin or remove /home/content/42/8930942/html/wp-content/object-cache.php.

  11. ever8302
    Member
    Posted 1 year ago #

    I'm back to again to the original message :)

  12. dailydishrecipes
    Member
    Posted 1 year ago #

    ditto - on the phone with my hosting company for the past half hour and even they are struggling to figure out what happened. This is actually the first "upgrade" I've ever had trouble with in all my years with wordpress, but it's also pretty frustrating.
    Has anyone figured out a solid solution yet?

  13. floydrose5150
    Member
    Posted 1 year ago #

    Try renaming the 3 files one more time, and the actual w3-total-cache directory. See if you can get back in. Then we'll go from there. Let me know.

  14. ever8302
    Member
    Posted 1 year ago #

    I also see a file called w3-total-cache-config-preview.php - does that need to be renamed too?

  15. ever8302,

    Yes you need to delete or rename that file too. Also you might need to delete or back up your .htaccess then once your able to login again refresh your permalinks by going to settings -> permalinks and saving.

  16. floydrose5150
    Member
    Posted 1 year ago #

    I didnt delete the config-preview in my case and all worked, but as Chris mentions, not a bad idea.

  17. ever8302
    Member
    Posted 1 year ago #

    I did that just now - no luck :( Thank you Floyd and Chris for your help. Turning in now it's almost 12 am here in India. I hope you don't mind if I trouble you later. I appreciate your patience.

  18. mrg2017
    Member
    Posted 1 year ago #

    I'm getting the same redirect problem, and I can't use any url with wp-admin in it, or it redirects to a 404. All the content is still there for viewers to see at http://www.mollysmusic.org/blog/ so I'm really hesitant about replacing files that could break the whole thing. I don't have w3 cache, and I've already tried most of the plugins. What do?

  19. esmi
    Forum Moderator
    Posted 1 year ago #

    @mrg2017: Can you please post your own topic as your problem may be slightly different?

  20. mrg2017
    Member
    Posted 1 year ago #

    Sure. Thanks.

  21. mrg2017
    Member
    Posted 1 year ago #

  22. Russ
    Member
    Posted 1 year ago #

  23. ever8302
    Member
    Posted 1 year ago #

    I changed the file names, deleted w3-total-cache-config-preview.php and .htaccess. However, it's still not working. GoDaddy didn't help either - quite frustrating.

  24. I have seen some instances of this problem where the persistent object cache stored in APC was not being flushed by W3 Total Cache during upgrade. It's always best to disable your caching plugins before doing an update.

    If you are stuck and can't complete the update you can make the database change manually using phpmyadmin or from the command line and changing the db_version in your wp_options table to 21707. This is the only database change from 3.4.1 to 3.4.2

    If you need to manually disable W3 Total Cache remove all the files added to wp-content except for your w3-config.php file ( it holds all your settings ) and delete your .htaccess.

    If you have APC installed on your server then restart Apache or Nginx and php-fpm to clear out the object cache.

    When you re activate the plugin it will put all those files back for you.

Topic Closed

This topic has been closed to new replies.

About this Topic