WordPress.org

Ready to get started?Download WordPress

Forums

After upgrade "success" 2.6.3 to 2.7.1 /wp-admin/post.php = http 403 error (8 posts)

  1. gazouteast
    Member
    Posted 5 years ago #

    Spent the six hours overnight to upgrade 2.6.3 to 2.7.1

    Several bugs -

    I can post a new post, but trying to edit an old post results in an error from wp-admin/post.php

    Forbidden
    You don't have permission to access /blogname/wp-admin/post.php on this server.
    Apache/1.3.27 Server at www.domainname.com Port 80

    File and folder permissions are the same as all my other working blogs (none of which are 2.7.1 and are a mix of 2.6.3 and 2.7.0)
    I'm not sure if this is coming from WP or from the server, or is related to cookie sessions or something else.
    ----
    In 2.7.1, there is a bad oversight in the wp-settings.php in-file help texts -
    It mentions that the DEFAULT secret word from wp-config.php has to be inserted. There is no DEFAULT secret word - so which one of the four secret words has to be used? Please post a help note in the codex and fix this before 2.7.2
    ----
    Turbo does not work with Windows 2000 (our LAN web-connect server is also my admin workstation, so please - no suggestions to upgrade it unless one of you feels like coming to upgrade the whole network (and pay for it)). The entire wp-admin side is slower than a slug on prozac - it was bad enough in 2.6.3 but this is terrible - in short it is bluddy awful to try doing anything, and I'm now looking at having to do a roll-back to 2.6.3.
    Click, then go out for a meal, and come back and maybe the page has loaded = lose the Java and Flash and offer a version that runs like pre-2.5 for speed, after all, it's why we use WP.

    Gaz

  2. Sorry to hear that you are having a rough time with it.

    I'm not sure if this is coming from WP or from the server, or is related to cookie sessions or something else.

    It's coming from your server. 403 not authorized... do you have mod_security enabled on your Apache 1.3.27 server? When WordPress does not like your cookies, it tosses up a different page itself. The plain white 403 page with the server version is from your Apache server.

    I doubt this is it, since it's partially working for you except for editing old posts but double check your file/directory permission and ownerships. If you are running Apache on Windows 2000 I don't know how to do that.

    If you are running on Linux/BSD/UN*X try

    cd /to/your/wordpress/directory
    find . -type f | sed -e's/\ /\\\ /g' | xargs chmod 644
    find . -type d | sed -e's/\ /\\\ /g' | xargs chmod 755

    This will make your files world readable and directories readable by any user. Check your server's error_log for that Apache instance, there might be a clue there. See this article for file permissions.

    Good luck.

  3. gazouteast
    Member
    Posted 5 years ago #

    JD - OK thanks - the server is a hosted php5.something + mySQL 4.something
    they upgraded the php last week so it's possible the mod_security got wiped or modded or something - this particular blog is on a different server to any of the others and I haven't edited a post in the last fortnight before today's attempt after the upgrade.

    wp-admin/post.php is currently 644. I'll bump it 755 and give it a go, then contact the hosts if no joy

    Gaz

  4. gazouteast
    Member
    Posted 5 years ago #

    Nope 754 doesn't work, nor does 755 or 777

    Time to contact the hosts I think

  5. gazouteast
    Member
    Posted 5 years ago #

    Live Help at the hosts just fixed this -

    Quote - "I have just check the error logs and found that the issue with mod security hence uploaded file .htaccess under your eye/wp-admin which resolved such issue "

    Hope it helps others
    Gaz

  6. lostdeviant
    Member
    Posted 5 years ago #

    what did the .htaccess contain that is in/wp-admin?

    I am getting this same error after upgrading from 2.7 to 2.7.1

  7. lostdeviant
    Member
    Posted 5 years ago #

    when I disabled the nonce and other "keys" in wp-congig I was able to login.

  8. lostdeviant
    Member
    Posted 5 years ago #

    ok tested each one and it was the auth key causing the error.

    I went from this
    define('AUTH_KEY', 'put your unique phrase here');

    to this (commented it out with // )
    //define('AUTH_KEY', 'put your unique phrase here');

Topic Closed

This topic has been closed to new replies.

About this Topic