WordPress.org

Ready to get started?Download WordPress

Forums

WP-Piwik
[resolved] After upgrade, Piwik automatically places cookies again (15 posts)

  1. Joost
    Member
    Posted 1 year ago #

    A small bugreport... I use the option to track our visitors without cookies. But after every plugin update, Piwik starts placing cookies again. The solution to this problem is to go to the plugin backend page, and just save the settings again.

    Not a big problem, but I thought I should mention it anyway.

    http://wordpress.org/extend/plugins/wp-piwik/

  2. braekling
    Member
    Plugin Author

    Posted 1 year ago #

    Can yo give me some details about your configuration? Especially if you are using a blog network (and if the plugin is activated in "network mode").

    Is the "disable cookies" option still checked while Piwik is placing cookies again?

  3. braekling
    Member
    Plugin Author

    Posted 1 year ago #

    I bet you use WP-Piwik as a network plugin ;-) In this case your issue will be fixed in 0.9.7.

  4. Joost
    Member
    Posted 1 year ago #

    The disable cookies is still selected when it sets cookies again.

    Piwik settings:

    Using piwik url
    auto config checked
    User agent: Php default

    Tracking:

    Add tracking code selected
    Disable cookies selected
    Track 404 selected
    Use js/index.php selected

    Statistics:

    Piwik default date: today
    Home dashboard: 30 days chart
    Piwik shortcut selected
    Piwik display to administrator & editor

  5. Joost
    Member
    Posted 1 year ago #

    BTW: We do not use network mode (it's no multisite)

  6. braekling
    Member
    Plugin Author

    Posted 1 year ago #

    Please try again after updating to 0.9.7.

  7. Joost
    Member
    Posted 1 year ago #

    Nope, same problem again...

  8. braekling
    Member
    Plugin Author

    Posted 1 year ago #

    At last... fixed in 0.9.8 :D

  9. Joost
    Member
    Posted 1 year ago #

    I hate to spoil your party, but I still have the same problem...

    We appreciate your work, though!

  10. braekling
    Member
    Plugin Author

    Posted 1 year ago #

    Hmmm... I'm not able to reproduce this issue anymore. I'll have a look at this again.

  11. braekling
    Member
    Plugin Author

    Posted 1 year ago #

    Can you describe your update process? Do you use WP's included updater?

    Did you try to reset WP-Piwik before you update?

  12. braekling
    Member
    Plugin Author

    Posted 1 year ago #

    0.9.8.1 is finished. The update should appear in some minutes - I hope this issue is solved definitely.

  13. braekling
    Member
    Plugin Author

    Posted 1 year ago #

    Any feedback regarding this issue?

  14. Joost
    Member
    Posted 1 year ago #

    Hi,

    Sorry for my late reply... First of all, the situation here has changed. The government (Netherlands) declared that you are NOT breaking the cookie law if you place an analytics cookie and don't share the user information with third parties. So we started to set the cookie again, which means that the problem has vanished for us...

    The last time I updated and the problem surfaced I just updated using WP automatic updating process. My settings haven't changed (see top of thread). Going to the front-end the cookie immediately showed again (using ghostery). I then went to the backend and enabled cookies, saved, disabled cookies, saved again. After that the problem was gone again.

  15. braekling
    Member
    Plugin Author

    Posted 1 year ago #

    After I was able to reproduce this issue using 0.9.8, I wasn't able to reproduce it using 0.9.8.1, 0.9.9.0 and 0.9.9.1 again.

    Therefore this issue should be solved now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags