WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] after upgrade: domain redirect causing endless loop (16 posts)

  1. khenjin
    Member
    Posted 6 years ago #

    hi all,

    yesterday i upgraded to the all new version 2.5 (which is really nice btw).

    the only thing is that since then my domain redirects are not working anymore:

    currently i have a domain registred like http://www.the-domain-i-want-to-be-shown.org

    this is redirecting to my actual webspace. that webspace of course has another domain like http://www.i-dont-want-that-domain-to-be-shown.com

    i have created a subdomain like sub.i-dont-want-that-domain-to-be-shown.com which is pointing to the wordpress folder.

    in my wordpress settings i have been using only the first of those domains (which i want to be shown) and that has worked fine until i upgraded.
    now my browser keeps telling me that it was redirected endlessly and aborts the request.
    strangely i still can log in to the admin interface using /wp-admin/.

    only if i change the options to the following it works:

    wordpress adress (URL): http://www.the-domain-i-want-to-be-shown.org
    blog adress (URL): sub.i-dont-want-that-domain-to-be-shown.com

    but now the inital request uses the domain i want to be shown but after clicking on a link changes to the one i dont want to be shown (sic!).

    what do i have to or edit so that wordpress behaves the way it did before?

    thanks for your help in advance.

  2. khenjin
    Member
    Posted 6 years ago #

    anyone? :(

  3. khenjin
    Member
    Posted 6 years ago #

    it seems i have to downgrade again...which i really would not like to. come people, there must be someone who can answer this ;).

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Download this plugin. Install it, activate it.

    http://txfx.net/files/wordpress/disable-canonical-redirects.phps

  5. khenjin
    Member
    Posted 6 years ago #

    thanks, otto!

    that solved it!! great. :D

  6. nprignano
    Member
    Posted 6 years ago #

    Worked for me too. Thanks a lot.

  7. nette
    Member
    Posted 5 years ago #

    how can u activate the plugin if you can't get into the admin panel?

  8. evenstar00
    Member
    Posted 5 years ago #

    how can u activate the plugin if you can't get into the admin panel?

    I'm wondering that too..... :\

    Anyone knows?

  9. ArakonKaizen
    Member
    Posted 5 years ago #

    You can stop the redirect loop by going into the phpMyAdmin panel and changing the settings manually in the wp_options section in the database.

  10. DouglasVB
    Member
    Posted 5 years ago #

    I tried the plugin but it didn't work for me. I am wondering if this is perhaps being caused by having a tilde (~) in my URL. Any thoughts anyone?

  11. dell80
    Member
    Posted 5 years ago #

    I had a problem with redirects to, using wordpress 2.6 with a godaddy subdomain, thanks for the plugin Otto, it's not as pretty as I would like but it's the only working solution I've found so far which allows me to use my subdomain as the blog address without creating a redirect loop.

    Out of curiosity does anyone know the option_name ArakonKaizen was refering to?

  12. nintensity
    Member
    Posted 5 years ago #

    wow, it worked@ thanks dude!

  13. bcreighton
    Member
    Posted 5 years ago #

    @ArakonKaizen- what option_name are you referring to? I can't access my admin screen at all so I wouldn't be able to activate the plugin. I'm also on IIS and never had the fancy permalinks enabled (if that makes a difference).

  14. jbbrwcky
    Member
    Posted 5 years ago #

    Arakon - what option_name? I need to get this fixed and have been trying to get help on here for months now, and this could possibly do it. I'd love to install the plugin, but can't even log in!

  15. jbbrwcky
    Member
    Posted 5 years ago #

    I found this page...
    http://www.magpiebrain.com/blog/2008/06/01/wordpress-site-hacked/

    ... fixed the problem.

  16. HunnyBunny
    Member
    Posted 5 years ago #

    Hey I'm going through the same problem where my site won't redirect.... where do I place the desired code in my panel to let it redirect. It's giving me a LOOP error HELP!!!

Topic Closed

This topic has been closed to new replies.

About this Topic