WordPress.org

Ready to get started?Download WordPress

Forums

After upgrade, can't read comments (11 posts)

  1. scribbler
    Member
    Posted 9 years ago #

    All comments are available for editing from my admin page, but on my actual blog, no comments display. When I click on the link to view comments under and article, I get the article, but no comments after it, and no box for writing comments. Any ideas?

  2. YardOBeef
    Member
    Posted 9 years ago #

    Are you using the stock template or have you edited it in any way?

  3. Matt Mullenweg
    Troublemaker
    Posted 9 years ago #

    You probably didn't update the comment line as the upgrade docs said.

  4. scribbler
    Member
    Posted 9 years ago #

    I've triple-checked, and I made all the changes required by Podz' upgrade instructions. When I switch to the default theme, comments appear. When I switch back to my original theme (which, as best I can tell, I modified correctly according to the Podz instructions), comments disappear.

  5. scribbler
    Member
    Posted 9 years ago #

    For clarification, I modified the wp-comments.php and index.php files from WP 1.2.

  6. scribbler
    Member
    Posted 9 years ago #

    Would I screw everything up if I replaced my theme's comments.php file with the comments.php file from the 1.5 default theme?

  7. Kafkaesqui

    Posted 9 years ago #

    Only the modifications you may have made to it.

  8. litlnemo
    Member
    Posted 9 years ago #

    Do you have your blog running in a subdirectory? We had this problem and I had to go into Options>General and change WordPress address and Blog address to be the same (Before, the WP address was http://slumberland.org/wp/ and the Blog address was http://slumberland.org/). When this was done, the comments reappeared.

  9. miaow
    Member
    Posted 9 years ago #

    I am having exactly the same problem. Only now I can comment and then I get the error:
    Fatal error: Call to undefined function: checkaicode() in /home/blahblah/public_html/wordpress/wp-comments-post.php on line 40

    So I know that I've got to change some code somewhere, but I'm not sure where or what it is! This is taking days!
    :o(
    Beth
    miaow the cat

  10. Anonymous
    Unregistered
    Posted 9 years ago #

    if you have an index.htm in your root directory, delete it.

  11. lukanova
    Member
    Posted 9 years ago #

    checkaicode() is a function from AuthImage plugin. you may have disabled that plugin but the code is still there. remove these lines from wp-comments-post.php, if they are there and your authimage plugin is disabled:

    // AuthImage
    if ( !checkAICode($comment_code) )
    die( __('Error: please enter the valid authorization code.') );

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.