WordPress.org

Ready to get started?Download WordPress

Forums

Co-Authors Plus
[resolved] After update wp to 3.8 the plugin has stop working (12 posts)

  1. Animalejourbano
    Member
    Posted 8 months ago #

    The search function has stop working and the name of the author has been replaced by default by the admin . It is a mess, so I decided to deactivate it until it get to work well with wp 3.8. I really hope this happen soon, 'cause it's a great plugin and I need it a lot.

    http://wordpress.org/plugins/co-authors-plus/

  2. Animalejourbano
    Member
    Posted 7 months ago #

    Any news about this?

  3. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 7 months ago #

    Can you share a screenshot of what you see in 3.8?

  4. swbts
    Member
    Posted 7 months ago #

    Same thing here. Happens in FireFox, Chrome, and Safari (Mac). Only uses author that's logged in. You can click in the field to change the author name but when you move out of the text field is reverts back to the name of the author who's logged in. also, I'm not seeing the link to remove or add additional authors. can share screenshots but not sure how in this forum. thanks.

  5. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 7 months ago #

    Odd. I can't reproduce in my local environment with 3.8

    Can you use http://quick.as/ to produce a screencast of the behavior? Also, to confirm, this bug persists when you've deactivated all other plugins but Co-Authors Plus, correct?

  6. Animalejourbano
    Member
    Posted 7 months ago #

    I assume that the problem is with the plugin itself, 'cause is the only plugin that is not working after the update to 3.8. And was working just fine before the update. Anyway, I'll try to make a screencast as you suggest. I'm really sad about this issue, it's a great plugin and I really need it. Thanks for your answer!

  7. swbts
    Member
    Posted 7 months ago #

    link to what i'm seeing in wordpress 3.8: http://quick.as/qjruneb
    and yes, still doesn't work when I turned other plugins off.

    you can't edit/change the default author that displays when you create the post (the user logged in), and there are no options to remove an author or add multiple. hopefully, this quickcast will let you see what i'm seeing. thanks for your help. I too really like the plugin and the way it previously functioned. something that is very useful. thanks again, Daniel.

  8. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 7 months ago #

    @swbts The "Search for an Author" field is how you add a second author to a post. In your screencast, I didn't see you enter any text there.

    Also, when you search to replace the first author, you do get one result:

    https://dl.dropboxusercontent.com/s/fv4elww9wrbdojt/2014-01-14%20at%203.31%20PM.png

    I imagine the user you're actually trying to search for can't be added to the post. What user role are they, and have you modified any of the user roles / capabilities?

  9. Animalejourbano
    Member
    Posted 7 months ago #

    I was having the same issue that shows swbts in his screencast, but even worse, the users weren't even appearing. It seems to be a role problem: I was trying to assign a "Colaborator" as author. I assume that this was the problem. Am I right? Thanks for your time.

  10. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 7 months ago #

    I was trying to assign a "Colaborator" as author. I assume that this was the problem.

    If the role doesn't have the edit_posts capability, then you're correct. You can change the behavior with the coauthors_edit_author_cap filter.

  11. swbts
    Member
    Posted 7 months ago #

    I may have misunderstood what the plugin could do. I thought you could assign an author to a post even if they didn't have a user role. for the blog in my organization, we have a lot of different guest author/posters. so, they still have to be assigned a role as a user? Thanks!

  12. swbts
    Member
    Posted 7 months ago #

    My apologies for overlooking the Guest Author section in the user area. this fixes my issues. thanks for your time!

Reply

You must log in to post.

About this Plugin

About this Topic