WordPress.org

Ready to get started?Download WordPress

Forums

Attachments
After update to 3.6, cant switch from visual editor to text (11 posts)

  1. vasilescu_anton
    Member
    Posted 1 year ago #

    Whenever I save now the editor view is switched from Text to Visual and the formatting gets lost. Once I disable the Attachment plugin everything works fine again which makes me think that this is a bug in the plugin.

    Can you please let me know what can I do to fix it?

    Thank you!

    http://wordpress.org/plugins/attachments/

  2. Jonathan Christopher
    Member
    Plugin Author

    Posted 11 months ago #

    I will be sure to validate this and if applicable get a fix out in the next release.

  3. Julian Chaniolleau
    Member
    Posted 11 months ago #

    Yes ! got the same problem and... it's really bad :S....
    I hope you will fix that quickly Jonathan! :)

    Thanks !

  4. Jonathan Christopher
    Member
    Plugin Author

    Posted 11 months ago #

    I spent some time trying (and failing) to replicate the issue locally, but if multiple people are seeing it I definitely want to get it resolved quickly. Are either of you able to record a screencast of the issue occurring twice in a row? If you can also switch to Twenty Thirteen and deactivate all other plugins that would be helpful.

  5. Julian Chaniolleau
    Member
    Posted 11 months ago #

    yes... let me do it now

  6. Julian Chaniolleau
    Member
    Posted 11 months ago #

    http://lab.devilcantburn.com/attachement.mp4

    as you can see on the video, if i deactivate the plugin, when i save the change, the Text panel stay activated. if i activate the plugin, it switch automatically to the Visual panel.

    PS: Sorry for the filigree :D !

  7. Jonathan Christopher
    Member
    Plugin Author

    Posted 11 months ago #

    Thank you so much that helps a ton, I misread the original report and I can now replicate the issue locally. This problem will be my highest priority, expect a fix soon.

  8. Jonathan Christopher
    Member
    Plugin Author

    Posted 10 months ago #

    Hi guys, really sorry for the delay on this. I was out of town and had trouble tracking down the real issue. Version 3.5.2 was just pushed to the repo and should fix the issue!

  9. Julian Chaniolleau
    Member
    Posted 10 months ago #

    Hi Jonathan, ;)

    well i just updated the plugin to the version 3.5.2 and it seems to be the same :S ....

    i deactivated the plugin, and reactive it... same.

    :S ...

  10. Jonathan Christopher
    Member
    Plugin Author

    Posted 10 months ago #

    Shoot I'm very sorry about that. The update should resolve the formatting issue but I will continue to research how to avoid the underlying problem, which is caused by JavaScript toggling what the active tab was.

  11. Julian Chaniolleau
    Member
    Posted 10 months ago #

    great ! thank you!

    meanwhile, i will add a trigger to the Text button to switch to the Text tab on load ;)

    Thanks for this cool plugin ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.