WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
After the Deadline Errors (10 posts)

  1. jfairfull
    Member
    Posted 9 months ago #

    When I try to do anything spellcheck with Jetpack, I get this:

    GENERAL
    400
    At: http://kmdgideas.com/skyhigh/blog/wp-admin/admin-ajax.php?action=proxy_atd&url=/checkDocument

    Is it supposed to have something besides "/checkDocument" in the URL parameter? Any help is appreciated! I have all plugins except Jetpack disabled at this point.

    http://wordpress.org/plugins/jetpack/

  2. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 9 months ago #

    Hi there,

    I see 3 issues with your site, any and all of which could be causing this problem. Issue #3 is the most likely culprit.

    1) you are loading jQuery twice, at least on the front-end of your site. I do not know if this is because of your theme or because of a plugin, but in any case, you should only load it once.

    2) your theme or one of your plugins seems to be loading an old version of jQuery instead of using the version that comes bundled with WordPress.

    It can create multiple conflicts with WordPress and with other plugins like Jetpack. You can read more about it here:
    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4#post-3547424

    Try switching to a different theme for a few minutes, and check if that solves the issue; if it does, you'll want to look for the function loading jQuery in your theme's header.php file, or in the functions.php file. Once you find that function, you can remove it and enqueue the proper version of jQuery as explained here:
    http://codex.wordpress.org/Function_Reference/wp_enqueue_script

    If the issue is not related to your theme, please try to disable all your plugins, one at a time, until you find the one that causes the conflict. You can then enqueue jQuery using the method I linked to above.

    If you do not feel comfortable editing PHP files, you can also contact the theme or plugin author and ask them to solve the issue.

    3) the xmlrpc.php file is not returning the correct response. Can you contact your hosting provider and explain to them that we are unable to access your blog via cURL, which is needed in order to use Jetpack on your site.

    You can let them know we tested the following:

    1. Check for access to xmlrpc.php via browser:
    http://kmdgideas.com/skyhigh/blog/xmlrpc.php

    That test returned "XML-RPC server accepts POST requests only." which is a valid result.

    2. Check for access via cURL by running the following command from the command prompt:
    curl -i -H 'Content-Type: text/xml' --data '<?xml version="1.0&"?><methodCall><methodName>demo.sayHello</methodName><params></params></methodCall>' 'http://kmdgideas.com/skyhigh/blog/xmlrpc.php'

    The cURL test returned the following invalid result:

    !DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>400 Bad Request</title>
    </head><body>
    <h1>Bad Request</h1>
    <p>Your browser sent a request that this server could not understand.<br />
    </p>
    <p>Additionally, a 404 Not Found
    error was encountered while trying to use an ErrorDocument to handle the request.</p>
    <hr>
    <address>Apache Server at kmdgideas.com Port 80</address>
    </body></html>

    Please provide the information above to your hosting provider so that they can correct the server settings to allow cURL access.

  3. jfairfull
    Member
    Posted 9 months ago #

    Thanks for your response!

    1) I disabled all plugins except Jetpack and still got the problem.
    2) I installed the Kubrick theme, enabled it and it's still doing it. Currently, I have all plugins except Jetpack disabled and this theme is installed. I will leave it like this for a while, but I may have to switch it at some point.
    3) I contacted the host. They said the command should be sent thusly:

    curl -i -H 'Content-Type: text/xml' --data '<?xml version="1.0"?><methodCall><methodName>demo.sayHello</methodName><params></params></methodCall>' 'http://kmdgideas.com/skyhigh/blog/xmlrpc.php'

    The "&" character is misplaced. Anyway, this command succeeds and the plugin still doesn't work.

    I can send cURL requests with php just fine as well:

    http://kmdgideas.com/skyhigh/curl.php

    ...but I don't know if this is relevant. Does this plugin need to have exec() enabled so it can cURL over a command line? I don't have exec() enabled.

  4. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 9 months ago #

    Hi! I spoke with our developers and they say that your site is giving a 400 bad response when we try to do a cURL php request from our servers while setting the content-type to html/xml. That's causing the AtD to fail, I think. Let your host know that, and le tm eknow what they say.

  5. jfairfull
    Member
    Posted 9 months ago #

    Can you elaborate a little? Do you want me to send the request like this?

    http://kmdgideas.com/skyhigh/curl.png

    This is a request that I sent from my PC to the server, and as you can see: it succeeds. I'm not sure html/xml is a valid content type either? I think these are the only valid types we could be using:

    text/html
    application/xhtml+xml
    text/xml
    application/xml

    I also sent a PHP cURL from a separate server here and this also works:

    http://ingerodev.com/test.php

    I'm not doubting that there's a problem here, but if I go to the host again without a more specific problem, they're just going to do this and blow me off again.

  6. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 9 months ago #

    The developers would like to know if you could send me an admin login for your site so that they can check something? Would that be ok? If so, please send in the login credentials through our contact form, http://jetpack.me/contact-support/ . Make sure to link to this thread. Thanks!

  7. jfairfull
    Member
    Posted 9 months ago #

    Thanks Richard, I submitted that form with access.

  8. jfairfull
    Member
    Posted 9 months ago #

    I'm going to go ahead and revert the template and plugins back to normal because I need to work on this project and I think we've ruled the template and plugins out as possible culprits.

  9. wizard247
    Member
    Posted 4 months ago #

    Any updates on this? Having exactly the same problems. WordPress 3.8.1, twenty fourteen theme and TinyMCE Spellcheck plugin installed. Reinstalled WordPress, deactivated all other plugins. Continue to have the same error message:

    GENERAL
    404
    At: http://stieglitzsisters.com/wp-admin/admin-ajax.php?action=proxy_atd&url=/checkDocument

    Blog: stieglitzsisters.com

    Any ideas - I ran the xmlrpc.php access test which was OK but don't know how to do the curl test.

    Any help would be appreciated.

    Regards,
    Wizard247

  10. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 4 months ago #

    Hi Wizard247,

    Since we can't be entirely certain that your issue and setup is exactly the same as the original poster, could you please start your own thread, as per the Forum Welcome?

    http://wordpress.org/support/plugin/jetpack#postform

    Thank you!

Reply

You must log in to post.

About this Plugin

About this Topic