WordPress.org

Ready to get started?Download WordPress

Forums

After network install, can't access wp-admin, getting wp-signup instead (11 posts)

  1. lumenbeing
    Member
    Posted 3 years ago #

    After struggling for hours with what started out as a n Amazon EC2 AMI by Bitnami, I finally got to the final stages of multi-site activation.

    WordPress gave me the last little bits of code to drop into my wp-config.php and .htaccess file (previously non-existent)

    Then it told me to log in again. After I did, instead of taking my to the backend, I landed here:
    http://echotreemedia.com/wp-signup.php?new=ec2-50-16-250-250.compute-1.amazonaws.com
    and tells me "registration has been disabled"

    Why is this happening?
    At this point I have edited my htpd.conf, /extra/htpd-vhosts.conf, wp-config.php and .htaccess file so as far as I know it could be any of those things.
    Although I suspect its the apache config. Should I paste it in here?

  2. kuld33p
    Member
    Posted 3 years ago #

    check for your redirects.. i think there is some problem with that.. login link seems to be linking to

    http://ec2-50-16-250-250.compute-1.amazonaws.com/wordpress/wp-login.php

    also make sure its the root installation.. not the new site that you added.

  3. Yep. the amazon link is in there somewhere, in some of the tables for the main site. So WP is looking it up as another site.

  4. lumenbeing
    Member
    Posted 3 years ago #

    kuld33p, what do you mean check my redirects? the .htaccess?

    Andrea_r, do you mean that the database base the Amazon string in it somewhere? I'm having a hard time accessing my database because this is EC2 and there is no cPanel. I used a Bitnami AMI which did install phpmyadmin, but for the life of me, I can figure out how to load it. Nor can access MySQL through the terminal via ssh.

    I don't really know what I'm doing with this command line stuff. This is what I've tried so far:

    bitnami@ip-10-243-21-23:~$ mysql -ubitnami -p -h localhost:3306 bitnami_wordpress
    Enter password:
    ERROR 2005 (HY000): Unknown MySQL server host 'localhost:3306' (2)
    bitnami@ip-10-243-21-23:~$ mysql -ubitnami -p -h 10.243.21.23:3306 bitnami_wordpress
    Enter password:
    ERROR 2005 (HY000): Unknown MySQL server host '10.243.21.23:3306' (3)
    bitnami@ip-10-243-21-23:~$ mysql -ubitnami -p -h echotreemedia.com:3306 bitnami_wordpress
    Enter password:
    ERROR 2005 (HY000): Unknown MySQL server host 'echotreemedia.com:3306' (3)
    bitnami@ip-10-243-21-23:~$ mysql -ubitnami -p -h msql.echotreemedia.com bitnami_wordpress
    Enter password:
    ERROR 1130 (HY000): Host '50.16.250.250' is not allowed to connect to this MySQL server
    bitnami@ip-10-243-21-23:~$ sudo mysql -ubitnami -p -h msql.echotreemedia.com bitnami_wordpress
    sudo: mysql: command not found
    bitnami@ip-10-243-21-23:~$ mysql -ubitnami -p -h msql.echotreemedia.com bitnami_wordpress
    Enter password:
    ERROR 1130 (HY000): Host '50.16.250.250' is not allowed to connect to this MySQL server
    bitnami@ip-10-243-21-23:~$ mysql -ubitnami -p -h 50.16.250.250 bitnami_wordpress
    Enter password:
    ERROR 1130 (HY000): Host '50.16.250.250' is not allowed to connect to this MySQL server
    bitnami@ip-10-243-21-23:~$ mysql -u bitnami -p -h 50.16.250.250 bitnami_wordpress
    Enter password:
    ERROR 1130 (HY000): Host '50.16.250.250' is not allowed to connect to this MySQL server

  5. lumenbeing
    Member
    Posted 3 years ago #

    Also, to be clear, I have not added any new sites. Echotreemedia.com is the base site.
    The domain is registered with godaddy. Within Goodaddy's DNS there's an A record that points to the elastic IP (50.16.250.250) which I have assigned to my EC2 instance.
    There is another A record which defines the wildcard. I'm not sure I have that right. Its * points to that same IP. It appeared to be correct though, because before I activated network, I tried various random subdomain urls eg. http://random.echotreemedia.com and they were loading the page correctly.

  6. ericawinter
    Member
    Posted 3 years ago #

    That's the same theme I'm using. I can't get in to my admin page and keep getting 404 errors... maybe it's a coincidence.

  7. lumenbeing
    Member
    Posted 3 years ago #

    Same theme? That's the default theme. It is not a coincidence.

  8. @lumenbeing yes, you will have to look at the main site tables in the db.

  9. lumenbeing
    Member
    Posted 3 years ago #

    Awesome. You were right Andrea. I had to change the site and home tables. Took some doing but I finally figured out how to get phpmyadmin to work. Turns out there was a phpmyadmin.conf file and I had to add 'Allow from all' in there.

  10. lumenbeing
    Member
    Posted 3 years ago #

    Now this is weird. After changing the database, everything worked fine, but I'm not having trouble with permalink. They just don't work. I get 404 everytime. So I figure that must be something to do with the httpd.cnf or httpd-vhost.conf but here's the weird part. Everytime I make a tweak to these files I have to restart Apache to see the effects, but every time I restart Apache, those datebase tables go back to http://ec2-50-16-250-250.compute-1.amazonaws.com for site and URL fields. Then I get locked out again and have to change them again through phpMyAdmin.
    Now I'd really like to solve my permalink problem, but before I can do that I need to know what is overwriting my database when I restart my EC2 instance. There does not even seem to be a Site URL or WordPress directory field in my admin settings anymore after enabling multi-site.

  11. lumenbeing
    Member
    Posted 3 years ago #

    Okay I have resolved myself to the fact that WordPress is just going to change my domain back to the public URL every time I restart the instance. I can live with it.
    But I can't live without permalinks. I need Buddypress to work.
    So the latest thing I've tried is changing my wordpress.conf file.
    to this:
    '<Directory "/opt/bitnami/apache2/htdocs">
    Options Indexes MultiViews +FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>'

    And now the site gives me 403! PLEASE HELP!

Topic Closed

This topic has been closed to new replies.

About this Topic