WordPress.org

Ready to get started?Download WordPress

Forums

After moving from local to a server, login hangs (8 posts)

  1. tpae
    Member
    Posted 3 years ago #

    Hello,

    After trying to move WordPress from local machine to my production machine, I have done the following:

    1. Import my current local database into production database
    2. Updated my wp-config.php file with correct information
    3. Went into phpmyadmin, updated 'siteurl' and 'home' with correct URL
    4. Finally, I was able to see the wordpress site, and everything else works fine.
    5. When I try to log in, however, it hangs. I don't get error messages, or nothing..

    Here's what I did, in my attempt to fix it (unsuccessful):

    1. Re-uploaded wp-login.php file.
    2. clear cookies, cache

    both servers are using IIS7.. any clues?

    Here's my php information...

    System Windows NT myPC-5 6.0 build 6002 (Windows Server 2008 Standard Edition Service Pack 2) i586
    Build Date Dec 9 2010 22:17:30
    Server API CGI/FastCGI
    _SERVER["SERVER_PROTOCOL"] HTTP/1.1
    _SERVER["SERVER_SOFTWARE"] Microsoft-IIS/7.0
    Client API version mysqlnd 5.0.7-dev - 091210 - $Revision: 304625 $

  2. Kevin Cristiano
    Member
    Posted 3 years ago #

    Just changing the siturl and home values in wp_options is not enough in my experience.

    This article Changing the Site Url saved my life a few years ago during an emergency server move and url change.

    I now find the easiest way to get this going(as noted in the article) is to add the following to wp-config.php

    define('WP_HOME','http://example.com');
    define('WP_SITEURL','http://example.com');

    Read the whole article as your posts may need to be updated as well.

  3. tpae
    Member
    Posted 3 years ago #

    I found out that it's related with iis.. I can't seem to log in to anything else with php.

    I can't set up default document for index.php, very strange.

  4. Kevin Cristiano
    Member
    Posted 3 years ago #

    If you cannot log in to anything else with php, can you at least run a php file? Can you create an info.php file and run it:
    <?php phpinfo(); ?>

    Wht version of php, and are you running FastCGI. IIS7 has an update for FastCGI for Server 2008: FastCGI Update

    If you cannot set the default document how have you tried to do this? Can you add a web.config to the root of the site specifying the default document:

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        <system.webServer>
            <defaultDocument>
                <files>
                    <clear />
                    <add value="index.php" />
               </files>
            </defaultDocument>
        </system.webServer>
    </configuration>

    You may have a web.config already, so this would need to be merged with an existing one. Let me know if one already exists.

    Let us know what you find out.

  5. tpae
    Member
    Posted 3 years ago #

    It appears there's an error with the php configuration with iis.. I am not sure what.. It's giving me this error:

    Error Code: 0x800700b7
    Config Error: "There is a duplicate 'system.web.extensions/scripting/scriptResourceHandler' section defined"
    Config file: \\?
    /D:\inetpub\wwwroot\mysite\WebSite\web.config

  6. Kevin Cristiano
    Member
    Posted 3 years ago #

    That error means that there is a conflict (usually a duplicate entry) between web.config files.

    A)
    Follow the path look in d:\inetpub\wwwroot is there a web.config?
    Then look at d:\inetpub\wwwroot\mysite is there another web.config?
    Lastly look at d:\inetpub\wwwroot\mysite\website is there yet another web.config?

    If the web.config files conflict with one another without clearing the parent values the above error can occur.

    B)

    Is the site running under its own application pool? It should be (more secure this way) and you can control the .net version. If the site is only WordPress, set the .NET Framework Version to "No managed Code" in the Application pool advanced Settings. In addition, for php sites, make sure enable 32-bit Applications are set to True.

    Check out these and let me know what you find.

  7. fl@nders
    Member
    Posted 3 years ago #

    I have exactly the same problem. I moved my site from live to local. I can access my website but I don't succeed to login.
    I can type my login and password but then I get a blank page (http://localhost:8888/wp-login.php).

Topic Closed

This topic has been closed to new replies.

About this Topic