WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] After mirgration, Dashboard links redirect back to login screen (4 posts)

  1. PaulaJ
    Member
    Posted 2 years ago #

    I created a client's site on a subdomain of my site using Headway Themes. I then used BackupBuddy to migrate the site to the client's host (also DreamHost).

    I can log in as the admin, but when I click Headway Visual Editor, it redirects to the log-in screen. The URL shows a redirect:

    http://www.makebelievemelodies.com/wp-login.php?redirect_to=http%3A%2F%2Fmakebelievemelodies.com%2F%3Fvisual-editor%3Dtrue&reauth=1

    If I click Posts, I get another redirect:
    http://www.makebelievemelodies.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.makebelievemelodies.com%2Fwp-admin%2Fedit.php&reauth=1

    When I click anything on the dashboard I am redirected to the log-in screen.

    In case the problem was with the www or no www, I checked the hosting control panel, and this is way I checked in the beginning:

    Leave it alone: Both http://www.makebelievemelodies.com/ andhttp://makebelievemelodies.com/ will work.

    What other things might be the cause of this? It seems like if could stop the redirects, most of my problems would be solved.

    Meanwhile, the client is able to post to the site with his Editor account. I logged in as him and the Dashboard links work on the Editor account.

    I set up a second admin account to see if that would help. It generated the same redirects.

    I am not a coder, so I don't know if I'm using the right words to describe the problem. I also posted to the Headway forum and the BackupBuddy forum, but not suggestions yet.

  2. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    It seems the problem is with your theme. Can you switch back to Twenty Eleven and see if the problem persists?

  3. PaulaJ
    Member
    Posted 2 years ago #

    No, if I try to switch themes, I get the log-in screen again.

    The theme worked fine when the site was under development. It got wierd after migration.

  4. PaulaJ
    Member
    Posted 2 years ago #

    It ended up being a super-simple fix. Under Settings, General, the two URLs needed to be the same.

Topic Closed

This topic has been closed to new replies.

About this Topic