WordPress.org

Ready to get started?Download WordPress

Forums

All In One WP Security & Firewall
[resolved] After installing and change my table prefix using the plugin cant login (17 posts)

  1. anown2
    Member
    Posted 3 months ago #

    Good day everyone here is the scenario.

    I installed the plug in and i changed my table prefix using the plug in and after that every time i log in it always say You do not have sufficient permissions to access this page. I deleted the plugin folder using my ftp hoping it will be fix and right now I can't access it still. Searching for the answer over the internet is not helping me out,

    Someone help me with this problem please, thank you

    https://wordpress.org/plugins/all-in-one-wp-security-and-firewall/

  2. mbrsolution
    Member
    Posted 3 months ago #

    Hi anown2, try the following URL.

    Let me know if that helps you.

    Kind regards

  3. anown2
    Member
    Posted 3 months ago #

    Hello mbr,

    I can't follow the tutorial written in the url. I cant find that back up though.

  4. mbrsolution
    Member
    Posted 3 months ago #

    Hi anown2, have you carried the following in your .htaccess file?

    1. Open the .htaccess file with a text editor. If the file does not have a .txt extension (which it shouldn’t at this point), you may have to open the text editor first and use the File >> Open… command, rather than double-click the file.

    2. Locate the “# BEGIN All In One WP Security” and “# END All In One WP Security” lines and remove all lines in between (and including) those lines.

    3. Save the file.

    4. If you downloaded the file upload the file again to your server. In the same path you downloaded the file from.

    Regards

  5. anown2
    Member
    Posted 3 months ago #

    I can't find such line in my htaccess file. All i see is

    # BEGIN WordPress
    the lines here

    # END WordPress

  6. mbrsolution
    Member
    Posted 3 months ago #

    Hi, did you manage to disable the plugin?

  7. wpsolutions
    Member
    Plugin Author

    Posted 3 months ago #

    @anown2,
    Were there any errors when you ran the DB prefix change feature?

    Did you do a backup as recommended by the instructions?

    Can you please log into PHPMyAdmin and do the following:

    1) firstly check if the tables in general have the new DB prefix?

    2) Then click on the "usermeta" table and look at the following entries:

    <dbprefix>_capabilities
    <dbprefix>_user_level
    <dbprefix>_user-settings
    <dbprefix>_user-settings-time
    <dbprefix>_dashboard_quick_press_last_post_id

    Do these entries contain the new or old <dbprefix>?

    If they have the old prefix, then change them to the new prefix.

  8. anown2
    Member
    Posted 3 months ago #

    @mbr

    hello, I deleted the plugin folder in my FTP since I can't access my wp-admin anymore still problem not solved.

    @wpsolutions
    Hello

    I can't login in phpmyadmin anymore because everytime I login with my admin account it keeps on giving me You do not have sufficient permissions to access this page.

  9. mbrsolution
    Member
    Posted 3 months ago #

    Hi @anown2 in regards to your comment...

    I can't login in phpmyadmin anymore because everytime I login with my admin account it keeps on giving me You do not have sufficient permissions to access this page.

    That means that you have locked yourself from your server and can't log into Cpanel if that is your environment. That is where you will be able to access PHPMyAdmin. You will have to contact your server administrator to fix this issue for you.

    Regards

  10. anown2
    Member
    Posted 3 months ago #

    Sorry for confusion I was really sleepy during my last reply I thought that phpmyadmin is my wp-admin sorry for that.

    @wpsolutions
    I checked the tables and it is correct it changed to the new one.

  11. mbrsolution
    Member
    Posted 3 months ago #

    Hi @anown2, is your issue now resolved?

    Regards

  12. anown2
    Member
    Posted 3 months ago #

    @mbrsolution

    hello thank you for your concern sir as of now it is not yet resolved.

  13. wpsolutions
    Member
    Plugin Author

    Posted 2 months ago #

    You didn't answer all of the questions I asked you in my last response?

    Were there any errors when you ran the DB prefix change feature?
    Did you do a backup as recommended by the instructions?

    I checked the tables and it is correct it changed to the new one

    Did you also open the usermeta table and look inside it for the entries I listed in my last response in point 2)?

  14. anown2
    Member
    Posted 2 months ago #

    @wpsolutions
    sorry for the very late reply sir.

    Were there any errors when you ran the DB prefix change feature?

    As I recall I saw an error but I forgot exactly what was it :(

    Did you do a backup as recommended by the instructions?
    I didn't back up :(

    in response to number 2 sir, yes it to the new one.

  15. anown2
    Member
    Posted 2 months ago #

    I guess no one want to help me out with this one

  16. wpsolutions
    Member
    Plugin Author

    Posted 2 months ago #

    Hi,
    It is difficult to troubleshoot your issue without more information.
    Regarding the error log I asked you about you said you "forgot exactly what it was".
    Next time please try to be more careful when collecting information regarding errors etc.

    In the meantime check the plugin log file and also the server logs to see if the error is recorded there and let us know if you find anything.

  17. anown2
    Member
    Posted 2 months ago #

    Sorry for disturbing anyways.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.