WordPress.org

Ready to get started?Download WordPress

Forums

After installation, comment counts are all (0) (13 posts)

  1. spackletoe
    Member
    Posted 8 years ago #

    Even posts that have comments attached to them, the comment count is zero. Is there any way, short of adding a comment to each post and removing it to refresh the count, to have wordpress re-count the comments for each post?

    Site is here.

    Thanks!

    -spack

  2. schestowitz
    Member
    Posted 8 years ago #

    Try emptying the cache. This is a common problem that may or may not be resolved by clearing the cache. Some people reported this to happen after importing posts, but others just saw this behaviour after a simple upgrade.

  3. nathanielstern
    Member
    Posted 8 years ago #

    i had the same problem and fixed it in mine:
    http://trac.wordpress.org/ticket/2159

  4. Mazalien
    Member
    Posted 8 years ago #

    I have the same problem.So I have re-open that thicket (ticket 2159) because
    it works only when you re-edit a comment and re-save it, then it start count again. So lets wait and see what the devolopers do about it... Greetings

  5. schestowitz
    Member
    Posted 8 years ago #

    It's a known issue. I have seen it at least 4 times and I don't even hang around the forums much. I can't change the severity of bug reports and I believe that improper count is not 'critical' or 'major'. It will be fixed shortly, I hope.

  6. Heliologue
    Member
    Posted 8 years ago #

    I'm having the same issue; comment counts seem not to update (although the behavior is sporadic). "Editing" a comment correctly updates the count, but certainly this isn't an ideal fix.

  7. schestowitz
    Member
    Posted 8 years ago #

    I believe it's being worked on and has maybe been resolved already. I should only point out that several people resolved the problem by disabling SpamKarma or upgrading to version 2.1 (of SpamKarma, not WordPress).

  8. citeewurkor
    Member
    Posted 8 years ago #

    Don't forget to install the plugin for SK, too.
    This thread is good.

  9. marginwalker
    Member
    Posted 8 years ago #

    Ive upgraded to SK2.1 Beta & the WP2Compatability plugin. Still no fix :-(

  10. priv
    Member
    Posted 8 years ago #

    2.1 Beta haven't fix the comment_count field, for now you need to use wp2 compatability plug-in, also the compatability plug-in is to place in SK2/sk2_plugins folder.

    And also, the plug-in will not fix the comment_count that already came in, it will only fix the comment_count after install the fix.

  11. citeewurkor
    Member
    Posted 8 years ago #

    marginwalker, be sure the compatibility plugin is enabled from the Spam Karma options page.
    I've heard in some instances you have to run comments through the compatibility plugin to get them counted. But I haven't tried this (because I didn't need to), so it may or may not work for you.

  12. marginwalker
    Member
    Posted 8 years ago #

    I have it enabled.

  13. citeewurkor
    Member
    Posted 8 years ago #

    On your Spam Karma dashboard go to "approved commentes"
    Select all the comments, and in the filter section select "run selected entries" through and select the "wp2-compatibiltiy" plugin. Click "run selected entries."

    I don't know if this works, but I've heard of people having success with this method.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags