WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] after enabling multisite, my-sites.php gives empty page (22 posts)

  1. Frits1980
    Member
    Posted 4 years ago #

    In WP 3.0 Alpha

    After doing all settings in wp-config.php and .htaccess I get the new option my sites in my dashboard, as I was used to in MU. But when I click it it gives an empty page.

    Anyone ideas?

  2. MichaelH
    Member
    Posted 4 years ago #

    There were (or are) some problems but see if Andrea's info here helps:
    http://codex.wordpress.org/User:Andrea/Create_A_Network

  3. Frits1980
    Member
    Posted 4 years ago #

    Hi MichaelH,

    Followed the whole tut step by step, just to be shure I didn't screw up the first time... But still nothing.

    Other thing I came up with. At the end of the tut Andrea I talking about a menu item called: "Super admin"
    I only get "My sites" as a child item of the dashboard.
    When I press that I still get the empty page...

    I also found out that the appearances page is screwed after doing this.
    As seen in the screendump: Screendump

    Thank you for your help.

  4. Frits1980
    Member
    Posted 4 years ago #

    Ok. Dived into the code and found the solution to this problem.

    When you edit the wp-config.php file to put in the code for the multisite, make shure you add those lines before these lines:

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Otherwise it won't work due to missing ms-functions.php file.

  5. I just upgraded to the latest trunk, then I undid the enabled network.

    define ('WP_ALLOW_MULTISITE', true ) ;

    Should be added to the wp-config.php to show you the network menu item under Tools.

    THEN, you have to go through the network setup and add what it tells you.

    After that, a Super Admin menu shows up when you refresh your admin screen. you must be logged in as the main admin for the blog.

    I'll run through this again this afternoon.

  6. Must'va had a glitchy version. worked fine for me.

  7. lokrin2000
    Member
    Posted 4 years ago #

    http://wordpress.org/support/topic/377729?replies=2

    I'm still having the same problem as listed in the above thread. I've double checked everything in this thread including the link listed above.

    I have the my sites link and I've updated the wp-config.php and .htaccess files and I still get the same error message.

  8. Frits1980
    Member
    Posted 4 years ago #

    @Andrea, it worked fine after putting the code in de wp-config file right before the require of the wp-settings.php file.
    I expect developers make this just like I used in wordpress on official release. With one push on a button, instead of editing php files...

    @lokrin2000, I didn't use admin as first user and still it worked. So I don't think that could be the reason of your problems. I think you still have the same problems as I had. Because all the functions your wordpress can't find are located in the ms-functions.php file. Which is called in the wp-settings.php file.
    Can you make sure the wp-settings.php file is called after your multisite settings in the wp-config.php file.

  9. lokrin2000
    Member
    Posted 4 years ago #

    I had
    require_once(ABSPATH . 'wp-settings.php');
    at the beginning of the multisite lines in wp-config.

    Everything is ok now. Thanks.

  10. cinematic
    Member
    Posted 4 years ago #

    I put
    require_once(ABSPATH . 'wp-settings.php');
    before
    define ('WP_ALLOW_MULTISITE', true ) ;
    Then I couldn't login any more and got the message
    "You don't have sufficient permissions to do that."

    After installing the network settings everything worked fine with this line added at the beginning of the multisite lines.

  11. jamk
    Member
    Posted 4 years ago #

    I had the same problem as here: pages rendered blank or only semi-rendered. After moving the line require_once(ABSPATH . 'wp-settings.php'); to the end of the wp-config.php file, where it now resides right after define ('WP_ALLOW_MULTISITE', true); and the rest of the multisite-code, the problem was fixed.

    IMO, Andrea's (otherwise very good) document doesn't mention this. Maybe it should?

  12. That's an interesting problem. I say that because in wp-config-sample.php (and in all builds of WP I've ever seen), the last few lines of the file look like this:

    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
            define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Now, that implies, to ME at least, that any changes you make should ALWAYS happen above that section. Perhaps that needs to be made more explicit: DO NOT EDIT OR ADD LINES BELOW THIS!

  13. .. and further above there's an inline comment that says "add your extra stuff here below this line" or similar.

    I'm paraphrasing here. ;)

    I could add a remind to not add these to the end of the file though. A full create a network page now exists in the codex. (thanks whoever bumped it live :) )

  14. thecoup
    Member
    Posted 4 years ago #

    it might make sense to include the allow multisite line by default, disabled as a comment. with a statement above that says to remove //. that way nobody would put it in the wrong place! (saving the forums a lot of heartache)

    /**
     * Multisite
     * Remove // below to begin Multisite setup.
     * Add config provided by WP immediately below.
     */
    // define ('WP_ALLOW_MULTISITE', true ) ;
  15. Wouldn't help anyone doing upgrades, though.

  16. If you look back far enough in trac, things like that *were* in there, but it was decided to remove it because the majority of users don't need it.

  17. hypothesard
    Member
    Posted 3 years ago #

    8 month later I managed to encounter the same problem
    maybe worse because the Url loaded up fully, but there was absolutly no code at all (blank source page and inspector showing nothing loaded either except the chit-chat between the browser and the webhost)
    How?

    Simply by not having installed the default theme (twentyten) on the server
    but The theme was still registerd as present in the database

    Stupid huh?

    Here It is !

    There should be a fall back mechanism, picking up the theme avalaible if the refered one does not exist anymore on the website (which was my case with twentyten)

  18. There is a way to do that.

    define('WP_DEFAULT_THEME', 'theme-folder-name');

    Change your default to whatever you want it be. But yes, by default WP looks for Twenty Ten. It has to look for A theme, after all.

  19. hypothesard
    Member
    Posted 3 years ago #

    Well I chose WP to not have my head at/in the CODE,
    I fought for few hours with this, then searched for another few hours to finally not find the solution, but just the time for my brain to cool down, then only after a night of jerking with WP I found that previewing a theme finally showed up the site (I even tried to append the parameter to the permalinks LOL => doesn't work)

    WordPress may be the easier-most-customizable blogging plateform, but It's more and more like Android : a mediocre implementation of a good idea (Linux/GPL Code for the rest of us on a given plateform [the Web for WP])

    But yes, by default WP looks for Twenty Ten. It has to look for A theme, after all.

    with all this php code, there should be a way to list the themes actually installed before setting one up.
    and Heck, even copy-paste the theme setting from the main site, as It is present, otherwise I wouldn't have been able to even log in the main admin page to begin with.

    In my case I pushed a button in my Web Host Console to do an auto Install of WP 2.9 (I didn't wanted to deal with their backward PHPMyAdmin selector, but I had to in the end)
    So the default one was from 2.9 and it wasn't TwentyTen but the OLD-OLD one named … “Default Theme” [based on the Kubrick theme]

    Cheers

  20. There will always be some code savvy required for any website :) No way around that, so you're going to have to have your head in it now and again.

    If you're using multisite, it defaults to assume you have a bog-standard install, and have left the theme alone. Maybe in the future there will be a nice GUI to let you pick a default theme, but right now, it's a bit of a manual process, so at least now you know.

    And yes, Twenty Ten replaced Kubrick. This was posted all over the place when 3.0 came out.

  21. hypothesard
    Member
    Posted 3 years ago #

    Is my english that Bad?

    I explained in which context I got stuk with the 2.9 default theme [resulting in BLANK (so NO source code, NO error message, NOTHING)]
    Detailing the every day scenario encoutered by zillion of users, and It's still MY fault?

    Seriously?

    Big Post-scriptum :
    Between that kind of disregard for the NORMAL user (the intended target of wordpress if I recall correctly) and the non-answering to a specific question sending the user to a phantom thread, no wonder why the OpenSource community got Its Freetard nickname…

    I'm sorry for being such a helpless code-impaired person, To be frank, I do work every days with developpers, I can read and talk about code, It's just that compaired to those guys, each Time I try, do and solve a problem [code related] I feel like an impostor and a slow one (especially compared to our Igor&Gritchka programming tandem, who where also blessed with photgraphic memory in addition of being Real twins).

    Why?
    — Because I'm a Graphic designer, not a programmer!
    Fortunately, I'm a dying race and, with more and more talented Graphic artists/designer also able to handle code, you'll soon have a quiet forum.

    Untill then, you'll have and already have to do deal with idiotic posters like myself with impossible scenarios to figure out, and some times simpler doable solutions on the software side than the typical “You can type It in a shell ! Duh !”

  22. You have a bit of a weird signal to noise ratio (there's too much non-helpful info in your posts, like about your job, the programing twins etc), which makes it hard for us to sort out what the question really is.

    You had a pretty weird and rare problem. Is it resolved now? Sounds like, but you're still venting so I'm not really sure and I want to BE sure, so you have an up and running since.

    But three things.
    1) If you're not using 3.1 RC 2, then you actually should make a NEW post in the multisite forum.
    2) We can't be all things for all people, as much as we try, and I'm sorry you're having a shit time of it.
    3) There will still always be some coding knowledge needed for any website. Open source or closed. And there will always be a need for graphic designers.

    S where are we NOW? If you're just ranting, I'll let you be :) if you need help about 3.0.4 with multisite, please post in the multisite forum.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.