WordPress.org

Ready to get started?Download WordPress

Forums

After custom permalinks, clicking on post title redirects to home page of websit (2 posts)

  1. suehutton
    Member
    Posted 5 years ago #

    I've just installed WP 2.7 today and all seemed to be going well until I tried to activate custom Permalinks.

    I've got in a muddle with .htaccess files and permissions. Nowhere is very explicit about what permission is actually required for a .htaccess file.

    Furthermore, .htaccess files of different kinds can be found in the site root and the blog root. It's all rather confusing.

    I finally seemed to manage to install custom permalinks, and sure enough, the title of my first post appeared as a clickable link. Except that when I clicked on it, it took me to the error 404 page of my website, without any CSS.

    This is the code in my .htaccess file which I have uploaded to the blog directory

    '<IfModule mod_rewrite.c>'
    'RewriteEngine On'
    'RewriteBase /sooznooz/'
    'RewriteCond %{REQUEST_FILENAME} !-f'
    'RewriteCond %{REQUEST_FILENAME} !-d'
    'RewriteRule . /wp7/index.php [L]'
    '</IfModule>'

    I haven't got any ReWriteEngine code in the .htaccess file in the root of my website.

    My home page is 'www.suehutton.co.uk' and the blog is at 'www.suehutton.co.uk/sooznooz/'

    I have had to disable the custom settings in Permalinks for the time being.

    I had installed the SuperCache plugin, but that seemed to make things worse than ever, and it wasn't clear about what file permissions were needed. So I have deactivated Super Cache.

    My web host seems to have finally loaded mod_rewrite. The fact that it hadn't two years ago was the principal reason for my not having installed WP on my website earlier.

    You'll find phpinfo at 'http://www.suehutton.co.uk/phpinfo.php'

    I would be very grateful for feedback.

  2. suehutton
    Member
    Posted 5 years ago #

    Just to let you know that I have done a complete re-install of WordPress, activated Permalinks but have NOT installed the WPSuperCache plug in.

    Fingers crossed, it seems to work now.

    There's still a problem about WP writing to the .htaccess file. I have put .htaccess files with the recommended code in both the blog directory and the wp-admin directory. I don't know which one is needed.

    I changed the permissions to 777 for the .htaccess files and the permissions on the sub-directories in the blog directory to 755. I noticed that the permissions had been set to 2755. I have no idea what that means and why that should be.

Topic Closed

This topic has been closed to new replies.

About this Topic